summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer3.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-02 14:23:00 +0200
committerRemi Collet <remi@remirepo.net>2021-09-02 14:23:00 +0200
commit0a9dfd73fec0090ac65e3b77425b06c2ae632b3c (patch)
tree89ae08b18025a5e2b2240740a32fa19a12702c42 /php-cs-fixer3.spec
parentb4fcc4e0ba9bd8678611d17e87bc1f68407e0eaf (diff)
update to 3.1.0
add dependency on symfony/polyfill-php81
Diffstat (limited to 'php-cs-fixer3.spec')
-rw-r--r--php-cs-fixer3.spec19
1 files changed, 14 insertions, 5 deletions
diff --git a/php-cs-fixer3.spec b/php-cs-fixer3.spec
index 6d52ab2..d824e4c 100644
--- a/php-cs-fixer3.spec
+++ b/php-cs-fixer3.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 990b979379502feb7f393d6c9aa36cc9b9765f24
+%global gh_commit cf4cedb9e8991c2daa94a756176d81bf487e4c4b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -27,7 +27,7 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer%{major}
-Version: 3.0.2
+Version: 3.1.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -53,12 +53,14 @@ BuildRequires: (php-composer(composer/semver) >= 3.2 with php-co
BuildRequires: (php-composer(composer/xdebug-handler) >= 2.0 with php-composer(composer/xdebug-handler) < 3)
BuildRequires: (php-composer(doctrine/annotations) >= 1.12 with php-composer(doctrine/annotations) < 2)
BuildRequires: (php-composer(sebastian/diff) >= 1.4 with php-composer(sebastian/diff) < 2)
-# remirepo:6
+BuildRequires: (php-composer(symfony/polyfill-php81) >= 1.23 with php-composer(symfony/polyfill-php81) < 2)
+# remirepo:7
%else
BuildRequires: php-composer-semver3 >= 3.2
BuildRequires: php-composer-xdebug-handler2 >= 2.0
BuildRequires: php-doctrine-annotations >= 1.12
BuildRequires: php-phpunit-diff >= 1.4
+Requires: php-symfony/polyfill >= 1.23
%endif
BuildRequires: php-symfony4-console >= 4.4.20
BuildRequires: php-symfony4-event-dispatcher >= 4.4.20
@@ -142,7 +144,8 @@ BuildRequires: php-fedora-autoloader-devel
# "symfony/filesystem": "^4.4.20 || ^5.0",
# "symfony/finder": "^4.4.20 || ^5.0",
# "symfony/options-resolver": "^4.4.20 || ^5.0",
-# "symfony/polyfill-php72": "^1.22",
+# "symfony/polyfill-php72": "^1.23",
+# "symfony/polyfill-php81": "^1.23",
# "symfony/process": "^4.4.20 || ^5.0",
# "symfony/stopwatch": "^4.4.20 || ^5.0"
# raised to 7.2 to avoid the polyfill
@@ -155,12 +158,14 @@ Requires: (php-composer(composer/semver) >= 3.2 with php-co
Requires: (php-composer(composer/xdebug-handler) >= 2.0 with php-composer(composer/xdebug-handler) < 3)
Requires: (php-composer(doctrine/annotations) >= 1.12 with php-composer(doctrine/annotations) < 2)
Requires: (php-composer(sebastian/diff) >= 1.4 with php-composer(sebastian/diff) < 2)
-# remirepo:6
+Requires: (php-composer(symfony/polyfill-php81) >= 1.23 with php-composer(symfony/polyfill-php81) < 2)
+# remirepo:7
%else
Requires: php-composer-semver3 >= 3.2
Requires: php-composer-xdebug-handler2 >= 2.0
Requires: php-doctrine-annotations >= 1.12
Requires: php-phpunit-diff >= 1.4
+Requires: php-symfony/polyfill >= 1.23
%endif
Requires: php-symfony4-console
Requires: php-symfony4-event-dispatcher
@@ -227,6 +232,7 @@ cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Autoload::addPsr4('PhpCsFixer\\', __DIR__);
\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Symfony/Polyfill/autoload.php',
'%{php_home}/Composer/Semver3/autoload.php',
'%{php_home}/Composer/XdebugHandler2/autoload.php',
'%{php_home}/Doctrine/Common/Annotations/autoload.php',
@@ -339,6 +345,9 @@ exit $ret
%changelog
+* Thu Sep 2 2021 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+- add dependency on symfony/polyfill-php81
* Thu Aug 5 2021 Remi Collet <remi@remirepo.net> - 3.0.2-1
- update to 3.0.2