summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer-phpunit-constraint-xmlmatchesxsd.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-cs-fixer-phpunit-constraint-xmlmatchesxsd.spec')
-rw-r--r--php-cs-fixer-phpunit-constraint-xmlmatchesxsd.spec48
1 files changed, 32 insertions, 16 deletions
diff --git a/php-cs-fixer-phpunit-constraint-xmlmatchesxsd.spec b/php-cs-fixer-phpunit-constraint-xmlmatchesxsd.spec
index 6403099..d9c6ee7 100644
--- a/php-cs-fixer-phpunit-constraint-xmlmatchesxsd.spec
+++ b/php-cs-fixer-phpunit-constraint-xmlmatchesxsd.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-cs-fixer-phpunit-constraint-xmlmatchesxsd
#
-# Copyright (c) 2018 Remi Collet
+# Copyright (c) 2018-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 5d67c189ca4d2d63bf31fd62ede0977b24a87232
+%global gh_commit 92e0ca8fd30b257a993a66511198267ca7d9d8eb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner PHP-CS-Fixer
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{pk_vendor}-%{pk_project}
-Version: 1.0.1
+Version: 1.1.0
Release: 1%{?dist}
Summary: Constraint for testing XML against XSD
@@ -36,19 +36,22 @@ BuildRequires: php(language) >= 5.5
BuildRequires: php-dom
BuildRequires: php-libxml
# From composer.json, "require-dev": {
-# "johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
-# "symfony/phpunit-bridge": "^3.2.2 || ^4.0"
+# "johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
+# "symfony/phpunit-bridge": "^3.2.2 || ^4.0"
# ignore phpunit listeners
+%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
+BuildRequires: phpunit8
+%endif
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
BuildRequires: phpunit7
%endif
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(phpunitgoodpractices/polyfill) >= 1.0 with php-composer(phpunitgoodpractices/polyfill) < 2)
+BuildRequires: (php-composer(phpunitgoodpractices/polyfill) >= 1.1 with php-composer(phpunitgoodpractices/polyfill) < 2)
BuildRequires: phpunit6 >= 6.4.3
# remirepo:3
%else
-BuildRequires: php-phpunitgoodpractices-polyfill
+BuildRequires: php-phpunitgoodpractices-polyfill >= 1.1
%endif
BuildRequires: php-composer(phpunit/phpunit) >= 5.7.23
# Autoloader
@@ -56,21 +59,24 @@ BuildRequires: php-fedora-autoloader-devel
%endif
# From composer.json, "require": {
-# "php": "^5.5 || ^7.0",
-# "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.0",
-# "phpunitgoodpractices/polyfill": "^1.1"
+# "php": "^5.5 || ^7.0",
+# "ext-dom": "*",
+# "ext-libxml": "*",
+# "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.0 || ^8.0",
+# "phpunitgoodpractices/polyfill": "^1.1"
Requires: php(language) >= 5.5
+Requires: php-dom
+Requires: php-libxml
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(phpunitgoodpractices/polyfill) >= 1.0 with php-composer(phpunitgoodpractices/polyfill) < 2)
+Requires: (php-composer(phpunitgoodpractices/polyfill) >= 1.1 with php-composer(phpunitgoodpractices/polyfill) < 2)
# remirepo:3
%else
-Requires: php-phpunitgoodpractices-polyfill
+Requires: php-phpunitgoodpractices-polyfill >= 1.1
%endif
# ignore phpunit dep, package using it will run the proper phpunit command (and autoloader)
# From phpcompatinfo report for version 1.0.0
-Requires: php-dom
-Requires: php-libxml
+# nothing
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -86,8 +92,6 @@ Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-rm src/.gitkeep
-
cat << 'EOF' | tee src/autoload.php
<?php
/* autoloader for %{name} */
@@ -144,6 +148,13 @@ if [ -x %{_bindir}/phpunit7 ]; then
fi
done
fi
+if [ -x %{_bindir}/phpunit8 ]; then
+ for cmd in php php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit8 --verbose || ret=1
+ fi
+ done
+fi
exit $ret
%else
: Test suite disabled
@@ -159,6 +170,11 @@ exit $ret
%changelog
+* Tue Mar 26 2019 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+- raise dependency on phpunitgoodpractices/polyfill 1.1
+- allow PHPUnit 8
+
* Mon Jun 11 2018 Remi Collet <remi@remirepo.net> - 1.0.1-1
- update to 1.0.1 (no change)