summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-06-11 07:59:00 +0200
committerRemi Collet <remi@remirepo.net>2018-06-11 07:59:00 +0200
commit6c4bac08fcb995b5480b7b262bbf630f13414211 (patch)
tree0cbf33b8036ada907dedc46b1fb43ae0cd3640c1
parent3deabde01abd64bd238d6c644ba164387178b378 (diff)
update to 1.0.1 (no change)
-rw-r--r--composer.json3
-rw-r--r--php-cs-fixer-phpunit-constraint-xmlmatchesxsd.spec12
2 files changed, 8 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index aad7516..54b9363 100644
--- a/composer.json
+++ b/composer.json
@@ -15,14 +15,13 @@
"require": {
"php": "^5.5 || ^7.0",
"phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.0",
- "phpunitgoodpractices/polyfill": "^1.0"
+ "phpunitgoodpractices/polyfill": "^1.1"
},
"conflict": {
"hhvm": "*"
},
"require-dev": {
"johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
- "phpunitgoodpractices/traits": "^1.3.2",
"symfony/phpunit-bridge": "^3.2.2 || ^4.0"
},
"config": {
diff --git a/php-cs-fixer-phpunit-constraint-xmlmatchesxsd.spec b/php-cs-fixer-phpunit-constraint-xmlmatchesxsd.spec
index e958798..6403099 100644
--- a/php-cs-fixer-phpunit-constraint-xmlmatchesxsd.spec
+++ b/php-cs-fixer-phpunit-constraint-xmlmatchesxsd.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 076e7645a0b93f981922dfe5d842e81540a05c92
+%global gh_commit 5d67c189ca4d2d63bf31fd62ede0977b24a87232
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner PHP-CS-Fixer
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{pk_vendor}-%{pk_project}
-Version: 1.0.0
+Version: 1.0.1
Release: 1%{?dist}
Summary: Constraint for testing XML against XSD
@@ -37,7 +37,6 @@ BuildRequires: php-dom
BuildRequires: php-libxml
# From composer.json, "require-dev": {
# "johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
-# "phpunitgoodpractices/traits": "^1.3.2",
# "symfony/phpunit-bridge": "^3.2.2 || ^4.0"
# ignore phpunit listeners
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
@@ -59,7 +58,7 @@ BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
# "php": "^5.5 || ^7.0",
# "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.0",
-# "phpunitgoodpractices/polyfill": "^1.0"
+# "phpunitgoodpractices/polyfill": "^1.1"
Requires: php(language) >= 5.5
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -120,7 +119,7 @@ require '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
: Disable the listeners
-sed -e 's/listeners/nolisteners/' phpunit.xml.dist >phpunit.xml
+sed -e '/<listeners>/,/<\/listeners>/d' phpunit.xml.dist >phpunit.xml
: Run upstream test suite with each available phpunit version
ret=0
@@ -160,6 +159,9 @@ exit $ret
%changelog
+* Mon Jun 11 2018 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- update to 1.0.1 (no change)
+
* Mon Jun 4 2018 Remi Collet <remi@remirepo.net> - 1.0.0-1
- initial package, version 1.0.0
- https://github.com/PHP-CS-Fixer/phpunit-constraint-xmlmatchesxsd/issues/2