summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer-phpunit-constraint-isidenticalstring.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-cs-fixer-phpunit-constraint-isidenticalstring.spec')
-rw-r--r--php-cs-fixer-phpunit-constraint-isidenticalstring.spec41
1 files changed, 27 insertions, 14 deletions
diff --git a/php-cs-fixer-phpunit-constraint-isidenticalstring.spec b/php-cs-fixer-phpunit-constraint-isidenticalstring.spec
index d7e5e2d..0718df5 100644
--- a/php-cs-fixer-phpunit-constraint-isidenticalstring.spec
+++ b/php-cs-fixer-phpunit-constraint-isidenticalstring.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-cs-fixer-phpunit-constraint-isidenticalstring
#
-# Copyright (c) 2018 Remi Collet
+# Copyright (c) 2018-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 3bdd62bec7c76cf90e8eb5227ec0eab5e3246141
+%global gh_commit 94e6d1032557253892b4797bc8b6262aac72d5f9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner PHP-CS-Fixer
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{pk_vendor}-%{pk_project}
-Version: 1.0.1
+Version: 1.1.0
Release: 1%{?dist}
Summary: Constraint for testing strings considering not-same line endings
@@ -35,19 +35,22 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.5
BuildRequires: php-pcre
# From composer.json, "require-dev": {
-# "johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
-# "symfony/phpunit-bridge": "^3.2.2 || ^4.0"
+# "johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
+# "symfony/phpunit-bridge": "^3.2.2 || ^4.0"
# ignore phpunit listeners
+%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
+BuildRequires: phpunit8
+%endif
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
BuildRequires: phpunit7
%endif
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(phpunitgoodpractices/polyfill) >= 1.0 with php-composer(phpunitgoodpractices/polyfill) < 2)
+BuildRequires: (php-composer(phpunitgoodpractices/polyfill) >= 1.1 with php-composer(phpunitgoodpractices/polyfill) < 2)
BuildRequires: phpunit6 >= 6.4.3
# remirepo:3
%else
-BuildRequires: php-phpunitgoodpractices-polyfill
+BuildRequires: php-phpunitgoodpractices-polyfill >= 1.1
%endif
BuildRequires: php-composer(phpunit/phpunit) >= 5.7.23
# Autoloader
@@ -55,16 +58,16 @@ BuildRequires: php-fedora-autoloader-devel
%endif
# From composer.json, "require": {
-# "php": "^5.5 || ^7.0",
-# "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.0",
-# "phpunitgoodpractices/polyfill": "^1.1"
+# "php": "^5.5 || ^7.0",
+# "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.0 || ^8.0",
+# "phpunitgoodpractices/polyfill": "^1.1"
Requires: php(language) >= 5.5
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(phpunitgoodpractices/polyfill) >= 1.0 with php-composer(phpunitgoodpractices/polyfill) < 2)
+Requires: (php-composer(phpunitgoodpractices/polyfill) >= 1.1 with php-composer(phpunitgoodpractices/polyfill) < 2)
# remirepo:3
%else
-Requires: php-phpunitgoodpractices-polyfill
+Requires: php-phpunitgoodpractices-polyfill >= 1.1
%endif
# ignore phpunit dep, package using it will run the proper phpunit command (and autoloader)
# From phpcompatinfo report for version 1.0.0
@@ -84,8 +87,6 @@ Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-rm src/.gitkeep
-
cat << 'EOF' | tee src/autoload.php
<?php
/* autoloader for %{name} */
@@ -142,6 +143,13 @@ if [ -x %{_bindir}/phpunit7 ]; then
fi
done
fi
+if [ -x %{_bindir}/phpunit8 ]; then
+ for cmd in php php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit8 --verbose || ret=1
+ fi
+ done
+fi
exit $ret
%else
: Test suite disabled
@@ -157,6 +165,11 @@ exit $ret
%changelog
+* Tue Mar 26 2019 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+- raise dependency on phpunitgoodpractices/polyfill 1.1
+- allow PHPUnit 8
+
* Mon Jun 11 2018 Remi Collet <remi@remirepo.net> - 1.0.1-1
- update to 1.0.1 (no change)