summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-20 08:13:20 +0200
committerRemi Collet <remi@remirepo.net>2020-10-20 08:13:20 +0200
commitc5e5c905aab5be9361425800f0c691dd84f1fd6d (patch)
tree9f907756346faf21675e38924fdbb961bc05a292
parent798e2f4ba4640b6875efdfea29f2cc90ddc6a69e (diff)
update to 1.2.0
raise dependency on phpunitgoodpractices/polyfill 1.4 allow PHPUnit 9
-rw-r--r--composer.json9
-rw-r--r--php-cs-fixer-phpunit-constraint-isidenticalstring.spec55
2 files changed, 36 insertions, 28 deletions
diff --git a/composer.json b/composer.json
index ba4be80..23e0b9c 100644
--- a/composer.json
+++ b/composer.json
@@ -10,12 +10,9 @@
}
],
"require": {
- "php": "^5.5 || ^7.0",
- "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.0 || ^8.0",
- "phpunitgoodpractices/polyfill": "^1.1"
- },
- "conflict": {
- "hhvm": "*"
+ "php": "^5.5 || ^7.0 || ^8.0",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20 || ^8.0 || ^9.0",
+ "phpunitgoodpractices/polyfill": "^1.4"
},
"require-dev": {
"johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
diff --git a/php-cs-fixer-phpunit-constraint-isidenticalstring.spec b/php-cs-fixer-phpunit-constraint-isidenticalstring.spec
index 0718df5..86cce9c 100644
--- a/php-cs-fixer-phpunit-constraint-isidenticalstring.spec
+++ b/php-cs-fixer-phpunit-constraint-isidenticalstring.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-cs-fixer-phpunit-constraint-isidenticalstring
#
-# Copyright (c) 2018-2019 Remi Collet
+# Copyright (c) 2018-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 94e6d1032557253892b4797bc8b6262aac72d5f9
+%global gh_commit 2bd63d705ff5db3892da10f4df768abaffa8c1e2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner PHP-CS-Fixer
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{pk_vendor}-%{pk_project}
-Version: 1.1.0
+Version: 1.2.0
Release: 1%{?dist}
Summary: Constraint for testing strings considering not-same line endings
@@ -38,36 +38,35 @@ BuildRequires: php-pcre
# "johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
# "symfony/phpunit-bridge": "^3.2.2 || ^4.0"
# ignore phpunit listeners
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
-BuildRequires: phpunit8
-%endif
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
-BuildRequires: phpunit7
-%endif
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(phpunitgoodpractices/polyfill) >= 1.1 with php-composer(phpunitgoodpractices/polyfill) < 2)
-BuildRequires: phpunit6 >= 6.4.3
+BuildRequires: (php-composer(phpunitgoodpractices/polyfill) >= 1.4 with php-composer(phpunitgoodpractices/polyfill) < 2)
# remirepo:3
%else
-BuildRequires: php-phpunitgoodpractices-polyfill >= 1.1
+BuildRequires: php-phpunitgoodpractices-polyfill >= 1.4
%endif
-BuildRequires: php-composer(phpunit/phpunit) >= 5.7.23
+%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
+BuildRequires: phpunit9
+%endif
+BuildRequires: phpunit8
+BuildRequires: phpunit7 >= 7.5.20
+BuildRequires: phpunit6 >= 6.5.14
+BuildRequires: phpunit >= 5.7.27
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
# From composer.json, "require": {
-# "php": "^5.5 || ^7.0",
-# "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.0 || ^8.0",
-# "phpunitgoodpractices/polyfill": "^1.1"
+# "php": "^5.5 || ^7.0 || ^8.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20 || ^8.0 || ^9.0",
+# "phpunitgoodpractices/polyfill": "^1.4"
Requires: php(language) >= 5.5
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(phpunitgoodpractices/polyfill) >= 1.1 with php-composer(phpunitgoodpractices/polyfill) < 2)
+Requires: (php-composer(phpunitgoodpractices/polyfill) >= 1.4 with php-composer(phpunitgoodpractices/polyfill) < 2)
# remirepo:3
%else
-Requires: php-phpunitgoodpractices-polyfill >= 1.1
+Requires: php-phpunitgoodpractices-polyfill >= 1.4
%endif
# ignore phpunit dep, package using it will run the proper phpunit command (and autoloader)
# From phpcompatinfo report for version 1.0.0
@@ -123,33 +122,40 @@ sed -e '/<listeners>/,/<\/listeners>/d' phpunit.xml.dist >phpunit.xml
: Run upstream test suite with each available phpunit version
ret=0
if [ -x %{_bindir}/phpunit ]; then
- for cmd in php php56 php70 php71 php72; do
+ for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
done
fi
if [ -x %{_bindir}/phpunit6 ]; then
- for cmd in php php70 php71 php72; do
+ for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit6 --verbose || ret=1
fi
done
fi
if [ -x %{_bindir}/phpunit7 ]; then
- for cmd in php php71 php72; do
+ for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit7 --verbose || ret=1
fi
done
fi
if [ -x %{_bindir}/phpunit8 ]; then
- for cmd in php php72; do
+ for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit8 --verbose || ret=1
fi
done
fi
+if [ -x %{_bindir}/phpunit9 ]; then
+ for cmd in php php73 php74 php80; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit9 --verbose || ret=1
+ fi
+ done
+fi
exit $ret
%else
: Test suite disabled
@@ -165,6 +171,11 @@ exit $ret
%changelog
+* Tue Oct 20 2020 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+- raise dependency on phpunitgoodpractices/polyfill 1.4
+- allow PHPUnit 9
+
* Tue Mar 26 2019 Remi Collet <remi@remirepo.net> - 1.1.0-1
- update to 1.1.0
- raise dependency on phpunitgoodpractices/polyfill 1.1