summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-06-04 09:41:16 +0200
committerRemi Collet <remi@remirepo.net>2018-06-04 09:41:16 +0200
commit82250a84eaffa2323fbaa74b747a5c5601b3fed4 (patch)
tree238d3477a4cdd0aa0fc871ea0275c690dc5eaf1c
New package
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json41
-rwxr-xr-xmakesrc.sh27
-rw-r--r--php-cs-fixer-phpunit-constraint-isidenticalstring.spec159
5 files changed, 239 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..940c105
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,41 @@
+{
+ "name": "php-cs-fixer/phpunit-constraint-isidenticalstring",
+ "type": "library",
+ "description": "Constraint for testing strings considering not-same line endings.",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Dariusz RumiƄski",
+ "email": "dariusz.ruminski@gmail.com"
+ }
+ ],
+ "require": {
+ "php": "^5.5 || ^7.0",
+ "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.0",
+ "phpunitgoodpractices/polyfill": "^1.0"
+ },
+ "conflict": {
+ "hhvm": "*"
+ },
+ "require-dev": {
+ "johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
+ "symfony/phpunit-bridge": "^3.2.2 || ^4.0"
+ },
+ "config": {
+ "optimize-autoloader": true,
+ "sort-packages": true
+ },
+ "autoload": {
+ "psr-4": {
+ "PhpCsFixer\\PhpunitConstraintIsIdenticalString\\": "src/"
+ },
+ "files": [
+ "src/Constraint/IsIdenticalString.php"
+ ]
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "PhpCsFixer\\PhpunitConstraintIsIdenticalString\\Tests\\": "tests/"
+ }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..dfd5c2a
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,27 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-cs-fixer-phpunit-constraint-isidenticalstring.spec b/php-cs-fixer-phpunit-constraint-isidenticalstring.spec
new file mode 100644
index 0000000..4fd9842
--- /dev/null
+++ b/php-cs-fixer-phpunit-constraint-isidenticalstring.spec
@@ -0,0 +1,159 @@
+# remirepo/fedora spec file for php-cs-fixer-phpunit-constraint-isidenticalstring
+#
+# Copyright (c) 2018 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit c82443aa03c87312070ea4b3e743bd114da2f7ca
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+#global gh_date 20150717
+%global gh_owner PHP-CS-Fixer
+%global gh_project phpunit-constraint-isidenticalstring
+%global pk_vendor php-cs-fixer
+%global pk_project %{gh_project}
+%global ns_vendor PhpCsFixer
+%global ns_project PhpunitConstraintIsIdenticalString
+%global php_home %{_datadir}/php
+%global with_tests 0%{!?_without_tests:1}
+
+Name: %{pk_vendor}-%{pk_project}
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: Constraint for testing strings considering not-same line endings
+
+Group: Development/Tools
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+# git snapshot to get upstream test suite
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: php(language) >= 5.5
+BuildRequires: php-pcre
+# From composer.json, "require-dev": {
+# "johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
+# "symfony/phpunit-bridge": "^3.2.2 || ^4.0"
+# ignore phpunit listeners
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+BuildRequires: phpunit7
+%endif
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(phpunitgoodpractices/polyfill) >= 1.0 with php-composer(phpunitgoodpractices/polyfill) < 2)
+BuildRequires: phpunit6 >= 6.4.3
+%else
+BuildRequires: php-phpunitgoodpractices-polyfill
+%endif
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7.23
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+%endif
+
+# From composer.json, "require": {
+# "php": "^5.5 || ^7.0",
+# "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.0",
+# "phpunitgoodpractices/polyfill": "^1.0"
+Requires: php(language) >= 5.5
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(phpunitgoodpractices/polyfill) >= 1.0 with php-composer(phpunitgoodpractices/polyfill) < 2)
+%else
+Requires: php-phpunitgoodpractices-polyfill
+%endif
+# ignore phpunit dep, package using it will run the proper phpunit command (and autoloader)
+# From phpcompatinfo report for version 1.0.0
+Requires: php-pcre
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+Constraint for testing strings considering not-same line endings.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+rm src/.gitkeep
+
+cat << 'EOF' | tee src/autoload.php
+<?php
+/* autoloader for %{name} */
+
+\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\', __DIR__);
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/PHPUnitGoodPractices/Polyfill/autoload.php',
+ __DIR__ . '/Constraint/IsIdenticalString.php',
+]);
+EOF
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+: Library
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
+EOF
+
+: Disable the listeners
+sed -e 's/listeners/nolisteners/' phpunit.xml.dist >phpunit.xml
+
+: Run upstream test suite with each available phpunit version
+ret=0
+if [ -x %{_bindir}/phpunit ]; then
+ for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+ done
+fi
+if [ -x %{_bindir}/phpunit6 ]; then
+ for cmd in php php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ fi
+ done
+fi
+if [ -x %{_bindir}/phpunit7 ]; then
+ for cmd in php php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit7 --verbose || ret=1
+ fi
+ done
+fi
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}
+
+
+%changelog
+* Mon Jun 4 2018 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package, version 1.0.0
+- open php-cs-fixer-phpunit-constraint-isidenticalstring - phpunit schema