summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-cs-fixer.spec')
-rw-r--r--php-cs-fixer.spec4
1 files changed, 3 insertions, 1 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index b4da659..1fe916f 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -66,6 +66,7 @@ BuildRequires: php-symfony3-finder
BuildRequires: php-symfony3-options-resolver
BuildRequires: php-symfony3-process
BuildRequires: php-symfony3-stopwatch
+BuildRequires: php-symfony3-yaml
BuildRequires: php-mbstring
BuildRequires: php-xml
BuildRequires: php-reflection
@@ -292,6 +293,7 @@ cat << 'EOF' | tee vendor/autoload.php
'%{php_home}/LegacyPHPUnit/autoload.php',
'%{php_home}/PHPUnitGoodPractices/Polyfill/autoload.php',
'%{buildroot}%{php_home}/PhpCsFixer/autoload.php',
+ '%{php_home}/Symfony3/Component/Yaml/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('PhpCsFixer\\Tests\\', dirname(__DIR__) . '/tests');
EOF
@@ -322,7 +324,7 @@ for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=2G ${2:-%{_bindir}/phpunit9} \
- --filter '^((?!(testFixerContainsAllPhpunitStaticMethodsInItsList|testFix74Deprecated|testFixersPriorityPairsHaveIntegrationTest|testThereAreNoExtraFiles|testFixersDocumentationIndexFileIsUpToDate)).)*$' \
+ --filter '^((?!(testFixerContainsAllPhpunitStaticMethodsInItsList|testFix74Deprecated|testFixersPriorityPairsHaveIntegrationTest|testThereAreNoExtraFiles|testFixersDocumentationIndexFileIsUpToDate|testInheritance)).)*$' \
|| ret=1
fi
done