summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-cs-fixer.spec')
-rw-r--r--php-cs-fixer.spec30
1 files changed, 19 insertions, 11 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 0a97c6a..49daa0a 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit ff401e58261ffc5934a58f795b3f95b355e276cb
+%global gh_commit adfab51ae979ee8b0fcbc55aa231ec2786cb1f91
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -26,7 +26,7 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.14.2
+Version: 2.15.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -39,6 +39,8 @@ Source2: makesrc.sh
# Use our autoloader
Patch0: %{name}-autoload.patch
+# Fix escape sequence is invalid in character class
+Patch1: https://github.com/FriendsOfPHP/PHP-CS-Fixer/pull/4406.patch
BuildArch: noarch
%if %{with_tests}
@@ -85,13 +87,13 @@ BuildRequires: php-symfony3-debug
# "johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
# "keradus/cli-executor": "^1.2",
# "justinrainbow/json-schema": "^5.0",
-# "mikey179/vfsStream": "^1.6",
+# "mikey179/vfsstream": "^1.6",
# "php-coveralls/php-coveralls": "^2.1",
# "php-cs-fixer/accessible-object": "^1.0",
-# "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.0.1",
-# "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.0.1",
+# "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.1",
+# "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.1",
# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1",
-# "phpunitgoodpractices/traits": "^1.5.1",
+# "phpunitgoodpractices/traits": "^1.8",
# "symfony/phpunit-bridge": "^4.0"
# ignored as test using it fail strangely
#BuildRequires: php-composer(keradus/cli-executor) < 2
@@ -99,11 +101,11 @@ BuildRequires: php-symfony3-debug
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(justinrainbow/json-schema) >= 5.0 with php-composer(justinrainbow/json-schema) < 6)
-BuildRequires: (php-composer(mikey179/vfsStream) >= 1.6 with php-composer(mikey179/vfsStream) < 2)
+BuildRequires: (php-composer(mikey179/vfsstream) >= 1.6 with php-composer(mikey179/vfsstream) < 2)
BuildRequires: (php-composer(php-cs-fixer/accessible-object) >= 1.0 with php-composer(php-cs-fixer/accessible-object) < 2)
-BuildRequires: (php-composer(php-cs-fixer/phpunit-constraint-isidenticalstring) >= 1.0 with php-composer(php-cs-fixer/phpunit-constraint-isidenticalstring) < 2)
-BuildRequires: (php-composer(php-cs-fixer/phpunit-constraint-xmlmatchesxsd) >= 1.0 with php-composer(php-cs-fixer/phpunit-constraint-xmlmatchesxsd) < 2)
-BuildRequires: (php-composer(phpunitgoodpractices/traits) >= 1.5.1 with php-composer(phpunitgoodpractices/traits) < 2)
+BuildRequires: (php-composer(php-cs-fixer/phpunit-constraint-isidenticalstring) >= 1.1 with php-composer(php-cs-fixer/phpunit-constraint-isidenticalstring) < 2)
+BuildRequires: (php-composer(php-cs-fixer/phpunit-constraint-xmlmatchesxsd) >= 1.1 with php-composer(php-cs-fixer/phpunit-constraint-xmlmatchesxsd) < 2)
+BuildRequires: (php-composer(phpunitgoodpractices/traits) >= 1.8 with php-composer(phpunitgoodpractices/traits) < 2)
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit7
BuildRequires: phpunit7 >= 7.1
@@ -213,6 +215,7 @@ projects. This tool does not only detect them, but also fixes them for you.
%prep
%setup -q -n %{gh_project}-%{gh_commit} -a1
%patch0 -p1 -b .rpm
+%patch1 -p1
mv diff-%{gh_diff_commit}/src src/diff
find src -name \*rpm -delete -print
@@ -313,7 +316,7 @@ sed -e '/<listeners>/,/<\/listeners>/d' phpunit.xml.dist >phpunit.xml
sed -e 's:%{php_home}:%{buildroot}%{php_home}:' -i %{name}
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72 php73; do
+for cmdarg in "php %{phpunit}" php71 php72 php73; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=2G ${2:-%{_bindir}/phpunit7} \
@@ -337,6 +340,11 @@ exit $ret
%changelog
+* Mon May 6 2019 Remi Collet <remi@remirepo.net> - 2.15.0-1
+- update to 2.15.0
+- add patch for libpcre2 10.33 from
+ https://github.com/FriendsOfPHP/PHP-CS-Fixer/pull/4406
+
* Mon Feb 18 2019 Remi Collet <remi@remirepo.net> - 2.14.2-1
- update to 2.14.2 (no change)