summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-cs-fixer.spec')
-rw-r--r--php-cs-fixer.spec12
1 files changed, 9 insertions, 3 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index c5fa71c..ab5ed27 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit ab99202fccff2a9f97592fbe1b5c76dd06df3513
+%global gh_commit 06f764e3cb6d60822d8f5135205f9d32b5508a31
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -26,7 +26,7 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.18.3
+Version: 2.18.4
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -216,6 +216,9 @@ mv diff-%{gh_diff_commit}/src src/diff
find src -name \*rpm -delete -print
+# Fix version
+sed -e '/VERSION/s/-DEV//' -i src/Console/Application.php
+
# from composer.json, "autoload" / "classmap"
TESTS="
tests/Test/AbstractFixerTestCase.php
@@ -325,7 +328,7 @@ for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=2G ${2:-%{_bindir}/phpunit9} \
- --filter '^((?!(testFixerContainsAllPhpunitStaticMethodsInItsList|testFix74Deprecated|testFixersPriorityPairsHaveIntegrationTest|testThereAreNoExtraFiles|testFixersDocumentationIndexFileIsUpToDate|testInheritance)).)*$' \
+ --filter '^((?!(testFixerContainsAllPhpunitStaticMethodsInItsList|testFix74Deprecated|testFixersPriorityPairsHaveIntegrationTest|testThereAreNoExtraFiles|testFixersDocumentationIndexFileIsUpToDate|testInheritance|testFixerDefinitions)).)*$' \
|| ret=1
fi
done
@@ -346,6 +349,9 @@ exit $ret
%changelog
+* Mon Mar 22 2021 Remi Collet <remi@remirepo.net> - 2.18.4-1
+- update to 2.18.4
+
* Thu Mar 11 2021 Remi Collet <remi@remirepo.net> - 2.18.3-1
- update to 2.18.3