summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-cs-fixer.spec')
-rw-r--r--php-cs-fixer.spec16
1 files changed, 11 insertions, 5 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 78e9cf8..5f43863 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit d9ec9b848cbf930c31dea3693d34dbd8b9c95295
+%global gh_commit 454ddbe65da6a9297446f442bad244e8a99a9a38
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -21,7 +21,7 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.8.3
+Version: 2.9.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -86,17 +86,19 @@ BuildRequires: php-symfony3-debug
# NOTICE: listener disabled during test suite
# "johnkary/phpunit-speedtrap": "^1.1 || ^2.0@dev",
# "justinrainbow/json-schema": "^5.0",
-# "satooshi/php-coveralls": "^1.0.2",
+# "mikey179/vfsStream": "^1.6",
+# "php-coveralls/php-coveralls": "^2.0",
# "php-cs-fixer/accessible-object": "^1.0",
# "phpunit/phpunit": "^5.7.23 || ^6.4.3",
# "symfony/phpunit-bridge": "^3.2.2 || ^4.0"
BuildRequires: php-composer(justinrainbow/json-schema) < 6
BuildRequires: php-composer(justinrainbow/json-schema) >= 5.0
+BuildRequires: php-composer(mikey179/vfsStream) < 2
+BuildRequires: php-composer(mikey179/vfsStream) >= 1.6
BuildRequires: php-composer(php-cs-fixer/accessible-object) < 2
BuildRequires: php-composer(php-cs-fixer/accessible-object) >= 1.0
BuildRequires: %{phpunit}
-BuildRequires: php-composer(symfony/phpunit-bridge) < 4
-BuildRequires: php-composer(symfony/phpunit-bridge) >= 3.2
+BuildRequires: php-symfony3-phpunit-bridge >= 3.2.2
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
@@ -216,6 +218,7 @@ if (class_exists('PHPUnit\\Runner\\Version') && version_compare(PHPUnit\Runner\V
\Fedora\Autoloader\Dependencies::required([
'%{php_home}//Composer/Semver/autoload.php',
$gecko,
+ '%{php_home}/org/bovigo/vfs/autoload.php',
'%{php_home}/Doctrine/Common/Annotations/autoload.php',
'%{php_home}/Symfony3/Component/Console/autoload.php',
'%{php_home}/Symfony3/Component/EventDispatcher/autoload.php',
@@ -291,6 +294,9 @@ exit $ret
%changelog
+* Sat Dec 9 2017 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- Update to 2.9.0
+
* Mon Nov 27 2017 Remi Collet <remi@remirepo.net> - 2.8.3-1
- Update to 2.8.3
- open https://github.com/FriendsOfPHP/PHP-CS-Fixer/issues/3279