summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json8
-rw-r--r--php-cs-fixer.spec7
2 files changed, 10 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 48da43d..989f20f 100644
--- a/composer.json
+++ b/composer.json
@@ -47,7 +47,6 @@
"php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.4",
"php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.4",
"phpunit/phpunit": "^9.6",
- "symfony/phpunit-bridge": "^6.3.8 || ^7.0",
"symfony/yaml": "^5.4 || ^6.0 || ^7.0"
},
"suggest": {
@@ -109,6 +108,7 @@
"./dev-tools/check_file_permissions.sh",
"./dev-tools/check_trailing_spaces.sh",
"@normalize",
+ "@unused-deps",
"@require-checker",
"@auto-review"
],
@@ -137,7 +137,8 @@
"test:unit": [
"Composer\\Config::disableProcessTimeout",
"paraunit run --testsuite unit"
- ]
+ ],
+ "unused-deps": "@php dev-tools/vendor/bin/composer-unused --excludePackage=composer/xdebug-handler"
},
"scripts-descriptions": {
"auto-review": "Execute Auto-review",
@@ -162,6 +163,7 @@
"test:coverage": "Run tests that provide code coverage",
"test:integration": "Run Integration tests",
"test:smoke": "Run Smoke tests",
- "test:unit": "Run Unit tests"
+ "test:unit": "Run Unit tests",
+ "unused-deps": "Verifies if app has dependencies that are not used"
}
}
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 74c9c85..46ba49f 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 8b6ae8dcbaf23f09680643ab832a4a3a260265f6
+%global gh_commit 632ef1be3447a9b890bef06147475facee535d0f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.41.1
+Version: 3.42.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -150,6 +150,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Wed Dec 27 2023 Remi Collet <remi@remirepo.net> - 3.42.0-1
+- update to 3.42.0
+
* Mon Dec 11 2023 Remi Collet <remi@remirepo.net> - 3.41.1-1
- update to 3.41.1