summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json5
-rw-r--r--php-cs-fixer.spec14
2 files changed, 12 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 8068d48..17aaa17 100644
--- a/composer.json
+++ b/composer.json
@@ -40,9 +40,10 @@
"php-cs-fixer/accessible-object": "^1.0",
"php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.1",
"php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.1",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.1",
"phpunitgoodpractices/traits": "^1.8",
- "symfony/phpunit-bridge": "^4.3"
+ "symfony/phpunit-bridge": "^4.3",
+ "symfony/yaml": "^3.0 || ^4.0"
},
"suggest": {
"ext-mbstring": "For handling non-UTF8 characters in cache signature.",
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 8020afc..743a17d 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit c9d30fddfa3feb8b82663104864224f2ce7a3675
+%global gh_commit 705490b0f282f21017d73561e9498d2b622ee34c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -26,7 +26,7 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.15.2
+Version: 2.15.3
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -90,9 +90,10 @@ BuildRequires: php-symfony3-debug
# "php-cs-fixer/accessible-object": "^1.0",
# "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.1",
# "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.1",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.1",
# "phpunitgoodpractices/traits": "^1.8",
-# "symfony/phpunit-bridge": "^4.3"
+# "symfony/phpunit-bridge": "^4.3",
+# "symfony/yaml": "^3.0 || ^4.0"
# ignored as test using it fail strangely
#BuildRequires: php-composer(keradus/cli-executor) < 2
#BuildRequires: php-composer(keradus/cli-executor) >= 1.0
@@ -109,7 +110,7 @@ BuildRequires: (php-composer(phpunitgoodpractices/traits)
BuildRequires: phpunit7 >= 7.1
%else
%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: phpunit6 >= 6.5.14
%endif
# remirepo:10
%else
@@ -340,6 +341,9 @@ exit $ret
%changelog
+* Sun Sep 1 2019 Remi Collet <remi@remirepo.net> - 2.15.3-1
+- update to 2.15.3
+
* Thu Aug 29 2019 Remi Collet <remi@remirepo.net> - 2.15.2-1
- update to 2.15.2