summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json8
-rw-r--r--installed.json310
-rwxr-xr-xmakesrc.sh2
-rw-r--r--php-cs-fixer.spec46
4 files changed, 191 insertions, 175 deletions
diff --git a/composer.json b/composer.json
index b498074..0434e87 100644
--- a/composer.json
+++ b/composer.json
@@ -40,6 +40,7 @@
},
"require-dev": {
"facile-it/paraunit": "^1.3 || ^2.0",
+ "infection/infection": "^0.27.11",
"justinrainbow/json-schema": "^5.2",
"keradus/cli-executor": "^2.1",
"mikey179/vfsstream": "^1.6.11",
@@ -88,6 +89,7 @@
"cs:fix": "@php php-cs-fixer fix",
"cs:fix:parallel": "echo '🔍 Will run in batches of 50 files.'; if [[ -f .php-cs-fixer.php ]]; then FIXER_CONFIG=.php-cs-fixer.php; else FIXER_CONFIG=.php-cs-fixer.dist.php; fi; php php-cs-fixer list-files --config=$FIXER_CONFIG | xargs -n 50 -P 8 php php-cs-fixer fix --config=$FIXER_CONFIG --path-mode intersection 2> /dev/null",
"docs": "@php dev-tools/doc.php",
+ "infection": "@test:mutation",
"install-tools": "@composer --working-dir=dev-tools install",
"mess-detector": "@php dev-tools/vendor/bin/phpmd . ansi dev-tools/mess-detector/phpmd.xml --exclude vendor/*,dev-tools/vendor/*,dev-tools/phpstan/*,tests/Fixtures/*",
"normalize": [
@@ -132,6 +134,10 @@
"Composer\\Config::disableProcessTimeout",
"paraunit run --testsuite integration"
],
+ "test:mutation": [
+ "Composer\\Config::disableProcessTimeout",
+ "infection --threads=max --only-covered --min-covered-msi=80"
+ ],
"test:short-open-tag": [
"Composer\\Config::disableProcessTimeout",
"@php -d short_open_tag=1 ./vendor/bin/phpunit --do-not-cache-result --testsuite short-open-tag"
@@ -152,6 +158,7 @@
"cs:fix": "Fix coding standards",
"cs:fix:parallel": "Fix coding standards in naive parallel mode (using xargs)",
"docs": "Regenerate docs",
+ "infection": "Alias for 'test:mutation'",
"install-tools": "Install DEV tools",
"mess-detector": "Analyse code with Mess Detector",
"normalize": "Run normalization for composer.json files",
@@ -168,6 +175,7 @@
"test:all": "Run Unit and Integration tests (but *NOT* Smoke tests)",
"test:coverage": "Run tests that provide code coverage",
"test:integration": "Run Integration tests",
+ "test:mutation": "Run mutation tests",
"test:short-open-tag": "Run tests with \"short_open_tag\" enabled",
"test:smoke": "Run Smoke tests",
"test:unit": "Run Unit tests",
diff --git a/installed.json b/installed.json
index 3feb5c2..510982d 100644
--- a/installed.json
+++ b/installed.json
@@ -160,17 +160,17 @@
},
{
"name": "composer/xdebug-handler",
- "version": "3.0.3",
- "version_normalized": "3.0.3.0",
+ "version": "3.0.4",
+ "version_normalized": "3.0.4.0",
"source": {
"type": "git",
"url": "https://github.com/composer/xdebug-handler.git",
- "reference": "ced299686f41dce890debac69273b47ffe98a40c"
+ "reference": "4f988f8fdf580d53bdb2d1278fe93d1ed5462255"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/xdebug-handler/zipball/ced299686f41dce890debac69273b47ffe98a40c",
- "reference": "ced299686f41dce890debac69273b47ffe98a40c",
+ "url": "https://api.github.com/repos/composer/xdebug-handler/zipball/4f988f8fdf580d53bdb2d1278fe93d1ed5462255",
+ "reference": "4f988f8fdf580d53bdb2d1278fe93d1ed5462255",
"shasum": ""
},
"require": {
@@ -181,9 +181,9 @@
"require-dev": {
"phpstan/phpstan": "^1.0",
"phpstan/phpstan-strict-rules": "^1.1",
- "symfony/phpunit-bridge": "^6.0"
+ "phpunit/phpunit": "^8.5 || ^9.6 || ^10.5"
},
- "time": "2022-02-25T21:32:43+00:00",
+ "time": "2024-03-26T18:29:49+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -207,9 +207,9 @@
"performance"
],
"support": {
- "irc": "irc://irc.freenode.org/composer",
+ "irc": "ircs://irc.libera.chat:6697/composer",
"issues": "https://github.com/composer/xdebug-handler/issues",
- "source": "https://github.com/composer/xdebug-handler/tree/3.0.3"
+ "source": "https://github.com/composer/xdebug-handler/tree/3.0.4"
},
"funding": [
{
@@ -391,31 +391,31 @@
},
{
"name": "sebastian/diff",
- "version": "4.0.6",
- "version_normalized": "4.0.6.0",
+ "version": "5.1.1",
+ "version_normalized": "5.1.1.0",
"source": {
"type": "git",
"url": "https://github.com/sebastianbergmann/diff.git",
- "reference": "ba01945089c3a293b01ba9badc29ad55b106b0bc"
+ "reference": "c41e007b4b62af48218231d6c2275e4c9b975b2e"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/sebastianbergmann/diff/zipball/ba01945089c3a293b01ba9badc29ad55b106b0bc",
- "reference": "ba01945089c3a293b01ba9badc29ad55b106b0bc",
+ "url": "https://api.github.com/repos/sebastianbergmann/diff/zipball/c41e007b4b62af48218231d6c2275e4c9b975b2e",
+ "reference": "c41e007b4b62af48218231d6c2275e4c9b975b2e",
"shasum": ""
},
"require": {
- "php": ">=7.3"
+ "php": ">=8.1"
},
"require-dev": {
- "phpunit/phpunit": "^9.3",
- "symfony/process": "^4.2 || ^5"
+ "phpunit/phpunit": "^10.0",
+ "symfony/process": "^6.4"
},
- "time": "2024-03-02T06:30:58+00:00",
+ "time": "2024-03-02T07:15:17+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-master": "4.0-dev"
+ "dev-main": "5.1-dev"
}
},
"installation-source": "dist",
@@ -448,7 +448,8 @@
],
"support": {
"issues": "https://github.com/sebastianbergmann/diff/issues",
- "source": "https://github.com/sebastianbergmann/diff/tree/4.0.6"
+ "security": "https://github.com/sebastianbergmann/diff/security/policy",
+ "source": "https://github.com/sebastianbergmann/diff/tree/5.1.1"
},
"funding": [
{
@@ -460,24 +461,25 @@
},
{
"name": "symfony/console",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v6.4.6",
+ "version_normalized": "6.4.6.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "c3ebc83d031b71c39da318ca8b7a07ecc67507ed"
+ "reference": "a2708a5da5c87d1d0d52937bdeac625df659e11f"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/c3ebc83d031b71c39da318ca8b7a07ecc67507ed",
- "reference": "c3ebc83d031b71c39da318ca8b7a07ecc67507ed",
+ "url": "https://api.github.com/repos/symfony/console/zipball/a2708a5da5c87d1d0d52937bdeac625df659e11f",
+ "reference": "a2708a5da5c87d1d0d52937bdeac625df659e11f",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
+ "php": ">=8.1",
+ "symfony/deprecation-contracts": "^2.5|^3",
"symfony/polyfill-mbstring": "~1.0",
- "symfony/service-contracts": "^1.1|^2|^3",
- "symfony/string": "^5.4|^6.0"
+ "symfony/service-contracts": "^2.5|^3",
+ "symfony/string": "^5.4|^6.0|^7.0"
},
"conflict": {
"symfony/dependency-injection": "<5.4",
@@ -491,20 +493,18 @@
},
"require-dev": {
"psr/log": "^1|^2|^3",
- "symfony/config": "^5.4|^6.0",
- "symfony/dependency-injection": "^5.4|^6.0",
- "symfony/event-dispatcher": "^5.4|^6.0",
- "symfony/lock": "^5.4|^6.0",
- "symfony/process": "^5.4|^6.0",
- "symfony/var-dumper": "^5.4|^6.0"
- },
- "suggest": {
- "psr/log": "For using the console logger",
- "symfony/event-dispatcher": "",
- "symfony/lock": "",
- "symfony/process": ""
- },
- "time": "2023-01-01T08:36:10+00:00",
+ "symfony/config": "^5.4|^6.0|^7.0",
+ "symfony/dependency-injection": "^5.4|^6.0|^7.0",
+ "symfony/event-dispatcher": "^5.4|^6.0|^7.0",
+ "symfony/http-foundation": "^6.4|^7.0",
+ "symfony/http-kernel": "^6.4|^7.0",
+ "symfony/lock": "^5.4|^6.0|^7.0",
+ "symfony/messenger": "^5.4|^6.0|^7.0",
+ "symfony/process": "^5.4|^6.0|^7.0",
+ "symfony/stopwatch": "^5.4|^6.0|^7.0",
+ "symfony/var-dumper": "^5.4|^6.0|^7.0"
+ },
+ "time": "2024-03-29T19:07:53+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -533,12 +533,12 @@
"homepage": "https://symfony.com",
"keywords": [
"cli",
- "command line",
+ "command-line",
"console",
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v6.0.19"
+ "source": "https://github.com/symfony/console/tree/v6.4.6"
},
"funding": [
{
@@ -558,27 +558,27 @@
},
{
"name": "symfony/deprecation-contracts",
- "version": "v3.0.2",
- "version_normalized": "3.0.2.0",
+ "version": "v3.4.0",
+ "version_normalized": "3.4.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/deprecation-contracts.git",
- "reference": "26954b3d62a6c5fd0ea8a2a00c0353a14978d05c"
+ "reference": "7c3aff79d10325257a001fcf92d991f24fc967cf"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/deprecation-contracts/zipball/26954b3d62a6c5fd0ea8a2a00c0353a14978d05c",
- "reference": "26954b3d62a6c5fd0ea8a2a00c0353a14978d05c",
+ "url": "https://api.github.com/repos/symfony/deprecation-contracts/zipball/7c3aff79d10325257a001fcf92d991f24fc967cf",
+ "reference": "7c3aff79d10325257a001fcf92d991f24fc967cf",
"shasum": ""
},
"require": {
- "php": ">=8.0.2"
+ "php": ">=8.1"
},
- "time": "2022-01-02T09:55:41+00:00",
+ "time": "2023-05-23T14:45:45+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "3.0-dev"
+ "dev-main": "3.4-dev"
},
"thanks": {
"name": "symfony/contracts",
@@ -608,7 +608,7 @@
"description": "A generic function and convention to trigger deprecation notices",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/deprecation-contracts/tree/v3.0.2"
+ "source": "https://github.com/symfony/deprecation-contracts/tree/v3.4.0"
},
"funding": [
{
@@ -628,25 +628,26 @@
},
{
"name": "symfony/event-dispatcher",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v6.4.3",
+ "version_normalized": "6.4.3.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/event-dispatcher.git",
- "reference": "2eaf8e63bc5b8cefabd4a800157f0d0c094f677a"
+ "reference": "ae9d3a6f3003a6caf56acd7466d8d52378d44fef"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/event-dispatcher/zipball/2eaf8e63bc5b8cefabd4a800157f0d0c094f677a",
- "reference": "2eaf8e63bc5b8cefabd4a800157f0d0c094f677a",
+ "url": "https://api.github.com/repos/symfony/event-dispatcher/zipball/ae9d3a6f3003a6caf56acd7466d8d52378d44fef",
+ "reference": "ae9d3a6f3003a6caf56acd7466d8d52378d44fef",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
- "symfony/event-dispatcher-contracts": "^2|^3"
+ "php": ">=8.1",
+ "symfony/event-dispatcher-contracts": "^2.5|^3"
},
"conflict": {
- "symfony/dependency-injection": "<5.4"
+ "symfony/dependency-injection": "<5.4",
+ "symfony/service-contracts": "<2.5"
},
"provide": {
"psr/event-dispatcher-implementation": "1.0",
@@ -654,19 +655,15 @@
},
"require-dev": {
"psr/log": "^1|^2|^3",
- "symfony/config": "^5.4|^6.0",
- "symfony/dependency-injection": "^5.4|^6.0",
- "symfony/error-handler": "^5.4|^6.0",
- "symfony/expression-language": "^5.4|^6.0",
- "symfony/http-foundation": "^5.4|^6.0",
- "symfony/service-contracts": "^1.1|^2|^3",
- "symfony/stopwatch": "^5.4|^6.0"
- },
- "suggest": {
- "symfony/dependency-injection": "",
- "symfony/http-kernel": ""
- },
- "time": "2023-01-01T08:36:10+00:00",
+ "symfony/config": "^5.4|^6.0|^7.0",
+ "symfony/dependency-injection": "^5.4|^6.0|^7.0",
+ "symfony/error-handler": "^5.4|^6.0|^7.0",
+ "symfony/expression-language": "^5.4|^6.0|^7.0",
+ "symfony/http-foundation": "^5.4|^6.0|^7.0",
+ "symfony/service-contracts": "^2.5|^3",
+ "symfony/stopwatch": "^5.4|^6.0|^7.0"
+ },
+ "time": "2024-01-23T14:51:35+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -694,7 +691,7 @@
"description": "Provides tools that allow your application components to communicate with each other by dispatching events and listening to them",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/event-dispatcher/tree/v6.0.19"
+ "source": "https://github.com/symfony/event-dispatcher/tree/v6.4.3"
},
"funding": [
{
@@ -714,31 +711,28 @@
},
{
"name": "symfony/event-dispatcher-contracts",
- "version": "v3.0.2",
- "version_normalized": "3.0.2.0",
+ "version": "v3.4.2",
+ "version_normalized": "3.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/event-dispatcher-contracts.git",
- "reference": "7bc61cc2db649b4637d331240c5346dcc7708051"
+ "reference": "4e64b49bf370ade88e567de29465762e316e4224"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/event-dispatcher-contracts/zipball/7bc61cc2db649b4637d331240c5346dcc7708051",
- "reference": "7bc61cc2db649b4637d331240c5346dcc7708051",
+ "url": "https://api.github.com/repos/symfony/event-dispatcher-contracts/zipball/4e64b49bf370ade88e567de29465762e316e4224",
+ "reference": "4e64b49bf370ade88e567de29465762e316e4224",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
+ "php": ">=8.1",
"psr/event-dispatcher": "^1"
},
- "suggest": {
- "symfony/event-dispatcher-implementation": ""
- },
- "time": "2022-01-02T09:55:41+00:00",
+ "time": "2024-01-23T14:51:35+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "3.0-dev"
+ "dev-main": "3.4-dev"
},
"thanks": {
"name": "symfony/contracts",
@@ -776,7 +770,7 @@
"standards"
],
"support": {
- "source": "https://github.com/symfony/event-dispatcher-contracts/tree/v3.0.2"
+ "source": "https://github.com/symfony/event-dispatcher-contracts/tree/v3.4.2"
},
"funding": [
{
@@ -796,25 +790,25 @@
},
{
"name": "symfony/filesystem",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v6.4.6",
+ "version_normalized": "6.4.6.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "3d49eec03fda1f0fc19b7349fbbe55ebc1004214"
+ "reference": "9919b5509ada52cc7f66f9a35c86a4a29955c9d3"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/3d49eec03fda1f0fc19b7349fbbe55ebc1004214",
- "reference": "3d49eec03fda1f0fc19b7349fbbe55ebc1004214",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/9919b5509ada52cc7f66f9a35c86a4a29955c9d3",
+ "reference": "9919b5509ada52cc7f66f9a35c86a4a29955c9d3",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
+ "php": ">=8.1",
"symfony/polyfill-ctype": "~1.8",
"symfony/polyfill-mbstring": "~1.8"
},
- "time": "2023-01-20T17:44:14+00:00",
+ "time": "2024-03-21T19:36:20+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -842,7 +836,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v6.0.19"
+ "source": "https://github.com/symfony/filesystem/tree/v6.4.6"
},
"funding": [
{
@@ -862,23 +856,26 @@
},
{
"name": "symfony/finder",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v6.4.0",
+ "version_normalized": "6.4.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "5cc9cac6586fc0c28cd173780ca696e419fefa11"
+ "reference": "11d736e97f116ac375a81f96e662911a34cd50ce"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/5cc9cac6586fc0c28cd173780ca696e419fefa11",
- "reference": "5cc9cac6586fc0c28cd173780ca696e419fefa11",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/11d736e97f116ac375a81f96e662911a34cd50ce",
+ "reference": "11d736e97f116ac375a81f96e662911a34cd50ce",
"shasum": ""
},
"require": {
- "php": ">=8.0.2"
+ "php": ">=8.1"
+ },
+ "require-dev": {
+ "symfony/filesystem": "^6.0|^7.0"
},
- "time": "2023-01-20T17:44:14+00:00",
+ "time": "2023-10-31T17:30:12+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -906,7 +903,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v6.0.19"
+ "source": "https://github.com/symfony/finder/tree/v6.4.0"
},
"funding": [
{
@@ -926,24 +923,24 @@
},
{
"name": "symfony/options-resolver",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v6.4.0",
+ "version_normalized": "6.4.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/options-resolver.git",
- "reference": "6a180d1c45e0d9797470ca9eb46215692de00fa3"
+ "reference": "22301f0e7fdeaacc14318928612dee79be99860e"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/options-resolver/zipball/6a180d1c45e0d9797470ca9eb46215692de00fa3",
- "reference": "6a180d1c45e0d9797470ca9eb46215692de00fa3",
+ "url": "https://api.github.com/repos/symfony/options-resolver/zipball/22301f0e7fdeaacc14318928612dee79be99860e",
+ "reference": "22301f0e7fdeaacc14318928612dee79be99860e",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
- "symfony/deprecation-contracts": "^2.1|^3"
+ "php": ">=8.1",
+ "symfony/deprecation-contracts": "^2.5|^3"
},
- "time": "2023-01-01T08:36:10+00:00",
+ "time": "2023-08-08T10:16:24+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -976,7 +973,7 @@
"options"
],
"support": {
- "source": "https://github.com/symfony/options-resolver/tree/v6.0.19"
+ "source": "https://github.com/symfony/options-resolver/tree/v6.4.0"
},
"funding": [
{
@@ -1488,23 +1485,23 @@
},
{
"name": "symfony/process",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v6.4.4",
+ "version_normalized": "6.4.4.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "2114fd60f26a296cc403a7939ab91478475a33d4"
+ "reference": "710e27879e9be3395de2b98da3f52a946039f297"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/2114fd60f26a296cc403a7939ab91478475a33d4",
- "reference": "2114fd60f26a296cc403a7939ab91478475a33d4",
+ "url": "https://api.github.com/repos/symfony/process/zipball/710e27879e9be3395de2b98da3f52a946039f297",
+ "reference": "710e27879e9be3395de2b98da3f52a946039f297",
"shasum": ""
},
"require": {
- "php": ">=8.0.2"
+ "php": ">=8.1"
},
- "time": "2023-01-01T08:36:10+00:00",
+ "time": "2024-02-20T12:31:00+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1532,7 +1529,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v6.0.19"
+ "source": "https://github.com/symfony/process/tree/v6.4.4"
},
"funding": [
{
@@ -1552,34 +1549,31 @@
},
{
"name": "symfony/service-contracts",
- "version": "v3.0.2",
- "version_normalized": "3.0.2.0",
+ "version": "v3.4.2",
+ "version_normalized": "3.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/service-contracts.git",
- "reference": "d78d39c1599bd1188b8e26bb341da52c3c6d8a66"
+ "reference": "11bbf19a0fb7b36345861e85c5768844c552906e"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/service-contracts/zipball/d78d39c1599bd1188b8e26bb341da52c3c6d8a66",
- "reference": "d78d39c1599bd1188b8e26bb341da52c3c6d8a66",
+ "url": "https://api.github.com/repos/symfony/service-contracts/zipball/11bbf19a0fb7b36345861e85c5768844c552906e",
+ "reference": "11bbf19a0fb7b36345861e85c5768844c552906e",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
- "psr/container": "^2.0"
+ "php": ">=8.1",
+ "psr/container": "^1.1|^2.0"
},
"conflict": {
"ext-psr": "<1.1|>=2"
},
- "suggest": {
- "symfony/service-implementation": ""
- },
- "time": "2022-05-30T19:17:58+00:00",
+ "time": "2023-12-19T21:51:00+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "3.0-dev"
+ "dev-main": "3.4-dev"
},
"thanks": {
"name": "symfony/contracts",
@@ -1590,7 +1584,10 @@
"autoload": {
"psr-4": {
"Symfony\\Contracts\\Service\\": ""
- }
+ },
+ "exclude-from-classmap": [
+ "/Test/"
+ ]
},
"notification-url": "https://packagist.org/downloads/",
"license": [
@@ -1617,7 +1614,7 @@
"standards"
],
"support": {
- "source": "https://github.com/symfony/service-contracts/tree/v3.0.2"
+ "source": "https://github.com/symfony/service-contracts/tree/v3.4.2"
},
"funding": [
{
@@ -1637,24 +1634,24 @@
},
{
"name": "symfony/stopwatch",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v6.4.3",
+ "version_normalized": "6.4.3.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/stopwatch.git",
- "reference": "011e781839dd1d2eb8119f65ac516a530f60226d"
+ "reference": "416596166641f1f728b0a64f5b9dd07cceb410c1"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/stopwatch/zipball/011e781839dd1d2eb8119f65ac516a530f60226d",
- "reference": "011e781839dd1d2eb8119f65ac516a530f60226d",
+ "url": "https://api.github.com/repos/symfony/stopwatch/zipball/416596166641f1f728b0a64f5b9dd07cceb410c1",
+ "reference": "416596166641f1f728b0a64f5b9dd07cceb410c1",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
- "symfony/service-contracts": "^1|^2|^3"
+ "php": ">=8.1",
+ "symfony/service-contracts": "^2.5|^3"
},
- "time": "2023-01-01T08:36:10+00:00",
+ "time": "2024-01-23T14:35:58+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1682,7 +1679,7 @@
"description": "Provides a way to profile code",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/stopwatch/tree/v6.0.19"
+ "source": "https://github.com/symfony/stopwatch/tree/v6.4.3"
},
"funding": [
{
@@ -1702,36 +1699,37 @@
},
{
"name": "symfony/string",
- "version": "v6.0.19",
- "version_normalized": "6.0.19.0",
+ "version": "v6.4.4",
+ "version_normalized": "6.4.4.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "d9e72497367c23e08bf94176d2be45b00a9d232a"
+ "reference": "4e465a95bdc32f49cf4c7f07f751b843bbd6dcd9"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/d9e72497367c23e08bf94176d2be45b00a9d232a",
- "reference": "d9e72497367c23e08bf94176d2be45b00a9d232a",
+ "url": "https://api.github.com/repos/symfony/string/zipball/4e465a95bdc32f49cf4c7f07f751b843bbd6dcd9",
+ "reference": "4e465a95bdc32f49cf4c7f07f751b843bbd6dcd9",
"shasum": ""
},
"require": {
- "php": ">=8.0.2",
+ "php": ">=8.1",
"symfony/polyfill-ctype": "~1.8",
"symfony/polyfill-intl-grapheme": "~1.0",
"symfony/polyfill-intl-normalizer": "~1.0",
"symfony/polyfill-mbstring": "~1.0"
},
"conflict": {
- "symfony/translation-contracts": "<2.0"
+ "symfony/translation-contracts": "<2.5"
},
"require-dev": {
- "symfony/error-handler": "^5.4|^6.0",
- "symfony/http-client": "^5.4|^6.0",
- "symfony/translation-contracts": "^2.0|^3.0",
- "symfony/var-exporter": "^5.4|^6.0"
+ "symfony/error-handler": "^5.4|^6.0|^7.0",
+ "symfony/http-client": "^5.4|^6.0|^7.0",
+ "symfony/intl": "^6.2|^7.0",
+ "symfony/translation-contracts": "^2.5|^3.0",
+ "symfony/var-exporter": "^5.4|^6.0|^7.0"
},
- "time": "2023-01-01T08:36:10+00:00",
+ "time": "2024-02-01T13:16:41+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1770,7 +1768,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v6.0.19"
+ "source": "https://github.com/symfony/string/tree/v6.4.4"
},
"funding": [
{
diff --git a/makesrc.sh b/makesrc.sh
index 42647d4..55c46fd 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -23,7 +23,7 @@ else
git checkout $COMMIT || exit1
cp composer.json ../
- composer config platform.php 8.0.99
+ composer config platform.php 8.1.99
composer install --no-interaction --no-progress --no-dev --optimize-autoloader
cp vendor/composer/installed.json ../
popd
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index a4d349c..41822b2 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit a3564bd66f4bce9bc871ef18b690e2dc67a7f969
+%global gh_commit 2aecbc8640d7906c38777b3dcab6f4ca79004d08
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 2024-03-18
+%global gh_date 2024-04-17
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.52.0
+Version: 3.54.0
Release: 1%{?dist}
Summary: PHP Coding Standards Fixer
@@ -32,12 +32,12 @@ Source2: makesrc.sh
Patch0: %{name}-autoload.patch
BuildArch: noarch
-BuildRequires: php(language) >= 8.0.1
+BuildRequires: php(language) >= 8.1
BuildRequires: php-cli
BuildRequires: php-json
# see composer.json and makesrc.sh
-Requires: php(language) >= 8.0.1
+Requires: php(language) >= 8.1
Requires: php-json
Requires: php-tokenizer
# From phpcompatinfo report for version 3.5.0
@@ -51,31 +51,31 @@ Provides: php-cs-fixer3 = %{version}
# Bundled PHP libraries
# License BSD-3-Clause
-Provides: bundled(php-sebastian-diff) = 4.0.6
+Provides: bundled(php-sebastian-diff) = 5.1.1
# License MIT
Provides: bundled(php-composer-pcre) = 3.1.3
Provides: bundled(php-composer-semver) = 3.4.0
-Provides: bundled(php-composer-xdebug-handler) = 3.0.3
+Provides: bundled(php-composer-xdebug-handler) = 3.0.4
Provides: bundled(php-psr-container) = 2.0.2
Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 2.0.0
-Provides: bundled(php-symfony-console) = v6.0.19
-Provides: bundled(php-symfony-deprecation-contracts) = v3.0.2
-Provides: bundled(php-symfony-event-dispatcher) = v6.0.19
-Provides: bundled(php-symfony-event-dispatcher-contracts) = v3.0.2
-Provides: bundled(php-symfony-filesystem) = v6.0.19
-Provides: bundled(php-symfony-finder) = v6.0.19
-Provides: bundled(php-symfony-options-resolver) = v6.0.19
+Provides: bundled(php-symfony-console) = v6.4.6
+Provides: bundled(php-symfony-deprecation-contracts) = v3.4.0
+Provides: bundled(php-symfony-event-dispatcher) = v6.4.3
+Provides: bundled(php-symfony-event-dispatcher-contracts) = v3.4.2
+Provides: bundled(php-symfony-filesystem) = v6.4.6
+Provides: bundled(php-symfony-finder) = v6.4.0
+Provides: bundled(php-symfony-options-resolver) = v6.4.0
Provides: bundled(php-symfony-polyfill-ctype) = v1.29.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.29.0
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.29.0
Provides: bundled(php-symfony-polyfill-mbstring) = v1.29.0
Provides: bundled(php-symfony-polyfill-php80) = v1.29.0
Provides: bundled(php-symfony-polyfill-php81) = v1.29.0
-Provides: bundled(php-symfony-process) = v6.0.19
-Provides: bundled(php-symfony-service-contracts) = v3.0.2
-Provides: bundled(php-symfony-stopwatch) = v6.0.19
-Provides: bundled(php-symfony-string) = v6.0.19
+Provides: bundled(php-symfony-process) = v6.4.4
+Provides: bundled(php-symfony-service-contracts) = v3.4.2
+Provides: bundled(php-symfony-stopwatch) = v6.4.3
+Provides: bundled(php-symfony-string) = v6.4.4
Provides: php-composer(friendsofphp/php-cs-fixer) = %{version}
@@ -150,6 +150,16 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Wed Apr 17 2024 Remi Collet <remi@remirepo.net> - 3.54.0-1
+- update to 3.54.0
+
+* Tue Apr 9 2024 Remi Collet <remi@remirepo.net> - 3.53.0-1
+- update to 3.53.0
+- bump dependency on PHP 8.1
+
+* Wed Mar 20 2024 Remi Collet <remi@remirepo.net> - 3.52.1-1
+- update to 3.52.1
+
* Tue Mar 19 2024 Remi Collet <remi@remirepo.net> - 3.52.0-1
- update to 3.52.0