summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-02 16:31:20 +0100
committerRemi Collet <remi@php.net>2022-11-02 16:31:20 +0100
commite4529e7b4dcd7e2730a5b0cf9692254491bbc4e9 (patch)
treecd2ada56698821acffdef7e64258025a9753e52c /php-cs-fixer.spec
parent07b250023f5c098beb14d910ecf764154332bc3c (diff)
update to 3.13.0
Diffstat (limited to 'php-cs-fixer.spec')
-rw-r--r--php-cs-fixer.spec44
1 files changed, 24 insertions, 20 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 6cd825e..87d45d6 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,18 +10,19 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit eae11d945e2885d86e1c080eec1bb30a2aa27998
+%global gh_commit a6232229a8309e8811dc751c28b91cb34b2943e1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.12.0
+Version: 3.13.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
-License: MIT and BSD
+# see bundled list below, SPDX
+License: MIT AND BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
# git snapshot to get upstream test suite
Source0: %{name}-%{version}-%{gh_short}.tgz
@@ -61,7 +62,7 @@ Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.1.2
Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 1.1.4
-Provides: bundled(php-symfony-console) = v5.4.14
+Provides: bundled(php-symfony-console) = v5.4.15
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
Provides: bundled(php-symfony-event-dispatcher) = v5.4.9
Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.2
@@ -78,7 +79,7 @@ Provides: bundled(php-symfony-polyfill-php81) = v1.26.0
Provides: bundled(php-symfony-process) = v5.4.11
Provides: bundled(php-symfony-service-contracts) = v2.5.2
Provides: bundled(php-symfony-stopwatch) = v5.4.13
-Provides: bundled(php-symfony-string) = v5.4.14
+Provides: bundled(php-symfony-string) = v5.4.15
Provides: php-composer(friendsofphp/php-cs-fixer) = %{version}
@@ -103,23 +104,23 @@ projects. This tool does not only detect them, but also fixes them for you.
: List bundled libraries and Licenses
php -r '
- $pkgs = file_get_contents("vendor/composer/installed.json");
- $pkgs = json_decode($pkgs, true);
- if (!is_array($pkgs) || !isset($pkgs["packages"])) {
+ $pkgs = file_get_contents("vendor/composer/installed.json");
+ $pkgs = json_decode($pkgs, true);
+ if (!is_array($pkgs) || !isset($pkgs["packages"])) {
echo "cant decode json file\n";
- exit(3);
- }
- $res = [];
+ exit(3);
+ }
+ $res = [];
foreach($pkgs["packages"] as $pkg) {
- $lic = implode(" and ", $pkg["license"]);
- if (!isset($res[$lic])) $res[$lic] = [];
- $res[$lic][] = sprintf("Provides: bundled(php-%s) = %s", str_replace(["/", "_"], ["-", "-"], $pkg["name"]), $pkg["version"]);
- }
- ksort($res);
- foreach($res as $lic => $lib) {
- sort($lib);
- printf("# License %s\n%s\n", $lic, implode("\n", $lib));
- }
+ $lic = implode(" and ", $pkg["license"]);
+ if (!isset($res[$lic])) $res[$lic] = [];
+ $res[$lic][] = sprintf("Provides: bundled(php-%s) = %s", str_replace(["/", "_"], ["-", "-"], $pkg["name"]), $pkg["version"]);
+ }
+ ksort($res);
+ foreach($res as $lic => $lib) {
+ sort($lib);
+ printf("# License %s\n%s\n", $lic, implode("\n", $lib));
+ }
'
%build
@@ -153,6 +154,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Wed Nov 2 2022 Remi Collet <remi@remirepo.net> - 3.13.0-1
+- update to 3.13.0
+
* Wed Oct 12 2022 Remi Collet <remi@remirepo.net> - 3.12.0-1
- update to 3.12.0