summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-11 08:01:33 +0100
committerRemi Collet <remi@php.net>2023-12-11 08:01:33 +0100
commitfd4711af5af4ef88fa10b26849c2e01cad4504d1 (patch)
treefbed49d77757a27e15894db84f79bcf95b13de6a
parent93215c6da1a9efcdf0e012f827b5579f0915bfae (diff)
update to 3.41.1
-rw-r--r--composer.json4
-rw-r--r--php-cs-fixer.spec7
2 files changed, 6 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index dd90058..48da43d 100644
--- a/composer.json
+++ b/composer.json
@@ -46,8 +46,6 @@
"php-cs-fixer/accessible-object": "^1.1",
"php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.4",
"php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.4",
- "phpspec/prophecy": "^1.17",
- "phpspec/prophecy-phpunit": "^2.0",
"phpunit/phpunit": "^9.6",
"symfony/phpunit-bridge": "^6.3.8 || ^7.0",
"symfony/yaml": "^5.4 || ^6.0 || ^7.0"
@@ -85,7 +83,7 @@
"Composer\\Config::disableProcessTimeout",
"paraunit run --testsuite auto-review"
],
- "cs:check": "@php php-cs-fixer check --diff",
+ "cs:check": "@php php-cs-fixer check --verbose --diff",
"cs:fix": "@php php-cs-fixer fix",
"cs:fix:parallel": "echo '🔍 Will run in batches of 50 files.'; if [[ -f .php-cs-fixer.php ]]; then FIXER_CONFIG=.php-cs-fixer.php; else FIXER_CONFIG=.php-cs-fixer.dist.php; fi; php php-cs-fixer list-files --config=$FIXER_CONFIG | xargs -n 50 -P 8 php php-cs-fixer fix --config=$FIXER_CONFIG --path-mode intersection 2> /dev/null",
"docs": "@php dev-tools/doc.php",
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index d74b6c1..74c9c85 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 4344562a516b76afe8f2d64b2e52214c30d64ed8
+%global gh_commit 8b6ae8dcbaf23f09680643ab832a4a3a260265f6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.40.2
+Version: 3.41.1
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -150,6 +150,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Mon Dec 11 2023 Remi Collet <remi@remirepo.net> - 3.41.1-1
+- update to 3.41.1
+
* Mon Dec 4 2023 Remi Collet <remi@remirepo.net> - 3.40.2-1
- update to 3.40.2