summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-31 17:38:17 +0200
committerRemi Collet <fedora@famillecollet.com>2017-03-31 17:38:17 +0200
commitfa143b9f906c321b3a31e1c594a5b960d482b533 (patch)
tree3b4a0f5238f1101704a8f2e22e1301814178ba58
parentd831b76c2607760ced594bdfbf145d59245910ee (diff)
v2.1.3
-rw-r--r--.gitignore7
-rw-r--r--composer.json5
-rw-r--r--php-cs-fixer.spec28
3 files changed, 28 insertions, 12 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 2908450..fa6da1d 100644
--- a/composer.json
+++ b/composer.json
@@ -23,6 +23,7 @@
"symfony/finder": "^2.2 || ^3.0",
"symfony/polyfill-php54": "^1.0",
"symfony/polyfill-php55": "^1.3",
+ "symfony/polyfill-php70": "^1.0",
"symfony/polyfill-xml": "^1.3",
"symfony/process": "^2.3 || ^3.0",
"symfony/stopwatch": "^2.5 || ^3.0"
@@ -35,7 +36,9 @@
"symfony/phpunit-bridge": "^3.2"
},
"suggest": {
- "ext-xml": "For better performance."
+ "ext-mbstring": "For handling non-UTF8 characters in cache singature.",
+ "ext-xml": "For better performance.",
+ "symfony/polyfill-mbstring": "When enabling `ext-mbstring` is not possible."
},
"conflict": {
"hhvm": "<3.9"
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index b0d8633..942a630 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit c7de769d7b44f2c9de68e1f678b65efd8126f60b
+%global gh_commit d30ca69f8bed931b5c630407f0a98306e33c2c39
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-cs-fixer
-Version: 2.1.2
+Version: 2.1.3
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -30,7 +30,6 @@ Source2: %{name}-autoload.php
# Use our autoloader
Patch0: %{name}-autoload.patch
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
@@ -41,9 +40,12 @@ BuildRequires: php-composer(symfony/event-dispatcher) >= 2.1
BuildRequires: php-composer(symfony/filesystem) >= 2.4
BuildRequires: php-composer(symfony/finder) >= 2.4
BuildRequires: php-composer(symfony/polyfill-php55) >= 1.3
+BuildRequires: php-composer(symfony/polyfill-php70) >= 1.3
BuildRequires: php-composer(symfony/process) >= 2.3
BuildRequires: php-composer(symfony/stopwatch) >= 2.5
BuildRequires: php-composer(sebastian/diff) >= 1.1
+BuildRequires: php-mbstring
+BuildRequires: php-xml
BuildRequires: php-reflection
BuildRequires: php-dom
BuildRequires: php-json
@@ -75,6 +77,7 @@ BuildRequires: php-composer(fedora/autoloader)
# "symfony/finder": "^2.2 || ^3.0",
# "symfony/polyfill-php54": "^1.0",
# "symfony/polyfill-php55": "^1.3",
+# "symfony/polyfill-php70": "^1.0",
# "symfony/polyfill-xml": "^1.3",
# "symfony/process": "^2.3 || ^3.0",
# "symfony/stopwatch": "^2.5 || ^3.0"
@@ -87,8 +90,15 @@ Requires: php-composer(symfony/event-dispatcher) >= 2.1
Requires: php-composer(symfony/filesystem) >= 2.4
Requires: php-composer(symfony/finder) >= 2.4
Requires: php-composer(symfony/polyfill-php55) >= 1.3
+Requires: php-composer(symfony/polyfill-php70) >= 1.0
Requires: php-composer(symfony/process) >= 2.3
Requires: php-composer(symfony/stopwatch) >= 2.5
+# From composer.json, "suggest": {
+# "ext-mbstring": "For handling non-UTF8 characters in cache singature.",
+# "ext-xml": "For better performance.",
+# "symfony/polyfill-mbstring": "When enabling `ext-mbstring` is not possible."
+Requires: php-mbstring
+Requires: php-xml
# From phpcompatinfo report for version 2.0.0
Requires: php-cli
Requires: php-reflection
@@ -97,7 +107,6 @@ Requires: php-json
Requires: php-pcre
Requires: php-phar
Requires: php-spl
-Requires: php-xml
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -126,8 +135,6 @@ cp %{SOURCE2} src/autoload.php
%install
-rm -rf %{buildroot}
-
: Library
mkdir -p %{buildroot}%{php_home}
cp -pr src %{buildroot}%{php_home}/PhpCsFixer
@@ -175,12 +182,7 @@ exit $ret
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -190,6 +192,10 @@ rm -rf %{buildroot}
%changelog
+* Fri Mar 31 2017 Remi Collet <remi@remirepo.net> - 2.1.3-1
+- Update to 2.1.3
+- add dependency on php-mbstring
+
* Wed Mar 15 2017 Remi Collet <remi@remirepo.net> - 2.1.2-1
- Update to 2.1.2