summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-11-26 09:13:30 +0100
committerRemi Collet <remi@remirepo.net>2019-11-26 09:13:30 +0100
commitdfdd7c8fc3075a3ee7ce04be16f102a04ec77569 (patch)
tree2c973730951a3a681af3fb9497783bef403a666e
parent4ad2dff00cd7b0a955f982e4a81d62888f4671fb (diff)
v2.16.1
-rw-r--r--composer.json18
-rw-r--r--php-cs-fixer.spec27
2 files changed, 24 insertions, 21 deletions
diff --git a/composer.json b/composer.json
index 17aaa17..8893e3a 100644
--- a/composer.json
+++ b/composer.json
@@ -21,15 +21,15 @@
"composer/xdebug-handler": "^1.2",
"doctrine/annotations": "^1.2",
"php-cs-fixer/diff": "^1.3",
- "symfony/console": "^3.4.17 || ^4.1.6",
- "symfony/event-dispatcher": "^3.0 || ^4.0",
- "symfony/filesystem": "^3.0 || ^4.0",
- "symfony/finder": "^3.0 || ^4.0",
- "symfony/options-resolver": "^3.0 || ^4.0",
+ "symfony/console": "^3.4.17 || ^4.1.6 || ^5.0",
+ "symfony/event-dispatcher": "^3.0 || ^4.0 || ^5.0",
+ "symfony/filesystem": "^3.0 || ^4.0 || ^5.0",
+ "symfony/finder": "^3.0 || ^4.0 || ^5.0",
+ "symfony/options-resolver": "^3.0 || ^4.0 || ^5.0",
"symfony/polyfill-php70": "^1.0",
"symfony/polyfill-php72": "^1.4",
- "symfony/process": "^3.0 || ^4.0",
- "symfony/stopwatch": "^3.0 || ^4.0"
+ "symfony/process": "^3.0 || ^4.0 || ^5.0",
+ "symfony/stopwatch": "^3.0 || ^4.0 || ^5.0"
},
"require-dev": {
"johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
@@ -42,8 +42,8 @@
"php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.1",
"phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.1",
"phpunitgoodpractices/traits": "^1.8",
- "symfony/phpunit-bridge": "^4.3",
- "symfony/yaml": "^3.0 || ^4.0"
+ "symfony/phpunit-bridge": "^4.3 || ^5.0",
+ "symfony/yaml": "^3.0 || ^4.0 || ^5.0"
},
"suggest": {
"ext-mbstring": "For handling non-UTF8 characters in cache signature.",
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 13234ae..defbfd6 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit ceaff36bee1ed3f1bbbedca36d2528c0826c336d
+%global gh_commit c8afb599858876e95e8ebfcd97812d383fa23f02
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -26,7 +26,7 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.16.0
+Version: 2.16.1
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -92,8 +92,8 @@ BuildRequires: php-symfony3-debug
# "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.1",
# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.1",
# "phpunitgoodpractices/traits": "^1.8",
-# "symfony/phpunit-bridge": "^4.3",
-# "symfony/yaml": "^3.0 || ^4.0"
+# "symfony/phpunit-bridge": "^4.3 || ^5.0",
+# "symfony/yaml": "^3.0 || ^4.0 || ^5.0"
# ignored as test using it fail strangely
#BuildRequires: php-composer(keradus/cli-executor) < 2
#BuildRequires: php-composer(keradus/cli-executor) >= 1.0
@@ -136,16 +136,16 @@ BuildRequires: php-fedora-autoloader-devel
# "doctrine/annotations": "^1.2",
# Bundled
# "php-cs-fixer/diff": "^1.3",
-# "symfony/console": "^3.4.17 || ^4.1.6",
-# "symfony/event-dispatcher": "^3.0 || ^4.0",
-# "symfony/filesystem": "^3.0 || ^4.0",
-# "symfony/finder": "^3.0 || ^4.0",
+# "symfony/console": "^3.4.17 || ^4.1.6 || ^5.0",
+# "symfony/event-dispatcher": "^3.0 || ^4.0 || ^5.0",
+# "symfony/filesystem": "^3.0 || ^4.0 || ^5.0",
+# "symfony/finder": "^3.0 || ^4.0 || ^5.0",
# "symfony/options-resolver": "^3.0 || ^4.0",
# "symfony/polyfill-php70": "^1.0",
# "symfony/polyfill-php72": "^1.4",
# "symfony/polyfill-xml": "^1.3",
-# "symfony/process": "^3.0 || ^4.0",
-# "symfony/stopwatch": "^3.0 || ^4.0"
+# "symfony/process": "^3.0 || ^4.0 || ^5.0",
+# "symfony/stopwatch": "^3.0 || ^4.0 || ^5.0"
Requires: php(language) >= 5.6
Requires: php-json
Requires: php-tokenizer
@@ -236,8 +236,8 @@ for i in $TESTS; do
done
# fix dev-tools path
-sed -e 's:../../../dev-tools/::' -i src/Console/Command/HelpCommand.php
-cp -pr dev-tools/ci-integration.sh src/Console/Command/
+sed -e 's:../../../ci:ci:' -i src/Console/Command/HelpCommand.php
+cp -pr ci-integration.sh src/Console/Command/
# tolerant because conditional definition in tests/TestCase.php
phpab --template fedora \
@@ -340,6 +340,9 @@ exit $ret
%changelog
+* Tue Nov 26 2019 Remi Collet <remi@remirepo.net> - 2.16.1-1
+- update to 2.16.1
+
* Mon Nov 4 2019 Remi Collet <remi@remirepo.net> - 2.16.0-1
- update to 2.16.0