summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-31 08:10:30 +0200
committerRemi Collet <remi@php.net>2023-08-31 08:10:30 +0200
commitdf6dfa22b2834b8361087fe9e89aa7f19b526147 (patch)
tree902bc386614e823df90dca4e63e04e3df8dd235d
parentac236980fa35027a7a8369f3951b2da4789f3698 (diff)
update to 3.24.0
-rw-r--r--composer.json17
-rw-r--r--installed.json96
-rw-r--r--php-cs-fixer.spec19
3 files changed, 69 insertions, 63 deletions
diff --git a/composer.json b/composer.json
index 65198ee..68a9d3d 100644
--- a/composer.json
+++ b/composer.json
@@ -98,20 +98,22 @@
"quality-assurance": [
"Composer\\Config::disableProcessTimeout",
"@install-tools --quiet",
- "@normalize",
"@self-check",
- "@mess-detector",
"@sa",
"@test"
],
+ "require-checker": "@php dev-tools/vendor/bin/composer-require-checker check composer.json --config-file .composer-require-checker.json",
"sa": "@static-analysis",
"self-check": [
"./dev-tools/check_file_permissions.sh",
- "./dev-tools/check_trailing_spaces.sh"
+ "./dev-tools/check_trailing_spaces.sh",
+ "@normalize",
+ "@require-checker"
],
"static-analysis": [
+ "@cs:check",
"@phpstan",
- "@cs:check"
+ "@mess-detector"
],
"test": "@test:all",
"test:all": [
@@ -133,12 +135,13 @@
"phpstan": "Run PHPStan analysis",
"phpstan:baseline": "Dump PHPStan baseline file - use only for updating, do not add new errors when possible",
"post-autoload-dump": "Run additional tasks after installing/updating main dependencies",
- "qa": "Run QA suite",
+ "qa": "Alias for 'quality-assurance'",
"quality-assurance": "Run QA suite",
- "sa": "Run static analysis",
+ "require-checker": "Verifies if codebase does not contain soft dependencies",
+ "sa": "Alias for 'static-analysis'",
"self-check": "Run set of self-checks ensuring repository's validity",
"static-analysis": "Run static analysis",
- "test": "Run tests",
+ "test": "Alias for 'test:all'",
"test:all": "Run all tests",
"test:coverage": "Run tool-related tests"
}
diff --git a/installed.json b/installed.json
index c23e477..fb0f85b 100644
--- a/installed.json
+++ b/installed.json
@@ -1258,17 +1258,17 @@
},
{
"name": "symfony/polyfill-ctype",
- "version": "v1.27.0",
- "version_normalized": "1.27.0.0",
+ "version": "v1.28.0",
+ "version_normalized": "1.28.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-ctype.git",
- "reference": "5bbc823adecdae860bb64756d639ecfec17b050a"
+ "reference": "ea208ce43cbb04af6867b4fdddb1bdbf84cc28cb"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/5bbc823adecdae860bb64756d639ecfec17b050a",
- "reference": "5bbc823adecdae860bb64756d639ecfec17b050a",
+ "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/ea208ce43cbb04af6867b4fdddb1bdbf84cc28cb",
+ "reference": "ea208ce43cbb04af6867b4fdddb1bdbf84cc28cb",
"shasum": ""
},
"require": {
@@ -1280,11 +1280,11 @@
"suggest": {
"ext-ctype": "For best performance"
},
- "time": "2022-11-03T14:55:06+00:00",
+ "time": "2023-01-26T09:26:14+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.27-dev"
+ "dev-main": "1.28-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1323,7 +1323,7 @@
"portable"
],
"support": {
- "source": "https://github.com/symfony/polyfill-ctype/tree/v1.27.0"
+ "source": "https://github.com/symfony/polyfill-ctype/tree/v1.28.0"
},
"funding": [
{
@@ -1343,17 +1343,17 @@
},
{
"name": "symfony/polyfill-intl-grapheme",
- "version": "v1.27.0",
- "version_normalized": "1.27.0.0",
+ "version": "v1.28.0",
+ "version_normalized": "1.28.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-grapheme.git",
- "reference": "511a08c03c1960e08a883f4cffcacd219b758354"
+ "reference": "875e90aeea2777b6f135677f618529449334a612"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/511a08c03c1960e08a883f4cffcacd219b758354",
- "reference": "511a08c03c1960e08a883f4cffcacd219b758354",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/875e90aeea2777b6f135677f618529449334a612",
+ "reference": "875e90aeea2777b6f135677f618529449334a612",
"shasum": ""
},
"require": {
@@ -1362,11 +1362,11 @@
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2022-11-03T14:55:06+00:00",
+ "time": "2023-01-26T09:26:14+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.27-dev"
+ "dev-main": "1.28-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1407,7 +1407,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.27.0"
+ "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.28.0"
},
"funding": [
{
@@ -1427,17 +1427,17 @@
},
{
"name": "symfony/polyfill-intl-normalizer",
- "version": "v1.27.0",
- "version_normalized": "1.27.0.0",
+ "version": "v1.28.0",
+ "version_normalized": "1.28.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-normalizer.git",
- "reference": "19bd1e4fcd5b91116f14d8533c57831ed00571b6"
+ "reference": "8c4ad05dd0120b6a53c1ca374dca2ad0a1c4ed92"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-normalizer/zipball/19bd1e4fcd5b91116f14d8533c57831ed00571b6",
- "reference": "19bd1e4fcd5b91116f14d8533c57831ed00571b6",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-normalizer/zipball/8c4ad05dd0120b6a53c1ca374dca2ad0a1c4ed92",
+ "reference": "8c4ad05dd0120b6a53c1ca374dca2ad0a1c4ed92",
"shasum": ""
},
"require": {
@@ -1446,11 +1446,11 @@
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2022-11-03T14:55:06+00:00",
+ "time": "2023-01-26T09:26:14+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.27-dev"
+ "dev-main": "1.28-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1494,7 +1494,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.27.0"
+ "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.28.0"
},
"funding": [
{
@@ -1514,17 +1514,17 @@
},
{
"name": "symfony/polyfill-mbstring",
- "version": "v1.27.0",
- "version_normalized": "1.27.0.0",
+ "version": "v1.28.0",
+ "version_normalized": "1.28.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-mbstring.git",
- "reference": "8ad114f6b39e2c98a8b0e3bd907732c207c2b534"
+ "reference": "42292d99c55abe617799667f454222c54c60e229"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/8ad114f6b39e2c98a8b0e3bd907732c207c2b534",
- "reference": "8ad114f6b39e2c98a8b0e3bd907732c207c2b534",
+ "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/42292d99c55abe617799667f454222c54c60e229",
+ "reference": "42292d99c55abe617799667f454222c54c60e229",
"shasum": ""
},
"require": {
@@ -1536,11 +1536,11 @@
"suggest": {
"ext-mbstring": "For best performance"
},
- "time": "2022-11-03T14:55:06+00:00",
+ "time": "2023-07-28T09:04:16+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.27-dev"
+ "dev-main": "1.28-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1580,7 +1580,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.27.0"
+ "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.28.0"
},
"funding": [
{
@@ -1600,27 +1600,27 @@
},
{
"name": "symfony/polyfill-php80",
- "version": "v1.27.0",
- "version_normalized": "1.27.0.0",
+ "version": "v1.28.0",
+ "version_normalized": "1.28.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php80.git",
- "reference": "7a6ff3f1959bb01aefccb463a0f2cd3d3d2fd936"
+ "reference": "6caa57379c4aec19c0a12a38b59b26487dcfe4b5"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/7a6ff3f1959bb01aefccb463a0f2cd3d3d2fd936",
- "reference": "7a6ff3f1959bb01aefccb463a0f2cd3d3d2fd936",
+ "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/6caa57379c4aec19c0a12a38b59b26487dcfe4b5",
+ "reference": "6caa57379c4aec19c0a12a38b59b26487dcfe4b5",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2022-11-03T14:55:06+00:00",
+ "time": "2023-01-26T09:26:14+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.27-dev"
+ "dev-main": "1.28-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1666,7 +1666,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php80/tree/v1.27.0"
+ "source": "https://github.com/symfony/polyfill-php80/tree/v1.28.0"
},
"funding": [
{
@@ -1686,27 +1686,27 @@
},
{
"name": "symfony/polyfill-php81",
- "version": "v1.27.0",
- "version_normalized": "1.27.0.0",
+ "version": "v1.28.0",
+ "version_normalized": "1.28.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php81.git",
- "reference": "707403074c8ea6e2edaf8794b0157a0bfa52157a"
+ "reference": "7581cd600fa9fd681b797d00b02f068e2f13263b"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/707403074c8ea6e2edaf8794b0157a0bfa52157a",
- "reference": "707403074c8ea6e2edaf8794b0157a0bfa52157a",
+ "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/7581cd600fa9fd681b797d00b02f068e2f13263b",
+ "reference": "7581cd600fa9fd681b797d00b02f068e2f13263b",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2022-11-03T14:55:06+00:00",
+ "time": "2023-01-26T09:26:14+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.27-dev"
+ "dev-main": "1.28-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1748,7 +1748,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php81/tree/v1.27.0"
+ "source": "https://github.com/symfony/polyfill-php81/tree/v1.28.0"
},
"funding": [
{
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index b467005..59396ea 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 35af3cbbacfa91e164b252a28ec0b644f1ed4e78
+%global gh_commit bb6c9d7945dcbf6942e151b018c44d3767e21403
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.23.0
+Version: 3.24.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -70,12 +70,12 @@ Provides: bundled(php-symfony-event-dispatcher-contracts) = v3.0.2
Provides: bundled(php-symfony-filesystem) = v6.0.19
Provides: bundled(php-symfony-finder) = v6.0.19
Provides: bundled(php-symfony-options-resolver) = v6.0.19
-Provides: bundled(php-symfony-polyfill-ctype) = v1.27.0
-Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.27.0
-Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.27.0
-Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
-Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
-Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
+Provides: bundled(php-symfony-polyfill-ctype) = v1.28.0
+Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.28.0
+Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.28.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.28.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.28.0
+Provides: bundled(php-symfony-polyfill-php81) = v1.28.0
Provides: bundled(php-symfony-process) = v6.0.19
Provides: bundled(php-symfony-service-contracts) = v3.0.2
Provides: bundled(php-symfony-stopwatch) = v6.0.19
@@ -154,6 +154,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Thu Aug 31 2023 Remi Collet <remi@remirepo.net> - 3.24.0-1
+- update to 3.24.0
+
* Fri Aug 18 2023 Remi Collet <remi@remirepo.net> - 3.23.0-1
- update to 3.23.0