summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-12 16:41:52 +0200
committerRemi Collet <remi@php.net>2022-10-12 16:41:52 +0200
commitd01388e5140be8c9fb613f6c0172d1d09c1ab9e2 (patch)
treed918e3aade468b4c9c5f1f5a926236d6a1559ad5
parent91ddc8082b35d9f14767aa1e71f5409d56ab911e (diff)
update to 3.12.0
-rw-r--r--composer.json4
-rw-r--r--installed.json56
-rw-r--r--php-cs-fixer.spec15
3 files changed, 39 insertions, 36 deletions
diff --git a/composer.json b/composer.json
index 01f09da..968425c 100644
--- a/composer.json
+++ b/composer.json
@@ -43,8 +43,8 @@
"phpspec/prophecy": "^1.15",
"phpspec/prophecy-phpunit": "^2.0",
"phpunit/phpunit": "^9.5",
- "phpunitgoodpractices/polyfill": "^1.5",
- "phpunitgoodpractices/traits": "^1.9.1",
+ "phpunitgoodpractices/polyfill": "^1.6",
+ "phpunitgoodpractices/traits": "^1.9.2",
"symfony/phpunit-bridge": "^6.0",
"symfony/yaml": "^5.4 || ^6.0"
},
diff --git a/installed.json b/installed.json
index 82087f9..4910572 100644
--- a/installed.json
+++ b/installed.json
@@ -662,17 +662,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.12",
- "version_normalized": "5.4.12.0",
+ "version": "v5.4.14",
+ "version_normalized": "5.4.14.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "c072aa8f724c3af64e2c7a96b796a4863d24dba1"
+ "reference": "984ea2c0f45f42dfed01d2f3987b187467c4b16d"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/c072aa8f724c3af64e2c7a96b796a4863d24dba1",
- "reference": "c072aa8f724c3af64e2c7a96b796a4863d24dba1",
+ "url": "https://api.github.com/repos/symfony/console/zipball/984ea2c0f45f42dfed01d2f3987b187467c4b16d",
+ "reference": "984ea2c0f45f42dfed01d2f3987b187467c4b16d",
"shasum": ""
},
"require": {
@@ -710,7 +710,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2022-08-17T13:18:05+00:00",
+ "time": "2022-10-07T08:01:20+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -744,7 +744,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.12"
+ "source": "https://github.com/symfony/console/tree/v5.4.14"
},
"funding": [
{
@@ -1004,17 +1004,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.12",
- "version_normalized": "5.4.12.0",
+ "version": "v5.4.13",
+ "version_normalized": "5.4.13.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "2d67c1f9a1937406a9be3171b4b22250c0a11447"
+ "reference": "ac09569844a9109a5966b9438fc29113ce77cf51"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/2d67c1f9a1937406a9be3171b4b22250c0a11447",
- "reference": "2d67c1f9a1937406a9be3171b4b22250c0a11447",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/ac09569844a9109a5966b9438fc29113ce77cf51",
+ "reference": "ac09569844a9109a5966b9438fc29113ce77cf51",
"shasum": ""
},
"require": {
@@ -1023,7 +1023,7 @@
"symfony/polyfill-mbstring": "~1.8",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-08-02T13:48:16+00:00",
+ "time": "2022-09-21T19:53:16+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1051,7 +1051,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.12"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.13"
},
"funding": [
{
@@ -1952,24 +1952,24 @@
},
{
"name": "symfony/stopwatch",
- "version": "v5.4.5",
- "version_normalized": "5.4.5.0",
+ "version": "v5.4.13",
+ "version_normalized": "5.4.13.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/stopwatch.git",
- "reference": "4d04b5c24f3c9a1a168a131f6cbe297155bc0d30"
+ "reference": "6df7a3effde34d81717bbef4591e5ffe32226d69"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/stopwatch/zipball/4d04b5c24f3c9a1a168a131f6cbe297155bc0d30",
- "reference": "4d04b5c24f3c9a1a168a131f6cbe297155bc0d30",
+ "url": "https://api.github.com/repos/symfony/stopwatch/zipball/6df7a3effde34d81717bbef4591e5ffe32226d69",
+ "reference": "6df7a3effde34d81717bbef4591e5ffe32226d69",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/service-contracts": "^1|^2|^3"
},
- "time": "2022-02-18T16:06:09+00:00",
+ "time": "2022-09-28T13:19:49+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1997,7 +1997,7 @@
"description": "Provides a way to profile code",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/stopwatch/tree/v5.4.5"
+ "source": "https://github.com/symfony/stopwatch/tree/v5.4.13"
},
"funding": [
{
@@ -2017,17 +2017,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.12",
- "version_normalized": "5.4.12.0",
+ "version": "v5.4.14",
+ "version_normalized": "5.4.14.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "2fc515e512d721bf31ea76bd02fe23ada4640058"
+ "reference": "089e7237497fae7a9c404d0c3aeb8db3254733e4"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/2fc515e512d721bf31ea76bd02fe23ada4640058",
- "reference": "2fc515e512d721bf31ea76bd02fe23ada4640058",
+ "url": "https://api.github.com/repos/symfony/string/zipball/089e7237497fae7a9c404d0c3aeb8db3254733e4",
+ "reference": "089e7237497fae7a9c404d0c3aeb8db3254733e4",
"shasum": ""
},
"require": {
@@ -2047,7 +2047,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2022-08-12T17:03:11+00:00",
+ "time": "2022-10-05T15:16:54+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2086,7 +2086,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.12"
+ "source": "https://github.com/symfony/string/tree/v5.4.14"
},
"funding": [
{
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 26ed51a..ae2e319 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 7dcdea3f2f5f473464e835be9be55283ff8cfdc3
+%global gh_commit eae11d945e2885d86e1c080eec1bb30a2aa27998
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.11.0
+Version: 3.12.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -61,11 +61,11 @@ Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.1.2
Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 1.1.4
-Provides: bundled(php-symfony-console) = v5.4.12
+Provides: bundled(php-symfony-console) = v5.4.14
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
Provides: bundled(php-symfony-event-dispatcher) = v5.4.9
Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.2
-Provides: bundled(php-symfony-filesystem) = v5.4.12
+Provides: bundled(php-symfony-filesystem) = v5.4.13
Provides: bundled(php-symfony-finder) = v5.4.11
Provides: bundled(php-symfony-options-resolver) = v5.4.11
Provides: bundled(php-symfony-polyfill-ctype) = v1.26.0
@@ -77,8 +77,8 @@ Provides: bundled(php-symfony-polyfill-php80) = v1.26.0
Provides: bundled(php-symfony-polyfill-php81) = v1.26.0
Provides: bundled(php-symfony-process) = v5.4.11
Provides: bundled(php-symfony-service-contracts) = v2.5.2
-Provides: bundled(php-symfony-stopwatch) = v5.4.5
-Provides: bundled(php-symfony-string) = v5.4.12
+Provides: bundled(php-symfony-stopwatch) = v5.4.13
+Provides: bundled(php-symfony-string) = v5.4.14
Provides: php-composer(friendsofphp/php-cs-fixer) = %{version}
@@ -153,6 +153,9 @@ sed -e 's:%{_datadir}:%{buildroot}%{_datadir}:' -i %{name}
%changelog
+* Wed Oct 12 2022 Remi Collet <remi@remirepo.net> - 3.12.0-1
+- update to 3.12.0
+
* Thu Sep 8 2022 Remi Collet <remi@remirepo.net> - 3.11.0-1
- update to 3.11.0