summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-26 09:57:54 +0100
committerRemi Collet <remi@remirepo.net>2020-10-26 09:57:54 +0100
commitbcfda92a995f9cd217c07f9e24137418d776a014 (patch)
treeb19117815082fb2aad8dc1c64b0812e6f488cf7b
parent1fb36fa91d4ed33ef30a7edc3c43fefee35c8a64 (diff)
raise dependency on PHP 7.2
drop dependency on symfony-polyfill
-rw-r--r--composer.json4
-rw-r--r--php-cs-fixer.spec39
2 files changed, 24 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index ee88eef..34a604e 100644
--- a/composer.json
+++ b/composer.json
@@ -42,12 +42,12 @@
"php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.1",
"phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.1",
"phpunitgoodpractices/traits": "^1.8",
- "symfony/phpunit-bridge": "^4.3 || ^5.0",
+ "symfony/phpunit-bridge": "^5.1",
"symfony/yaml": "^3.0 || ^4.0 || ^5.0"
},
"suggest": {
"ext-dom": "For handling output formats in XML",
- "ext-mbstring": "For handling non-UTF8 characters in cache signature.",
+ "ext-mbstring": "For handling non-UTF8 characters.",
"php-cs-fixer/phpunit-constraint-isidenticalstring": "For IsIdenticalString constraint.",
"php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "For XmlMatchesXsd constraint.",
"symfony/polyfill-mbstring": "When enabling `ext-mbstring` is not possible."
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 4b354c9..b58ca8d 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 83baf823a33a1cbd5416c8626935cf3f843c10b0
+%global gh_commit 1023c3458137ab052f6ff1e09621a721bfdeca13
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -26,8 +26,8 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.16.3
-Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
+Version: 2.16.4
+Release: 3%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
License: MIT
@@ -43,22 +43,19 @@ Patch0: %{name}-autoload.patch
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.2
BuildRequires: php-tokenizer
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 2)
BuildRequires: (php-composer(composer/xdebug-handler) >= 1.0 with php-composer(composer/xdebug-handler) < 2)
BuildRequires: (php-composer(doctrine/annotations) >= 1.2 with php-composer(doctrine/annotations) < 2)
-BuildRequires: (php-composer(symfony/polyfill-php70) >= 1.0 with php-composer(symfony/polyfill-php70) < 2)
-BuildRequires: (php-composer(symfony/polyfill-php72) >= 1.4 with php-composer(symfony/polyfill-php72) < 2)
BuildRequires: (php-composer(sebastian/diff) >= 1.4 with php-composer(sebastian/diff) < 2)
-# remirepo:7
+# remirepo:6
%else
BuildRequires: php-composer-semver >= 1.4
BuildRequires: php-composer-xdebug-handler >= 1.0
BuildRequires: php-doctrine-annotations >= 1.2
-BuildRequires: php-symfony-polyfill >= 1.4
BuildRequires: php-phpunit-diff >= 1.4
%endif
BuildRequires: php-symfony3-console
@@ -92,7 +89,7 @@ BuildRequires: php-symfony3-debug
# "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.1",
# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.1",
# "phpunitgoodpractices/traits": "^1.8",
-# "symfony/phpunit-bridge": "^4.3 || ^5.0",
+# "symfony/phpunit-bridge": "^5.1",
# "symfony/yaml": "^3.0 || ^4.0 || ^5.0"
# ignored as test using it fail strangely
#BuildRequires: php-composer(keradus/cli-executor) < 2
@@ -141,7 +138,7 @@ BuildRequires: php-fedora-autoloader-devel
# "symfony/polyfill-xml": "^1.3",
# "symfony/process": "^3.0 || ^4.0 || ^5.0",
# "symfony/stopwatch": "^3.0 || ^4.0 || ^5.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.2
Requires: php-json
Requires: php-tokenizer
# remirepo:1
@@ -149,15 +146,12 @@ Requires: php-tokenizer
Requires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 2)
Requires: (php-composer(composer/xdebug-handler) >= 1.2 with php-composer(composer/xdebug-handler) < 2)
Requires: (php-composer(doctrine/annotations) >= 1.2 with php-composer(doctrine/annotations) < 2)
-Requires: (php-composer(symfony/polyfill-php70) >= 1.0 with php-composer(symfony/polyfill-php70) < 2)
-Requires: (php-composer(symfony/polyfill-php72) >= 1.4 with php-composer(symfony/polyfill-php72) < 2)
Requires: (php-composer(sebastian/diff) >= 1.4 with php-composer(sebastian/diff) < 2)
-# remirepo:7
+# remirepo:6
%else
Requires: php-composer-semver >= 1.4
Requires: php-composer-xdebug-handler >= 1.2
Requires: php-doctrine-annotations >= 1.2
-Requires: php-symfony-polyfill >= 1.4
Requires: php-phpunit-diff >= 1.4
%endif
Requires: php-symfony3-console
@@ -171,7 +165,7 @@ Requires: php-symfony3-stopwatch
Requires: php-symfony3-debug
# From composer.json, "suggest": {
# "ext-dom": "For handling output formats in XML",
-# "ext-mbstring": "For handling non-UTF8 characters in cache signature.",
+# "ext-mbstring": "For handling non-UTF8 characters.",
# "php-cs-fixer/phpunit-constraint-isidenticalstring": "For IsIdenticalString constraint.",
# "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "For XmlMatchesXsd constraint.",
# "symfony/polyfill-mbstring": "When enabling `ext-mbstring` is not possible."
@@ -256,7 +250,6 @@ cat << 'EOF' | tee -a src/autoload.php
'%{php_home}/Symfony3/Component/OptionsResolver/autoload.php',
'%{php_home}/Symfony3/Component/Process/autoload.php',
'%{php_home}/Symfony3/Component/Stopwatch/autoload.php',
- '%{php_home}/Symfony/Polyfill/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
'%{php_home}/PhpCsFixer/PhpunitConstraintIsIdenticalString/autoload.php',
@@ -306,13 +299,18 @@ rm tests/Fixtures/Integration/priority/combine_consecutive_issets,no_singleline_
# Disable listener
sed -e '/<listeners>/,/<\/listeners>/d' phpunit.xml.dist >phpunit.xml
+sed -e '/ExpectDeprecationTrait/d' \
+ -i tests/Fixer/CastNotation/LowercaseCastFixerTest.php tests/Fixer/CastNotation/ShortScalarCastFixerTest.php
+# skip as rely on composer autoloader for phpunit
+rm tests/Fixer/PhpUnit/PhpUnitNamespacedFixerTest.php
+rm tests/AutoReview/ProjectCodeTest.php
# Redirect to buildroot
sed -e 's:%{php_home}:%{buildroot}%{php_home}:' -i %{name}
ret=0
# skip testFix74Deprecated as we don't use symfony/phpunit-bridge
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=2G ${2:-%{_bindir}/phpunit7} \
@@ -337,6 +335,13 @@ exit $ret
%changelog
+* Mon Oct 26 2020 Remi Collet <remi@remirepo.net> - 2.16.4-3
+- raise dependency on PHP 7.2
+- drop dependency on symfony-polyfill
+
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 2.16.4-1
+- update to 2.16.4
+
* Thu Apr 16 2020 Remi Collet <remi@remirepo.net> - 2.16.3-1
- update to 2.16.3