summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-06 10:46:05 +0100
committerRemi Collet <remi@remirepo.net>2018-02-06 10:46:05 +0100
commit948f212e09a9dc22f170eb4763dd021d52ecdf90 (patch)
tree5d982b64850e7484714aaf020c7606c0299994c3
parent2b69adee4377e19eeb490ea1c018a950daea7102 (diff)
Update to 2.10.2
use range dependencies on F27+
-rw-r--r--composer-diff.json2
-rw-r--r--composer.json10
-rw-r--r--php-cs-fixer.spec104
3 files changed, 63 insertions, 53 deletions
diff --git a/composer-diff.json b/composer-diff.json
index f8f2377..ceffd95 100644
--- a/composer-diff.json
+++ b/composer-diff.json
@@ -3,7 +3,7 @@
"description": "sebastian/diff v2 backport support for PHP5.6",
"keywords": ["diff"],
"homepage": "https://github.com/PHP-CS-Fixer",
- "license": "BSD-3-Clause|MIT",
+ "license": "BSD-3-Clause",
"authors": [
{
"name": "Sebastian Bergmann",
diff --git a/composer.json b/composer.json
index 7a14aa6..e390c12 100644
--- a/composer.json
+++ b/composer.json
@@ -57,20 +57,18 @@
"psr-4": { "PhpCsFixer\\": "src/" },
"classmap": [
"tests/Test/AbstractFixerTestCase.php",
+ "tests/Test/AbstractIntegrationCaseFactory.php",
"tests/Test/AbstractIntegrationTestCase.php",
"tests/Test/Assert/AssertTokensTrait.php",
"tests/Test/IntegrationCase.php",
"tests/Test/IntegrationCaseFactory.php",
+ "tests/Test/IntegrationCaseFactoryInterface.php",
+ "tests/Test/InternalIntegrationCaseFactory.php",
"tests/TestCase.php"
]
},
"autoload-dev": {
"psr-4": { "PhpCsFixer\\Tests\\": "tests/" }
},
- "bin": ["php-cs-fixer"],
- "extra": {
- "branch-alias": {
- "dev-master": "2.10-dev"
- }
- }
+ "bin": ["php-cs-fixer"]
}
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index dc73dd8..54d3855 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 513a3765b56dd029175f9f32995566657ee89dda
+%global gh_commit 74e4682a4073bc8bc2d4ff2b30a4873ac76cc1f1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -16,16 +16,15 @@
# Bundled this fork which is not designed for use outside of php-cs-fixer
%global gh_diff_owner PHP-CS-Fixer
-%global gh_diff_version 1.2.0
-%global gh_diff_commit f0ef6133d674137e902fdf8a6f2e8e97e14a087b
+%global gh_diff_version 1.2.1
+%global gh_diff_commit b95b8c02c58670b15612cfc60873f3f7f5290484
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.10.0
+Version: 2.10.2
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
-Group: Development/Tools
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
# git snapshot to get upstream test suite
@@ -39,37 +38,31 @@ Patch0: %{name}-autoload.patch
BuildArch: noarch
%if %{with_tests}
# For tests
-%if 0%{?fedora} >= 26
-BuildRequires: php(language) >= 7.0
-%global phpunit %{_bindir}/phpunit6
-%global gecko_min 3.0
-%global gecko_max 4
-%else
BuildRequires: php(language) >= 5.6
-%global phpunit %{_bindir}/phpunit
-%global gecko_min 2.0
-%global gecko_max 3
-%endif
BuildRequires: php-tokenizer
-BuildRequires: php-composer(composer/semver) < 2
-BuildRequires: php-composer(composer/semver) >= 1.4
-BuildRequires: php-composer(doctrine/annotations) < 2
-BuildRequires: php-composer(doctrine/annotations) >= 1.2
-BuildRequires: php-composer(gecko-packages/gecko-php-unit) < %{gecko_max}
-BuildRequires: php-composer(gecko-packages/gecko-php-unit) >= %{gecko_min}
+# remirepo:1
+%if 0%{?fedora} >= 27
+BuildRequires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 2)
+BuildRequires: (php-composer(doctrine/annotations) >= 1.2 with php-composer(doctrine/annotations) < 2)
+BuildRequires: (php-composer(gecko-packages/gecko-php-unit) >= 3.0 with php-composer(gecko-packages/gecko-php-unit) < 4)
+BuildRequires: (php-composer(symfony/polyfill-php70) >= 1.0 with php-composer(symfony/polyfill-php70) < 2)
+BuildRequires: (php-composer(symfony/polyfill-php72) >= 1.4 with php-composer(symfony/polyfill-php72) < 2)
+BuildRequires: (php-composer(sebastian/diff) >= 1.4 with php-composer(sebastian/diff) < 2)
+# remirepo:7
+%else
+BuildRequires: php-composer-semver >= 1.4
+BuildRequires: php-doctrine-annotations >= 1.2
+BuildRequires: php-gecko-packages-gecko-php-unit
+BuildRequires: php-symfony-polyfill >= 1.4
+BuildRequires: php-phpunit-diff >= 1.4
+%endif
BuildRequires: php-symfony3-console
BuildRequires: php-symfony3-event-dispatcher
BuildRequires: php-symfony3-filesystem
BuildRequires: php-symfony3-finder
BuildRequires: php-symfony3-options-resolver
-BuildRequires: php-composer(symfony/polyfill-php70) < 2
-BuildRequires: php-composer(symfony/polyfill-php70) >= 1.0
-BuildRequires: php-composer(symfony/polyfill-php72) < 2
-BuildRequires: php-composer(symfony/polyfill-php72) >= 1.4
BuildRequires: php-symfony3-process
BuildRequires: php-symfony3-stopwatch
-BuildRequires: php-composer(sebastian/diff) < 2
-BuildRequires: php-composer(sebastian/diff) >= 1.4
BuildRequires: php-mbstring
BuildRequires: php-xml
BuildRequires: php-reflection
@@ -96,13 +89,21 @@ BuildRequires: php-symfony3-debug
# ignored as test using it fail strangely
#BuildRequires: php-composer(keradus/cli-executor) < 2
#BuildRequires: php-composer(keradus/cli-executor) >= 1.0
-BuildRequires: php-composer(justinrainbow/json-schema) < 6
-BuildRequires: php-composer(justinrainbow/json-schema) >= 5.0
-BuildRequires: php-composer(mikey179/vfsStream) < 2
-BuildRequires: php-composer(mikey179/vfsStream) >= 1.6
-BuildRequires: php-composer(php-cs-fixer/accessible-object) < 2
-BuildRequires: php-composer(php-cs-fixer/accessible-object) >= 1.0
-BuildRequires: %{phpunit}
+# remirepo:1
+%if 0%{?fedora} >= 27
+BuildRequires: (php-composer(justinrainbow/json-schema) >= 5.0 with php-composer(justinrainbow/json-schema) < 6)
+BuildRequires: (php-composer(mikey179/vfsStream) >= 1.6 with php-composer(mikey179/vfsStream) < 2)
+BuildRequires: (php-composer(php-cs-fixer/accessible-object) >= 1.0 with php-composer(php-cs-fixer/accessible-object) < 2)
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.4.3
+# remirepo:7
+%else
+BuildRequires: php-justinrainbow-json-schema5
+BuildRequires: php-mikey179-vfsstream >= 1.6
+BuildRequires: php-cs-fixer-accessible-object
+%global phpunit %{_bindir}/phpunit
+BuildRequires: php-phpunit-PHPUnit >= 5.7.23
+%endif
# ignored as not yet available and optional (see TestCase.php)
#BuildRequires: php-composer(phpunitgoodpractices/traits) < 2
#BuildRequires: php-composer(phpunitgoodpractices/traits) >= 1.0
@@ -133,23 +134,27 @@ BuildRequires: php-fedora-autoloader-devel
Requires: php(language) >= 5.6
Requires: php-json
Requires: php-tokenizer
-Requires: php-composer(composer/semver) < 2
-Requires: php-composer(composer/semver) >= 1.4
-Requires: php-composer(doctrine/annotations) < 2
-Requires: php-composer(doctrine/annotations) >= 1.2
-Requires: php-composer(gecko-packages/gecko-php-unit) < %{gecko_max}
-Requires: php-composer(gecko-packages/gecko-php-unit) >= %{gecko_min}
-Requires: php-composer(sebastian/diff) < 2
-Requires: php-composer(sebastian/diff) >= 1.4
+# remirepo:1
+%if 0%{?fedora} >= 27
+Requires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 2)
+Requires: (php-composer(doctrine/annotations) >= 1.2 with php-composer(doctrine/annotations) < 2)
+Requires: (php-composer(gecko-packages/gecko-php-unit) >= 3.0 with php-composer(gecko-packages/gecko-php-unit) < 4)
+Requires: (php-composer(symfony/polyfill-php70) >= 1.0 with php-composer(symfony/polyfill-php70) < 2)
+Requires: (php-composer(symfony/polyfill-php72) >= 1.4 with php-composer(symfony/polyfill-php72) < 2)
+Requires: (php-composer(sebastian/diff) >= 1.4 with php-composer(sebastian/diff) < 2)
+# remirepo:7
+%else
+Requires: php-composer-semver >= 1.4
+Requires: php-doctrine-annotations >= 1.2
+Requires: php-gecko-packages-gecko-php-unit
+Requires: php-symfony-polyfill >= 1.4
+Requires: php-phpunit-diff >= 1.4
+%endif
Requires: php-symfony3-console
Requires: php-symfony3-event-dispatcher
Requires: php-symfony3-filesystem
Requires: php-symfony3-finder
Requires: php-symfony3-options-resolver
-Requires: php-composer(symfony/polyfill-php70) < 2
-Requires: php-composer(symfony/polyfill-php70) >= 1.0
-Requires: php-composer(symfony/polyfill-php72) < 2
-Requires: php-composer(symfony/polyfill-php72) >= 1.4
Requires: php-symfony3-process
Requires: php-symfony3-stopwatch
# Missing dependency for Console
@@ -193,10 +198,13 @@ find src -name \*rpm -delete -print
# from composer.json, "autoload" / "classmap"
TESTS="
tests/Test/AbstractFixerTestCase.php
+ tests/Test/AbstractIntegrationCaseFactory.php
tests/Test/AbstractIntegrationTestCase.php
tests/Test/Assert/AssertTokensTrait.php
tests/Test/IntegrationCase.php
tests/Test/IntegrationCaseFactory.php
+ tests/Test/IntegrationCaseFactoryInterface.php
+ tests/Test/InternalIntegrationCaseFactory.php
tests/TestCase.php
"
for i in $TESTS; do
@@ -303,6 +311,10 @@ exit $ret
%changelog
+* Tue Feb 6 2018 Remi Collet <remi@remirepo.net> - 2.10.2-1
+- Update to 2.10.2
+- use range dependencies on F27+
+
* Thu Jan 11 2018 Remi Collet <remi@remirepo.net> - 2.10.0-1
- Update to 2.10.0