summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-18 11:56:15 +0100
committerRemi Collet <remi@remirepo.net>2021-01-18 11:56:15 +0100
commit8b657d97623719b93ac9ba3991ba51e713016ede (patch)
treee7c8776e2e041f6bffa04d015952595bdfd5c012
parentef3f0ff42c6c56b6ee9d025dc84d09d971761c02 (diff)
update to 2.18.0
-rw-r--r--composer.json5
-rw-r--r--php-cs-fixer.spec11
2 files changed, 9 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 86d6076..a6aaa91 100644
--- a/composer.json
+++ b/composer.json
@@ -32,7 +32,6 @@
"symfony/stopwatch": "^3.0 || ^4.0 || ^5.0"
},
"require-dev": {
- "johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
"justinrainbow/json-schema": "^5.0",
"keradus/cli-executor": "^1.4",
"mikey179/vfsstream": "^1.6",
@@ -41,11 +40,11 @@
"php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.2",
"php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.2.1",
"phpspec/prophecy-phpunit": "^1.1 || ^2.0",
- "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20 || ^8.5.13 || ^9.4.4 <9.5",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20 || ^8.5.13 || ^9.5",
"phpunitgoodpractices/polyfill": "^1.5",
"phpunitgoodpractices/traits": "^1.9.1",
"sanmai/phpunit-legacy-adapter": "^6.4 || ^8.2.1",
- "symfony/phpunit-bridge": "^5.1",
+ "symfony/phpunit-bridge": "^5.2.1",
"symfony/yaml": "^3.0 || ^4.0 || ^5.0"
},
"suggest": {
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index be6b2d6..85ccd2f 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit bd32f5dd72cdfc7b53f54077f980e144bfa2f595
+%global gh_commit cbc5b50bfa2688a1afca20e5a8c71f058e9ccbef
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -26,7 +26,7 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.17.3
+Version: 2.18.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -89,11 +89,11 @@ BuildRequires: php-symfony3-debug
# "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.2",
# "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.2.1",
# "phpspec/prophecy-phpunit": "^1.1 || ^2.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20 || ^8.5.13 || ^9.4.4 <9.5",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20 || ^8.5.13 || ^9.5",
# "phpunitgoodpractices/polyfill": "^1.5",
# "phpunitgoodpractices/traits": "^1.9.1",
# "sanmai/phpunit-legacy-adapter": "^6.4 || ^8.2.1",
-# "symfony/phpunit-bridge": "^5.1",
+# "symfony/phpunit-bridge": "^5.2.1",
# "symfony/yaml": "^3.0 || ^4.0 || ^5.0"
# ignored as test using it fail strangely
#BuildRequires: php-composer(keradus/cli-executor) < 2
@@ -343,6 +343,9 @@ exit $ret
%changelog
+* Mon Jan 18 2021 Remi Collet <remi@remirepo.net> - 2.18.0-1
+- update to 2.18.0
+
* Mon Jan 4 2021 Remi Collet <remi@remirepo.net> - 2.17.3-1
- update to 2.17.3