summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-01-31 11:59:53 +0100
committerRemi Collet <remi@php.net>2023-01-31 11:59:53 +0100
commit8a43d617e8255f00c25dafeebc7b5951b3c7059a (patch)
treefadd9c6e6d3e4eeff4d3135e27e0ee6e0ccf84b8
parent252a5b3d3cd164f62a3b8a02cd6ad4f839a7ea45 (diff)
update to 3.14.3
-rw-r--r--composer.json19
-rw-r--r--installed.json138
-rw-r--r--php-cs-fixer.spec27
3 files changed, 94 insertions, 90 deletions
diff --git a/composer.json b/composer.json
index 218dc43..cc4e754 100644
--- a/composer.json
+++ b/composer.json
@@ -17,35 +17,36 @@
"php": "^7.4 || ^8.0",
"ext-json": "*",
"ext-tokenizer": "*",
- "composer/semver": "^3.2",
+ "composer/semver": "^3.3",
"composer/xdebug-handler": "^3.0.3",
- "doctrine/annotations": "^1.13",
+ "doctrine/annotations": "^2",
+ "doctrine/lexer": "^2 || ^3",
"sebastian/diff": "^4.0",
"symfony/console": "^5.4 || ^6.0",
"symfony/event-dispatcher": "^5.4 || ^6.0",
"symfony/filesystem": "^5.4 || ^6.0",
"symfony/finder": "^5.4 || ^6.0",
"symfony/options-resolver": "^5.4 || ^6.0",
- "symfony/polyfill-mbstring": "^1.23",
- "symfony/polyfill-php80": "^1.25",
- "symfony/polyfill-php81": "^1.25",
+ "symfony/polyfill-mbstring": "^1.27",
+ "symfony/polyfill-php80": "^1.27",
+ "symfony/polyfill-php81": "^1.27",
"symfony/process": "^5.4 || ^6.0",
"symfony/stopwatch": "^5.4 || ^6.0"
},
"require-dev": {
"justinrainbow/json-schema": "^5.2",
"keradus/cli-executor": "^2.0",
- "mikey179/vfsstream": "^1.6.10",
- "php-coveralls/php-coveralls": "^2.5.2",
+ "mikey179/vfsstream": "^1.6.11",
+ "php-coveralls/php-coveralls": "^2.5.3",
"php-cs-fixer/accessible-object": "^1.1",
"php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.2",
"php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.2.1",
- "phpspec/prophecy": "^1.15",
+ "phpspec/prophecy": "^1.16",
"phpspec/prophecy-phpunit": "^2.0",
"phpunit/phpunit": "^9.5",
"phpunitgoodpractices/polyfill": "^1.6",
"phpunitgoodpractices/traits": "^1.9.2",
- "symfony/phpunit-bridge": "^6.0",
+ "symfony/phpunit-bridge": "^6.2.3",
"symfony/yaml": "^5.4 || ^6.0"
},
"suggest": {
diff --git a/installed.json b/installed.json
index 2ab6db8..c52c534 100644
--- a/installed.json
+++ b/installed.json
@@ -229,37 +229,37 @@
},
{
"name": "doctrine/annotations",
- "version": "1.14.2",
- "version_normalized": "1.14.2.0",
+ "version": "2.0.0",
+ "version_normalized": "2.0.0.0",
"source": {
"type": "git",
"url": "https://github.com/doctrine/annotations.git",
- "reference": "ad785217c1e9555a7d6c6c8c9f406395a5e2882b"
+ "reference": "d02c9f3742044e17d5fa8d28d8402a2d95c33302"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/doctrine/annotations/zipball/ad785217c1e9555a7d6c6c8c9f406395a5e2882b",
- "reference": "ad785217c1e9555a7d6c6c8c9f406395a5e2882b",
+ "url": "https://api.github.com/repos/doctrine/annotations/zipball/d02c9f3742044e17d5fa8d28d8402a2d95c33302",
+ "reference": "d02c9f3742044e17d5fa8d28d8402a2d95c33302",
"shasum": ""
},
"require": {
- "doctrine/lexer": "^1 || ^2",
+ "doctrine/lexer": "^2 || ^3",
"ext-tokenizer": "*",
- "php": "^7.1 || ^8.0",
+ "php": "^7.2 || ^8.0",
"psr/cache": "^1 || ^2 || ^3"
},
"require-dev": {
- "doctrine/cache": "^1.11 || ^2.0",
- "doctrine/coding-standard": "^9 || ^10",
- "phpstan/phpstan": "~1.4.10 || ^1.8.0",
+ "doctrine/cache": "^2.0",
+ "doctrine/coding-standard": "^10",
+ "phpstan/phpstan": "^1.8.0",
"phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
- "symfony/cache": "^4.4 || ^5.4 || ^6",
+ "symfony/cache": "^5.4 || ^6",
"vimeo/psalm": "^4.10"
},
"suggest": {
"php": "PHP 8.0 or higher comes with attributes, a native replacement for annotations"
},
- "time": "2022-12-15T06:48:22+00:00",
+ "time": "2022-12-19T18:17:20+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -302,7 +302,7 @@
],
"support": {
"issues": "https://github.com/doctrine/annotations/issues",
- "source": "https://github.com/doctrine/annotations/tree/1.14.2"
+ "source": "https://github.com/doctrine/annotations/tree/2.0.0"
},
"install-path": "../doctrine/annotations"
},
@@ -713,17 +713,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.17",
- "version_normalized": "5.4.17.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "58422fdcb0e715ed05b385f70d3e8b5ed4bbd45f"
+ "reference": "dccb8d251a9017d5994c988b034d3e18aaabf740"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/58422fdcb0e715ed05b385f70d3e8b5ed4bbd45f",
- "reference": "58422fdcb0e715ed05b385f70d3e8b5ed4bbd45f",
+ "url": "https://api.github.com/repos/symfony/console/zipball/dccb8d251a9017d5994c988b034d3e18aaabf740",
+ "reference": "dccb8d251a9017d5994c988b034d3e18aaabf740",
"shasum": ""
},
"require": {
@@ -761,7 +761,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2022-12-28T14:15:31+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -795,7 +795,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.17"
+ "source": "https://github.com/symfony/console/tree/v5.4.19"
},
"funding": [
{
@@ -885,17 +885,17 @@
},
{
"name": "symfony/event-dispatcher",
- "version": "v5.4.17",
- "version_normalized": "5.4.17.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/event-dispatcher.git",
- "reference": "8e18a9d559eb8ebc2220588f1faa726a2fcd31c9"
+ "reference": "abf49cc084c087d94b4cb939c3f3672971784e0c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/event-dispatcher/zipball/8e18a9d559eb8ebc2220588f1faa726a2fcd31c9",
- "reference": "8e18a9d559eb8ebc2220588f1faa726a2fcd31c9",
+ "url": "https://api.github.com/repos/symfony/event-dispatcher/zipball/abf49cc084c087d94b4cb939c3f3672971784e0c",
+ "reference": "abf49cc084c087d94b4cb939c3f3672971784e0c",
"shasum": ""
},
"require": {
@@ -925,7 +925,7 @@
"symfony/dependency-injection": "",
"symfony/http-kernel": ""
},
- "time": "2022-12-12T15:54:21+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -953,7 +953,7 @@
"description": "Provides tools that allow your application components to communicate with each other by dispatching events and listening to them",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/event-dispatcher/tree/v5.4.17"
+ "source": "https://github.com/symfony/event-dispatcher/tree/v5.4.19"
},
"funding": [
{
@@ -1055,17 +1055,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.13",
- "version_normalized": "5.4.13.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "ac09569844a9109a5966b9438fc29113ce77cf51"
+ "reference": "648bfaca6a494f3e22378123bcee2894045dc9d8"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/ac09569844a9109a5966b9438fc29113ce77cf51",
- "reference": "ac09569844a9109a5966b9438fc29113ce77cf51",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/648bfaca6a494f3e22378123bcee2894045dc9d8",
+ "reference": "648bfaca6a494f3e22378123bcee2894045dc9d8",
"shasum": ""
},
"require": {
@@ -1074,7 +1074,7 @@
"symfony/polyfill-mbstring": "~1.8",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-09-21T19:53:16+00:00",
+ "time": "2023-01-14T19:14:44+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1102,7 +1102,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.13"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.19"
},
"funding": [
{
@@ -1122,17 +1122,17 @@
},
{
"name": "symfony/finder",
- "version": "v5.4.17",
- "version_normalized": "5.4.17.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "40c08632019838dfb3350f18cf5563b8080055fc"
+ "reference": "6071aebf810ad13fe8200c224f36103abb37cf1f"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/40c08632019838dfb3350f18cf5563b8080055fc",
- "reference": "40c08632019838dfb3350f18cf5563b8080055fc",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/6071aebf810ad13fe8200c224f36103abb37cf1f",
+ "reference": "6071aebf810ad13fe8200c224f36103abb37cf1f",
"shasum": ""
},
"require": {
@@ -1140,7 +1140,7 @@
"symfony/deprecation-contracts": "^2.1|^3",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-12-22T10:31:03+00:00",
+ "time": "2023-01-14T19:14:44+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1168,7 +1168,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v5.4.17"
+ "source": "https://github.com/symfony/finder/tree/v5.4.19"
},
"funding": [
{
@@ -1188,17 +1188,17 @@
},
{
"name": "symfony/options-resolver",
- "version": "v5.4.11",
- "version_normalized": "5.4.11.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/options-resolver.git",
- "reference": "54f14e36aa73cb8f7261d7686691fd4d75ea2690"
+ "reference": "b03c99236445492f20c61666e8f7e5d388b078e5"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/options-resolver/zipball/54f14e36aa73cb8f7261d7686691fd4d75ea2690",
- "reference": "54f14e36aa73cb8f7261d7686691fd4d75ea2690",
+ "url": "https://api.github.com/repos/symfony/options-resolver/zipball/b03c99236445492f20c61666e8f7e5d388b078e5",
+ "reference": "b03c99236445492f20c61666e8f7e5d388b078e5",
"shasum": ""
},
"require": {
@@ -1207,7 +1207,7 @@
"symfony/polyfill-php73": "~1.0",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-07-20T13:00:38+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1240,7 +1240,7 @@
"options"
],
"support": {
- "source": "https://github.com/symfony/options-resolver/tree/v5.4.11"
+ "source": "https://github.com/symfony/options-resolver/tree/v5.4.19"
},
"funding": [
{
@@ -1852,24 +1852,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.11",
- "version_normalized": "5.4.11.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "6e75fe6874cbc7e4773d049616ab450eff537bf1"
+ "reference": "c5ba874c9b636dbccf761e22ce750e88ec3f55e1"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/6e75fe6874cbc7e4773d049616ab450eff537bf1",
- "reference": "6e75fe6874cbc7e4773d049616ab450eff537bf1",
+ "url": "https://api.github.com/repos/symfony/process/zipball/c5ba874c9b636dbccf761e22ce750e88ec3f55e1",
+ "reference": "c5ba874c9b636dbccf761e22ce750e88ec3f55e1",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-06-27T16:58:25+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1897,7 +1897,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.11"
+ "source": "https://github.com/symfony/process/tree/v5.4.19"
},
"funding": [
{
@@ -2003,24 +2003,24 @@
},
{
"name": "symfony/stopwatch",
- "version": "v5.4.13",
- "version_normalized": "5.4.13.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/stopwatch.git",
- "reference": "6df7a3effde34d81717bbef4591e5ffe32226d69"
+ "reference": "bd2b066090fd6a67039371098fa25a84cb2679ec"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/stopwatch/zipball/6df7a3effde34d81717bbef4591e5ffe32226d69",
- "reference": "6df7a3effde34d81717bbef4591e5ffe32226d69",
+ "url": "https://api.github.com/repos/symfony/stopwatch/zipball/bd2b066090fd6a67039371098fa25a84cb2679ec",
+ "reference": "bd2b066090fd6a67039371098fa25a84cb2679ec",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/service-contracts": "^1|^2|^3"
},
- "time": "2022-09-28T13:19:49+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2048,7 +2048,7 @@
"description": "Provides a way to profile code",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/stopwatch/tree/v5.4.13"
+ "source": "https://github.com/symfony/stopwatch/tree/v5.4.19"
},
"funding": [
{
@@ -2068,17 +2068,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.17",
- "version_normalized": "5.4.17.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "55733a8664b8853b003e70251c58bc8cb2d82a6b"
+ "reference": "0a01071610fd861cc160dfb7e2682ceec66064cb"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/55733a8664b8853b003e70251c58bc8cb2d82a6b",
- "reference": "55733a8664b8853b003e70251c58bc8cb2d82a6b",
+ "url": "https://api.github.com/repos/symfony/string/zipball/0a01071610fd861cc160dfb7e2682ceec66064cb",
+ "reference": "0a01071610fd861cc160dfb7e2682ceec66064cb",
"shasum": ""
},
"require": {
@@ -2098,7 +2098,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2022-12-12T15:54:21+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2137,7 +2137,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.17"
+ "source": "https://github.com/symfony/string/tree/v5.4.19"
},
"funding": [
{
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 9427789..19f8c94 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -1,7 +1,7 @@
# remirepo/fedora spec file for php-cs-fixer
#
# Copyright (c) 2016-2023 Remi Collet
-# License: CC-BY-SA
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 3952f08a81bd3b1b15e11c3de0b6bf037faa8496
+%global gh_commit b418036b95b4936a33fe906245d3044395935e73
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.13.2
+Version: 3.14.3
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -56,20 +56,20 @@ Provides: bundled(php-sebastian-diff) = 4.0.4
Provides: bundled(php-composer-pcre) = 3.1.0
Provides: bundled(php-composer-semver) = 3.3.2
Provides: bundled(php-composer-xdebug-handler) = 3.0.3
-Provides: bundled(php-doctrine-annotations) = 1.14.2
+Provides: bundled(php-doctrine-annotations) = 2.0.0
Provides: bundled(php-doctrine-deprecations) = v1.0.0
Provides: bundled(php-doctrine-lexer) = 2.1.0
Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.1.2
Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 1.1.4
-Provides: bundled(php-symfony-console) = v5.4.17
+Provides: bundled(php-symfony-console) = v5.4.19
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
-Provides: bundled(php-symfony-event-dispatcher) = v5.4.17
+Provides: bundled(php-symfony-event-dispatcher) = v5.4.19
Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.2
-Provides: bundled(php-symfony-filesystem) = v5.4.13
-Provides: bundled(php-symfony-finder) = v5.4.17
-Provides: bundled(php-symfony-options-resolver) = v5.4.11
+Provides: bundled(php-symfony-filesystem) = v5.4.19
+Provides: bundled(php-symfony-finder) = v5.4.19
+Provides: bundled(php-symfony-options-resolver) = v5.4.19
Provides: bundled(php-symfony-polyfill-ctype) = v1.27.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.27.0
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.27.0
@@ -77,10 +77,10 @@ Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
Provides: bundled(php-symfony-polyfill-php73) = v1.27.0
Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
-Provides: bundled(php-symfony-process) = v5.4.11
+Provides: bundled(php-symfony-process) = v5.4.19
Provides: bundled(php-symfony-service-contracts) = v2.5.2
-Provides: bundled(php-symfony-stopwatch) = v5.4.13
-Provides: bundled(php-symfony-string) = v5.4.17
+Provides: bundled(php-symfony-stopwatch) = v5.4.19
+Provides: bundled(php-symfony-string) = v5.4.19
Provides: php-composer(friendsofphp/php-cs-fixer) = %{version}
@@ -155,6 +155,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Tue Jan 31 2023 Remi Collet <remi@remirepo.net> - 3.14.3-1
+- update to 3.14.3
+
* Tue Jan 3 2023 Remi Collet <remi@remirepo.net> - 3.13.2-1
- update to 3.13.2