summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-09-30 15:45:59 +0200
committerRemi Collet <remi@php.net>2023-09-30 15:45:59 +0200
commit7e65b3c4cd6e404390a613d11138198c571e4e00 (patch)
treec0e4ceb64947c36d9dfabaec45615e63da0ea6be
parent96c88b4a27cc87f766b9683272c53115730dfee6 (diff)
update to 3.34.0
-rw-r--r--composer.json5
-rw-r--r--php-cs-fixer.spec7
2 files changed, 9 insertions, 3 deletions
diff --git a/composer.json b/composer.json
index 388e4e7..2012ded 100644
--- a/composer.json
+++ b/composer.json
@@ -54,6 +54,9 @@
"symfony/phpunit-bridge": "^6.2.3",
"symfony/yaml": "^5.4 || ^6.0"
},
+ "conflict": {
+ "stevebauman/unfinalize": "*"
+ },
"suggest": {
"ext-dom": "For handling output formats in XML",
"ext-mbstring": "For handling non-UTF8 characters."
@@ -81,7 +84,7 @@
"post-autoload-dump": [
"@install-tools"
],
- "cs:check": "@php php-cs-fixer fix --dry-run --diff",
+ "cs:check": "@php php-cs-fixer check --diff",
"cs:fix": "@php php-cs-fixer fix",
"cs:fix:parallel": "echo '🔍 Will run in batches of 50 files.'; if [[ -f .php-cs-fixer.php ]]; then FIXER_CONFIG=.php-cs-fixer.php; else FIXER_CONFIG=.php-cs-fixer.dist.php; fi; php php-cs-fixer list-files --config=$FIXER_CONFIG | xargs -n 50 -P 8 php php-cs-fixer fix --config=$FIXER_CONFIG --path-mode intersection 2> /dev/null",
"docs": "@php dev-tools/doc.php",
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 0f42b27..ee45733 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 983a24f6fe16bdcfd5af02b14a7683e3fb1b882e
+%global gh_commit 7c7a4ad2ed8fe50df3e25528218b13d383608f23
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.31.0
+Version: 3.34.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -150,6 +150,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Sat Sep 30 2023 Remi Collet <remi@remirepo.net> - 3.34.0-1
+- update to 3.34.0
+
* Fri Sep 29 2023 Remi Collet <remi@remirepo.net> - 3.31.0-1
- update to 3.31.0