summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-06-04 10:28:23 +0200
committerRemi Collet <remi@remirepo.net>2018-06-04 10:28:23 +0200
commit72982dc68b82a35de18c0721ad1a8b40c656a586 (patch)
tree19fd31d69130c6a3558e0975619b9e21fb7a9f8b
parent2626c5b4cb038d39b6d345032feffc1d457bddf6 (diff)
update to 2.12.0
add dependency on composer/xdebug-handler add build dependency on php-cs-fixer/phpunit-constraint-isidenticalstring add build dependency on php-cs-fixer/phpunit-constraint-xmlmatchesxsd
-rw-r--r--composer.json21
-rw-r--r--php-cs-fixer-autoload.patch20
-rw-r--r--php-cs-fixer.spec48
3 files changed, 54 insertions, 35 deletions
diff --git a/composer.json b/composer.json
index 16eb3d8..d352a34 100644
--- a/composer.json
+++ b/composer.json
@@ -18,6 +18,7 @@
"ext-json": "*",
"ext-tokenizer": "*",
"composer/semver": "^1.4",
+ "composer/xdebug-handler": "^1.0",
"doctrine/annotations": "^1.2",
"php-cs-fixer/diff": "^1.3",
"symfony/console": "^3.2 || ^4.0",
@@ -36,25 +37,28 @@
"require-dev": {
"johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
"justinrainbow/json-schema": "^5.0",
- "keradus/cli-executor": "^1.0",
+ "keradus/cli-executor": "^1.1",
"mikey179/vfsStream": "^1.6",
- "php-coveralls/php-coveralls": "^2.0",
+ "php-coveralls/php-coveralls": "^2.1",
"php-cs-fixer/accessible-object": "^1.0",
- "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.0",
- "phpunitgoodpractices/traits": "^1.3.1",
- "symfony/phpunit-bridge": "^3.2.2 || ^4.0"
+ "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.0",
+ "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.0",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1",
+ "phpunitgoodpractices/traits": "^1.4",
+ "symfony/phpunit-bridge": "^4.0"
},
"suggest": {
"ext-mbstring": "For handling non-UTF8 characters in cache signature.",
+ "php-cs-fixer/phpunit-constraint-isidenticalstring": "For IsIdenticalString constraint.",
+ "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "For XmlMatchesXsd constraint.",
"symfony/polyfill-mbstring": "When enabling `ext-mbstring` is not possible."
},
"config": {
- "optimize-autoloader": true,
"sort-packages": true
},
"extra": {
"branch-alias": {
- "dev-master": "2.11-dev"
+ "dev-master": "2.12-dev"
}
},
"autoload": {
@@ -66,9 +70,6 @@
"tests/Test/AbstractIntegrationCaseFactory.php",
"tests/Test/AbstractIntegrationTestCase.php",
"tests/Test/Assert/AssertTokensTrait.php",
- "tests/Test/Constraint/SameStringsConstraint.php",
- "tests/Test/Constraint/SameStringsConstraintForV5.php",
- "tests/Test/Constraint/SameStringsConstraintForV7.php",
"tests/Test/IntegrationCase.php",
"tests/Test/IntegrationCaseFactory.php",
"tests/Test/IntegrationCaseFactoryInterface.php",
diff --git a/php-cs-fixer-autoload.patch b/php-cs-fixer-autoload.patch
index 262a233..209084c 100644
--- a/php-cs-fixer-autoload.patch
+++ b/php-cs-fixer-autoload.patch
@@ -1,7 +1,7 @@
diff -up ./php-cs-fixer.rpm ./php-cs-fixer
---- ./php-cs-fixer.rpm 2018-03-21 07:08:49.801165194 +0100
-+++ ./php-cs-fixer 2018-03-21 07:09:08.527252780 +0100
-@@ -39,25 +39,7 @@ set_error_handler(function ($severity, $
+--- ./php-cs-fixer.rpm 2018-06-04 08:32:38.764785724 +0200
++++ ./php-cs-fixer 2018-06-04 08:33:04.580971680 +0200
+@@ -44,25 +44,7 @@ set_error_handler(function ($severity, $
}
});
@@ -26,12 +26,12 @@ diff -up ./php-cs-fixer.rpm ./php-cs-fixer
-unset($require);
+require_once '/usr/share/php/PhpCsFixer/autoload.php';
+ use Composer\XdebugHandler\XdebugHandler;
use PhpCsFixer\Console\Application;
-
diff -up ./src/Console/Command/HelpCommand.php.rpm ./src/Console/Command/HelpCommand.php
---- ./src/Console/Command/HelpCommand.php.rpm 2018-03-21 07:06:08.000000000 +0100
-+++ ./src/Console/Command/HelpCommand.php 2018-03-21 07:08:49.801165194 +0100
-@@ -368,6 +368,8 @@ EOF
+--- ./src/Console/Command/HelpCommand.php.rpm 2018-06-04 08:27:41.000000000 +0200
++++ ./src/Console/Command/HelpCommand.php 2018-06-04 08:32:38.764785724 +0200
+@@ -379,6 +379,8 @@ EOF
{
static $version = null;
@@ -41,9 +41,9 @@ diff -up ./src/Console/Command/HelpCommand.php.rpm ./src/Console/Command/HelpCom
return $version;
}
diff -up ./tests/AutoReview/ProjectCodeTest.php.rpm ./tests/AutoReview/ProjectCodeTest.php
---- ./tests/AutoReview/ProjectCodeTest.php.rpm 2018-03-21 07:06:08.000000000 +0100
-+++ ./tests/AutoReview/ProjectCodeTest.php 2018-03-21 07:08:49.801165194 +0100
-@@ -433,8 +433,11 @@ final class ProjectCodeTest extends Test
+--- ./tests/AutoReview/ProjectCodeTest.php.rpm 2018-06-04 08:27:41.000000000 +0200
++++ ./tests/AutoReview/ProjectCodeTest.php 2018-06-04 08:32:38.764785724 +0200
+@@ -413,8 +413,11 @@ final class ProjectCodeTest extends Test
->files()
->name('*.php')
->in(__DIR__.'/../../src')
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 0530e10..28d53b2 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit ad94441c17b8ef096e517acccdbf3238af8a2da8
+%global gh_commit a53f39a72cf0baa03909fae779a4de6d3772c74f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -26,7 +26,7 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.11.1
+Version: 2.12.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -48,6 +48,7 @@ BuildRequires: php-tokenizer
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 2)
+BuildRequires: (php-composer(composer/xdebug-handler) >= 1.0 with php-composer(composer/xdebug-handler) < 2)
BuildRequires: (php-composer(doctrine/annotations) >= 1.2 with php-composer(doctrine/annotations) < 2)
BuildRequires: (php-composer(symfony/polyfill-php70) >= 1.0 with php-composer(symfony/polyfill-php70) < 2)
BuildRequires: (php-composer(symfony/polyfill-php72) >= 1.4 with php-composer(symfony/polyfill-php72) < 2)
@@ -55,6 +56,7 @@ BuildRequires: (php-composer(sebastian/diff) >= 1.4 with php-com
# remirepo:6
%else
BuildRequires: php-composer-semver >= 1.4
+BuildRequires: php-composer-xdebug-handler >= 1.0
BuildRequires: php-doctrine-annotations >= 1.2
BuildRequires: php-symfony-polyfill >= 1.4
BuildRequires: php-phpunit-diff >= 1.4
@@ -81,14 +83,16 @@ BuildRequires: php-symfony3-debug
# From composer.json, "require-dev": {
# NOTICE: listener disabled during test suite
# "johnkary/phpunit-speedtrap": "^1.1 || ^2.0 || ^3.0",
-# "keradus/cli-executor": "^1.0",
+# "keradus/cli-executor": "^1.1",
# "justinrainbow/json-schema": "^5.0",
# "mikey179/vfsStream": "^1.6",
-# "php-coveralls/php-coveralls": "^2.0",
+# "php-coveralls/php-coveralls": "^2.1",
# "php-cs-fixer/accessible-object": "^1.0",
-# "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.0",
-# "phpunitgoodpractices/traits": "^1.3.1",
-# "symfony/phpunit-bridge": "^3.2.2 || ^4.0"
+# "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.0",
+# "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1",
+# "phpunitgoodpractices/traits": "^1.4",
+# "symfony/phpunit-bridge": "^4.0"
# ignored as test using it fail strangely
#BuildRequires: php-composer(keradus/cli-executor) < 2
#BuildRequires: php-composer(keradus/cli-executor) >= 1.0
@@ -97,25 +101,28 @@ BuildRequires: php-symfony3-debug
BuildRequires: (php-composer(justinrainbow/json-schema) >= 5.0 with php-composer(justinrainbow/json-schema) < 6)
BuildRequires: (php-composer(mikey179/vfsStream) >= 1.6 with php-composer(mikey179/vfsStream) < 2)
BuildRequires: (php-composer(php-cs-fixer/accessible-object) >= 1.0 with php-composer(php-cs-fixer/accessible-object) < 2)
+BuildRequires: (php-composer(php-cs-fixer/phpunit-constraint-isidenticalstring) >= 1.0 with php-composer(php-cs-fixer/phpunit-constraint-isidenticalstring) < 2)
+BuildRequires: (php-composer(php-cs-fixer/phpunit-constraint-xmlmatchesxsd) >= 1.0 with php-composer(php-cs-fixer/phpunit-constraint-xmlmatchesxsd) < 2)
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.0
+BuildRequires: phpunit7 >= 7.1
%else
%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.4.3
+BuildRequires: phpunit6 >= 6.5.8
%endif
# remirepo:7
%else
BuildRequires: php-justinrainbow-json-schema5
BuildRequires: php-mikey179-vfsstream >= 1.6
BuildRequires: php-cs-fixer-accessible-object
+BuildRequires: php-cs-fixer-phpunit-constraint-isidenticalstring
+BuildRequires: php-cs-fixer-phpunit-constraint-xmlmatchesxsd
%global phpunit %{_bindir}/phpunit
BuildRequires: php-phpunit-PHPUnit >= 5.7.23
%endif
# ignored as not yet available and optional (see TestCase.php)
#BuildRequires: php-composer(phpunitgoodpractices/traits) < 2
#BuildRequires: php-composer(phpunitgoodpractices/traits) >= 1.0
-BuildRequires: php-symfony3-phpunit-bridge >= 3.2.2
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -125,6 +132,7 @@ BuildRequires: php-fedora-autoloader-devel
# "ext-json": "*",
# "ext-tokenizer": "*",
# "composer/semver": "^1.4",
+# "composer/xdebug-handler": "^1.0",
# "doctrine/annotations": "^1.2",
# Bundled
# "php-cs-fixer/diff": "^1.3",
@@ -144,13 +152,15 @@ Requires: php-tokenizer
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 2)
+Requires: (php-composer(composer/xdebug-handler) >= 1.0 with php-composer(composer/xdebug-handler) < 2)
Requires: (php-composer(doctrine/annotations) >= 1.2 with php-composer(doctrine/annotations) < 2)
Requires: (php-composer(symfony/polyfill-php70) >= 1.0 with php-composer(symfony/polyfill-php70) < 2)
Requires: (php-composer(symfony/polyfill-php72) >= 1.4 with php-composer(symfony/polyfill-php72) < 2)
Requires: (php-composer(sebastian/diff) >= 1.4 with php-composer(sebastian/diff) < 2)
-# remirepo:6
+# remirepo:7
%else
Requires: php-composer-semver >= 1.4
+Requires: php-composer-xdebug-handler >= 1.0
Requires: php-doctrine-annotations >= 1.2
Requires: php-symfony-polyfill >= 1.4
Requires: php-phpunit-diff >= 1.4
@@ -166,6 +176,8 @@ Requires: php-symfony3-stopwatch
Requires: php-symfony3-debug
# From composer.json, "suggest": {
# "ext-mbstring": "For handling non-UTF8 characters in cache signature.",
+# "php-cs-fixer/phpunit-constraint-isidenticalstring": "For IsIdenticalString constraint.",
+# "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "For XmlMatchesXsd constraint.",
# "symfony/polyfill-mbstring": "When enabling `ext-mbstring` is not possible."
Requires: php-mbstring
# From phpcompatinfo report for version 2.4.0
@@ -206,9 +218,6 @@ TESTS="
tests/Test/AbstractIntegrationCaseFactory.php
tests/Test/AbstractIntegrationTestCase.php
tests/Test/Assert/AssertTokensTrait.php
- tests/Test/Constraint/SameStringsConstraint.php
- tests/Test/Constraint/SameStringsConstraintForV5.php
- tests/Test/Constraint/SameStringsConstraintForV7.php
tests/Test/IntegrationCase.php
tests/Test/IntegrationCaseFactory.php
tests/Test/IntegrationCaseFactoryInterface.php
@@ -235,6 +244,7 @@ cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Autoload::addPsr4('PhpCsFixer\\', __DIR__);
\Fedora\Autoloader\Dependencies::required([
'%{php_home}//Composer/Semver/autoload.php',
+ '%{php_home}/Composer/XdebugHandler/autoload.php',
'%{php_home}/Doctrine/Common/Annotations/autoload.php',
'%{php_home}/Symfony3/Component/Console/autoload.php',
'%{php_home}/Symfony3/Component/EventDispatcher/autoload.php',
@@ -268,10 +278,11 @@ cat << 'EOF' | tee vendor/autoload.php
<?php
// Force version for local, when both versions are available
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Symfony3/Bridge/PhpUnit/autoload.php',
'%{php_home}/org/bovigo/vfs/autoload.php',
'%{php_home}/JsonSchema5/autoload.php',
'%{php_home}/PhpCsFixer/AccessibleObject/autoload.php',
+ '%{php_home}/PhpCsFixer/PhpunitConstraintIsIdenticalString/autoload.php',
+ '%{php_home}/PhpCsFixer/PhpunitConstraintXmlMatchesXsd/autoload.php',
'%{buildroot}%{php_home}/PhpCsFixer/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('PhpCsFixer\\Tests\\', dirname(__DIR__) . '/tests');
@@ -283,6 +294,7 @@ sed -e "/README.rst/s:__DIR__.*':'$PWD/README.rst':" \
# test using keradus/cli-executor
rm tests/Smoke/CiIntegrationTest.php
rm tests/Smoke/StdinTest.php
+rm tests/Smoke/InstallViaComposerTest.php
# strange failure
rm tests/Fixtures/Integration/priority/combine_consecutive_issets,no_singleline_whitespace_before_semicolons.test
@@ -315,6 +327,12 @@ exit $ret
%changelog
+* Mon Jun 4 2018 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+- add dependency on composer/xdebug-handler
+- add build dependency on php-cs-fixer/phpunit-constraint-isidenticalstring
+- add build dependency on php-cs-fixer/phpunit-constraint-xmlmatchesxsd
+
* Thu Mar 22 2018 Remi Collet <remi@remirepo.net> - 2.11.1-1
- update to 2.11.1