summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-08 10:52:36 +0100
committerRemi Collet <remi@remirepo.net>2020-12-08 10:52:36 +0100
commit7190ee034d1373aed7762fde2163936632a57ca1 (patch)
tree74ad7d549907a6a25261c87f167fd14415039748
parentc33585271df8d4ed9f348fa623820c7a37ea8ff8 (diff)
update to 2.17.0
-rw-r--r--composer.json8
-rw-r--r--php-cs-fixer-autoload.patch19
-rw-r--r--php-cs-fixer.spec14
3 files changed, 28 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index 6ff6822..ccc692a 100644
--- a/composer.json
+++ b/composer.json
@@ -14,7 +14,7 @@
}
],
"require": {
- "php": "^7.1",
+ "php": "^5.6 || ^7.0 || ^8.0",
"ext-json": "*",
"ext-tokenizer": "*",
"composer/semver": "^1.4 || ^2.0 || ^3.0",
@@ -41,6 +41,7 @@
"php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.2",
"php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.2.1",
"phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.1",
+ "phpunitgoodpractices/polyfill": "^1.5",
"phpunitgoodpractices/traits": "^1.9.1",
"symfony/phpunit-bridge": "^5.1",
"symfony/yaml": "^3.0 || ^4.0 || ^5.0"
@@ -55,6 +56,11 @@
"config": {
"sort-packages": true
},
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.17-dev"
+ }
+ },
"autoload": {
"psr-4": {
"PhpCsFixer\\": "src/"
diff --git a/php-cs-fixer-autoload.patch b/php-cs-fixer-autoload.patch
index 632dd31..e24ef55 100644
--- a/php-cs-fixer-autoload.patch
+++ b/php-cs-fixer-autoload.patch
@@ -1,7 +1,7 @@
diff -up ./php-cs-fixer.rpm ./php-cs-fixer
---- ./php-cs-fixer.rpm 2019-11-04 09:02:13.808580217 +0100
-+++ ./php-cs-fixer 2019-11-04 09:03:24.388258652 +0100
-@@ -43,38 +43,7 @@ set_error_handler(function ($severity, $
+--- ./php-cs-fixer.rpm 2020-12-08 10:29:13.190515695 +0100
++++ ./php-cs-fixer 2020-12-08 10:30:26.191258296 +0100
+@@ -52,39 +52,7 @@ set_error_handler(static function ($seve
}
});
@@ -10,6 +10,7 @@ diff -up ./php-cs-fixer.rpm ./php-cs-fixer
- // Maybe this file is used as phar-stub? Let's try!
- try {
- Phar::mapPhar('php-cs-fixer.phar');
+-
- require_once 'phar://php-cs-fixer.phar/vendor/autoload.php';
- $require = false;
- } catch (PharException $e) {
@@ -42,9 +43,9 @@ diff -up ./php-cs-fixer.rpm ./php-cs-fixer
use Composer\XdebugHandler\XdebugHandler;
use PhpCsFixer\Console\Application;
diff -up ./src/Console/Command/HelpCommand.php.rpm ./src/Console/Command/HelpCommand.php
---- ./src/Console/Command/HelpCommand.php.rpm 2019-11-04 09:01:59.000000000 +0100
-+++ ./src/Console/Command/HelpCommand.php 2019-11-04 09:02:13.808580217 +0100
-@@ -377,6 +377,8 @@ EOF
+--- ./src/Console/Command/HelpCommand.php.rpm 2020-12-08 07:57:58.000000000 +0100
++++ ./src/Console/Command/HelpCommand.php 2020-12-08 10:29:13.190515695 +0100
+@@ -374,6 +374,8 @@ EOF
{
static $version = null;
@@ -54,9 +55,9 @@ diff -up ./src/Console/Command/HelpCommand.php.rpm ./src/Console/Command/HelpCom
return $version;
}
diff -up ./tests/AutoReview/ProjectCodeTest.php.rpm ./tests/AutoReview/ProjectCodeTest.php
---- ./tests/AutoReview/ProjectCodeTest.php.rpm 2019-11-04 09:01:59.000000000 +0100
-+++ ./tests/AutoReview/ProjectCodeTest.php 2019-11-04 09:02:13.808580217 +0100
-@@ -473,8 +473,11 @@ final class ProjectCodeTest extends Test
+--- ./tests/AutoReview/ProjectCodeTest.php.rpm 2020-12-08 07:57:59.000000000 +0100
++++ ./tests/AutoReview/ProjectCodeTest.php 2020-12-08 10:29:13.190515695 +0100
+@@ -690,8 +690,11 @@ final class ProjectCodeTest extends Test
->files()
->name('*.php')
->in(__DIR__.'/../../src')
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 0d7e16b..072ab86 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 4e35806a6d7d8510d6842ae932e8832363d22c87
+%global gh_commit 5274ce3d3200a2b374baa42143cb9dfcdcc2fa52
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -88,6 +88,7 @@ BuildRequires: php-symfony3-debug
# "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.2",
# "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.2.1",
# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.1",
+# "phpunitgoodpractices/polyfill": "^1.5",
# "phpunitgoodpractices/traits": "^1.9.1",
# "symfony/phpunit-bridge": "^5.1",
# "symfony/yaml": "^3.0 || ^4.0 || ^5.0"
@@ -101,14 +102,16 @@ BuildRequires: (php-composer(mikey179/vfsstream)
BuildRequires: (php-composer(php-cs-fixer/accessible-object) >= 1.0 with php-composer(php-cs-fixer/accessible-object) < 2)
BuildRequires: (php-composer(php-cs-fixer/phpunit-constraint-isidenticalstring) >= 1.2 with php-composer(php-cs-fixer/phpunit-constraint-isidenticalstring) < 2)
BuildRequires: (php-composer(php-cs-fixer/phpunit-constraint-xmlmatchesxsd) >= 1.2.1 with php-composer(php-cs-fixer/phpunit-constraint-xmlmatchesxsd) < 2)
+BuildRequires: (php-composer(phpunitgoodpractices/polyfill) >= 1.5 with php-composer(phpunitgoodpractices/polyfill) < 2)
BuildRequires: (php-composer(phpunitgoodpractices/traits) >= 1.9.1 with php-composer(phpunitgoodpractices/traits) < 2)
-# remirepo:8
+# remirepo:9
%else
BuildRequires: php-justinrainbow-json-schema5
BuildRequires: php-mikey179-vfsstream >= 1.6
BuildRequires: php-cs-fixer-accessible-object
BuildRequires: php-cs-fixer-phpunit-constraint-isidenticalstring >= 1.2
BuildRequires: php-cs-fixer-phpunit-constraint-xmlmatchesxsd >= 1.2.1
+BuildRequires: php-phpunitgoodpractices-polyfill >= 1.5
BuildRequires: php-phpunitgoodpractices-traits >= 1.9.1
%endif
%global phpunit %{_bindir}/phpunit7
@@ -118,7 +121,7 @@ BuildRequires: phpunit7
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": "^7.1",
+# "php": "^5.6 || ^7.0 || ^8.0",
# "ext-json": "*",
# "ext-tokenizer": "*",
# "composer/semver": "^1.4 || ^2.0 || ^3.0",
@@ -290,6 +293,8 @@ rm tests/Smoke/StdinTest.php
rm tests/Smoke/InstallViaComposerTest.php
# strange failure
rm tests/Fixtures/Integration/priority/combine_consecutive_issets,no_singleline_whitespace_before_semicolons.test
+# test checking documentation
+rm tests/AutoReview/DocumentationTest.php
# Disable listener
sed -e '/<listeners>/,/<\/listeners>/d' phpunit.xml.dist >phpunit.xml
@@ -329,6 +334,9 @@ exit $ret
%changelog
+* Tue Dec 8 2020 Remi Collet <remi@remirepo.net> - 2.17.0-1
+- update to 2.17.0
+
* Wed Oct 28 2020 Remi Collet <remi@remirepo.net> - 2.16.7-1
- update to 2.16.7
- raise dependency on composer/semver v3