summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-08 07:55:51 +0100
committerRemi Collet <remi@php.net>2022-03-08 07:55:51 +0100
commit4a433ad5ff2fb5f4a182028755fd544f3c570cf8 (patch)
treeb701955aa5dde6ece9060b686037f8274b19ddb7
parentc94424bd1ae438e65def955395f67dc9e3d2c59e (diff)
update to 3.7.0 #StandWithUkraine️
-rw-r--r--composer.json6
-rw-r--r--installed.json180
-rw-r--r--php-cs-fixer.spec35
3 files changed, 112 insertions, 109 deletions
diff --git a/composer.json b/composer.json
index f3d8e76..5cff2a0 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"ext-json": "*",
"ext-tokenizer": "*",
"composer/semver": "^3.2",
- "composer/xdebug-handler": "^3.0",
+ "composer/xdebug-handler": "^3.0.3",
"doctrine/annotations": "^1.13",
"php-cs-fixer/diff": "^2.0",
"symfony/console": "^5.4 || ^6.0",
@@ -27,8 +27,8 @@
"symfony/finder": "^5.4 || ^6.0",
"symfony/options-resolver": "^5.4 || ^6.0",
"symfony/polyfill-mbstring": "^1.23",
- "symfony/polyfill-php80": "^1.23",
- "symfony/polyfill-php81": "^1.23",
+ "symfony/polyfill-php80": "^1.25",
+ "symfony/polyfill-php81": "^1.25",
"symfony/process": "^5.4 || ^6.0",
"symfony/stopwatch": "^5.4 || ^6.0"
},
diff --git a/installed.json b/installed.json
index 6d8f447..717de9b 100644
--- a/installed.json
+++ b/installed.json
@@ -2,32 +2,32 @@
"packages": [
{
"name": "composer/pcre",
- "version": "1.0.1",
- "version_normalized": "1.0.1.0",
+ "version": "3.0.0",
+ "version_normalized": "3.0.0.0",
"source": {
"type": "git",
"url": "https://github.com/composer/pcre.git",
- "reference": "67a32d7d6f9f560b726ab25a061b38ff3a80c560"
+ "reference": "e300eb6c535192decd27a85bc72a9290f0d6b3bd"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/pcre/zipball/67a32d7d6f9f560b726ab25a061b38ff3a80c560",
- "reference": "67a32d7d6f9f560b726ab25a061b38ff3a80c560",
+ "url": "https://api.github.com/repos/composer/pcre/zipball/e300eb6c535192decd27a85bc72a9290f0d6b3bd",
+ "reference": "e300eb6c535192decd27a85bc72a9290f0d6b3bd",
"shasum": ""
},
"require": {
- "php": "^5.3.2 || ^7.0 || ^8.0"
+ "php": "^7.4 || ^8.0"
},
"require-dev": {
"phpstan/phpstan": "^1.3",
"phpstan/phpstan-strict-rules": "^1.1",
- "symfony/phpunit-bridge": "^4.2 || ^5"
+ "symfony/phpunit-bridge": "^5"
},
- "time": "2022-01-21T20:24:37+00:00",
+ "time": "2022-02-25T20:21:48+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.x-dev"
+ "dev-main": "3.x-dev"
}
},
"installation-source": "dist",
@@ -56,7 +56,7 @@
],
"support": {
"issues": "https://github.com/composer/pcre/issues",
- "source": "https://github.com/composer/pcre/tree/1.0.1"
+ "source": "https://github.com/composer/pcre/tree/3.0.0"
},
"funding": [
{
@@ -160,21 +160,21 @@
},
{
"name": "composer/xdebug-handler",
- "version": "3.0.1",
- "version_normalized": "3.0.1.0",
+ "version": "3.0.3",
+ "version_normalized": "3.0.3.0",
"source": {
"type": "git",
"url": "https://github.com/composer/xdebug-handler.git",
- "reference": "12f1b79476638a5615ed00ea6adbb269cec96fd8"
+ "reference": "ced299686f41dce890debac69273b47ffe98a40c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/xdebug-handler/zipball/12f1b79476638a5615ed00ea6adbb269cec96fd8",
- "reference": "12f1b79476638a5615ed00ea6adbb269cec96fd8",
+ "url": "https://api.github.com/repos/composer/xdebug-handler/zipball/ced299686f41dce890debac69273b47ffe98a40c",
+ "reference": "ced299686f41dce890debac69273b47ffe98a40c",
"shasum": ""
},
"require": {
- "composer/pcre": "^1",
+ "composer/pcre": "^1 || ^2 || ^3",
"php": "^7.2.5 || ^8.0",
"psr/log": "^1 || ^2 || ^3"
},
@@ -183,7 +183,7 @@
"phpstan/phpstan-strict-rules": "^1.1",
"symfony/phpunit-bridge": "^6.0"
},
- "time": "2022-01-04T18:29:42+00:00",
+ "time": "2022-02-25T21:32:43+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -209,7 +209,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/xdebug-handler/issues",
- "source": "https://github.com/composer/xdebug-handler/tree/3.0.1"
+ "source": "https://github.com/composer/xdebug-handler/tree/3.0.3"
},
"funding": [
{
@@ -304,17 +304,17 @@
},
{
"name": "doctrine/lexer",
- "version": "1.2.2",
- "version_normalized": "1.2.2.0",
+ "version": "1.2.3",
+ "version_normalized": "1.2.3.0",
"source": {
"type": "git",
"url": "https://github.com/doctrine/lexer.git",
- "reference": "9c50f840f257bbb941e6f4a0e94ccf5db5c3f76c"
+ "reference": "c268e882d4dbdd85e36e4ad69e02dc284f89d229"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/doctrine/lexer/zipball/9c50f840f257bbb941e6f4a0e94ccf5db5c3f76c",
- "reference": "9c50f840f257bbb941e6f4a0e94ccf5db5c3f76c",
+ "url": "https://api.github.com/repos/doctrine/lexer/zipball/c268e882d4dbdd85e36e4ad69e02dc284f89d229",
+ "reference": "c268e882d4dbdd85e36e4ad69e02dc284f89d229",
"shasum": ""
},
"require": {
@@ -322,11 +322,11 @@
},
"require-dev": {
"doctrine/coding-standard": "^9.0",
- "phpstan/phpstan": "1.3",
+ "phpstan/phpstan": "^1.3",
"phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
"vimeo/psalm": "^4.11"
},
- "time": "2022-01-12T08:27:12+00:00",
+ "time": "2022-02-28T11:07:21+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -363,7 +363,7 @@
],
"support": {
"issues": "https://github.com/doctrine/lexer/issues",
- "source": "https://github.com/doctrine/lexer/tree/1.2.2"
+ "source": "https://github.com/doctrine/lexer/tree/1.2.3"
},
"funding": [
{
@@ -647,17 +647,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.3",
- "version_normalized": "5.4.3.0",
+ "version": "v5.4.5",
+ "version_normalized": "5.4.5.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "a2a86ec353d825c75856c6fd14fac416a7bdb6b8"
+ "reference": "d8111acc99876953f52fe16d4c50eb60940d49ad"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/a2a86ec353d825c75856c6fd14fac416a7bdb6b8",
- "reference": "a2a86ec353d825c75856c6fd14fac416a7bdb6b8",
+ "url": "https://api.github.com/repos/symfony/console/zipball/d8111acc99876953f52fe16d4c50eb60940d49ad",
+ "reference": "d8111acc99876953f52fe16d4c50eb60940d49ad",
"shasum": ""
},
"require": {
@@ -695,7 +695,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2022-01-26T16:28:35+00:00",
+ "time": "2022-02-24T12:45:35+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -729,7 +729,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.3"
+ "source": "https://github.com/symfony/console/tree/v5.4.5"
},
"funding": [
{
@@ -989,17 +989,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.3",
- "version_normalized": "5.4.3.0",
+ "version": "v5.4.6",
+ "version_normalized": "5.4.6.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "0f0c4bf1840420f4aef3f32044a9dbb24682731b"
+ "reference": "d53a45039974952af7f7ebc461ccdd4295e29440"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/0f0c4bf1840420f4aef3f32044a9dbb24682731b",
- "reference": "0f0c4bf1840420f4aef3f32044a9dbb24682731b",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/d53a45039974952af7f7ebc461ccdd4295e29440",
+ "reference": "d53a45039974952af7f7ebc461ccdd4295e29440",
"shasum": ""
},
"require": {
@@ -1008,7 +1008,7 @@
"symfony/polyfill-mbstring": "~1.8",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-01-02T09:53:40+00:00",
+ "time": "2022-03-02T12:42:23+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1036,7 +1036,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.3"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.6"
},
"funding": [
{
@@ -1194,8 +1194,8 @@
},
{
"name": "symfony/polyfill-ctype",
- "version": "v1.24.0",
- "version_normalized": "1.24.0.0",
+ "version": "v1.25.0",
+ "version_normalized": "1.25.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-ctype.git",
@@ -1229,12 +1229,12 @@
},
"installation-source": "dist",
"autoload": {
- "psr-4": {
- "Symfony\\Polyfill\\Ctype\\": ""
- },
"files": [
"bootstrap.php"
- ]
+ ],
+ "psr-4": {
+ "Symfony\\Polyfill\\Ctype\\": ""
+ }
},
"notification-url": "https://packagist.org/downloads/",
"license": [
@@ -1259,7 +1259,7 @@
"portable"
],
"support": {
- "source": "https://github.com/symfony/polyfill-ctype/tree/v1.24.0"
+ "source": "https://github.com/symfony/polyfill-ctype/tree/v1.25.0"
},
"funding": [
{
@@ -1279,8 +1279,8 @@
},
{
"name": "symfony/polyfill-intl-grapheme",
- "version": "v1.24.0",
- "version_normalized": "1.24.0.0",
+ "version": "v1.25.0",
+ "version_normalized": "1.25.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-grapheme.git",
@@ -1343,7 +1343,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.24.0"
+ "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.25.0"
},
"funding": [
{
@@ -1363,8 +1363,8 @@
},
{
"name": "symfony/polyfill-intl-normalizer",
- "version": "v1.24.0",
- "version_normalized": "1.24.0.0",
+ "version": "v1.25.0",
+ "version_normalized": "1.25.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-normalizer.git",
@@ -1430,7 +1430,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.24.0"
+ "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.25.0"
},
"funding": [
{
@@ -1450,8 +1450,8 @@
},
{
"name": "symfony/polyfill-mbstring",
- "version": "v1.24.0",
- "version_normalized": "1.24.0.0",
+ "version": "v1.25.0",
+ "version_normalized": "1.25.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-mbstring.git",
@@ -1485,12 +1485,12 @@
},
"installation-source": "dist",
"autoload": {
- "psr-4": {
- "Symfony\\Polyfill\\Mbstring\\": ""
- },
"files": [
"bootstrap.php"
- ]
+ ],
+ "psr-4": {
+ "Symfony\\Polyfill\\Mbstring\\": ""
+ }
},
"notification-url": "https://packagist.org/downloads/",
"license": [
@@ -1516,7 +1516,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.24.0"
+ "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.25.0"
},
"funding": [
{
@@ -1536,8 +1536,8 @@
},
{
"name": "symfony/polyfill-php73",
- "version": "v1.24.0",
- "version_normalized": "1.24.0.0",
+ "version": "v1.25.0",
+ "version_normalized": "1.25.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php73.git",
@@ -1598,7 +1598,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php73/tree/v1.24.0"
+ "source": "https://github.com/symfony/polyfill-php73/tree/v1.25.0"
},
"funding": [
{
@@ -1618,23 +1618,23 @@
},
{
"name": "symfony/polyfill-php80",
- "version": "v1.24.0",
- "version_normalized": "1.24.0.0",
+ "version": "v1.25.0",
+ "version_normalized": "1.25.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php80.git",
- "reference": "57b712b08eddb97c762a8caa32c84e037892d2e9"
+ "reference": "4407588e0d3f1f52efb65fbe92babe41f37fe50c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/57b712b08eddb97c762a8caa32c84e037892d2e9",
- "reference": "57b712b08eddb97c762a8caa32c84e037892d2e9",
+ "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/4407588e0d3f1f52efb65fbe92babe41f37fe50c",
+ "reference": "4407588e0d3f1f52efb65fbe92babe41f37fe50c",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2021-09-13T13:58:33+00:00",
+ "time": "2022-03-04T08:16:47+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -1684,7 +1684,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php80/tree/v1.24.0"
+ "source": "https://github.com/symfony/polyfill-php80/tree/v1.25.0"
},
"funding": [
{
@@ -1704,8 +1704,8 @@
},
{
"name": "symfony/polyfill-php81",
- "version": "v1.24.0",
- "version_normalized": "1.24.0.0",
+ "version": "v1.25.0",
+ "version_normalized": "1.25.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php81.git",
@@ -1766,7 +1766,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php81/tree/v1.24.0"
+ "source": "https://github.com/symfony/polyfill-php81/tree/v1.25.0"
},
"funding": [
{
@@ -1786,24 +1786,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.3",
- "version_normalized": "5.4.3.0",
+ "version": "v5.4.5",
+ "version_normalized": "5.4.5.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "553f50487389a977eb31cf6b37faae56da00f753"
+ "reference": "95440409896f90a5f85db07a32b517ecec17fa4c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/553f50487389a977eb31cf6b37faae56da00f753",
- "reference": "553f50487389a977eb31cf6b37faae56da00f753",
+ "url": "https://api.github.com/repos/symfony/process/zipball/95440409896f90a5f85db07a32b517ecec17fa4c",
+ "reference": "95440409896f90a5f85db07a32b517ecec17fa4c",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-01-26T16:28:35+00:00",
+ "time": "2022-01-30T18:16:22+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1831,7 +1831,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.3"
+ "source": "https://github.com/symfony/process/tree/v5.4.5"
},
"funding": [
{
@@ -1937,24 +1937,24 @@
},
{
"name": "symfony/stopwatch",
- "version": "v5.4.3",
- "version_normalized": "5.4.3.0",
+ "version": "v5.4.5",
+ "version_normalized": "5.4.5.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/stopwatch.git",
- "reference": "395220730edceb6bd745236ccb5c9125c748f779"
+ "reference": "4d04b5c24f3c9a1a168a131f6cbe297155bc0d30"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/stopwatch/zipball/395220730edceb6bd745236ccb5c9125c748f779",
- "reference": "395220730edceb6bd745236ccb5c9125c748f779",
+ "url": "https://api.github.com/repos/symfony/stopwatch/zipball/4d04b5c24f3c9a1a168a131f6cbe297155bc0d30",
+ "reference": "4d04b5c24f3c9a1a168a131f6cbe297155bc0d30",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/service-contracts": "^1|^2|^3"
},
- "time": "2022-01-02T09:53:40+00:00",
+ "time": "2022-02-18T16:06:09+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1982,7 +1982,7 @@
"description": "Provides a way to profile code",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/stopwatch/tree/v5.4.3"
+ "source": "https://github.com/symfony/stopwatch/tree/v5.4.5"
},
"funding": [
{
@@ -2036,12 +2036,12 @@
"type": "library",
"installation-source": "dist",
"autoload": {
- "psr-4": {
- "Symfony\\Component\\String\\": ""
- },
"files": [
"Resources/functions.php"
],
+ "psr-4": {
+ "Symfony\\Component\\String\\": ""
+ },
"exclude-from-classmap": [
"/Tests/"
]
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 7edf815..b77ed20 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 1975e4453eb2726d1f50da0ce7fa91295029a4fa
+%global gh_commit 7705d5a985132a40282d18a176eb9a4a0497747c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.6.0
+Version: 3.7.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -49,33 +49,33 @@ Obsoletes: php-cs-fixer3 < 3.5
Provides: php-cs-fixer3 = %{version}
# Bundled PHP libraries
-Provides: bundled(php-composer-pcre) = 1.0.1
+Provides: bundled(php-composer-pcre) = 3.0.0
Provides: bundled(php-composer-semver) = 3.2.9
-Provides: bundled(php-composer-xdebug-handler) = 3.0.1
+Provides: bundled(php-composer-xdebug-handler) = 3.0.3
Provides: bundled(php-doctrine-annotations) = 1.13.2
-Provides: bundled(php-doctrine-lexer) = 1.2.2
+Provides: bundled(php-doctrine-lexer) = 1.2.3
Provides: bundled(php-php-cs-fixer-diff) = v2.0.2
Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.1.2
Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 1.1.4
-Provides: bundled(php-symfony-console) = v5.4.3
+Provides: bundled(php-symfony-console) = v5.4.5
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.0
Provides: bundled(php-symfony-event-dispatcher) = v5.4.3
Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.0
-Provides: bundled(php-symfony-filesystem) = v5.4.3
+Provides: bundled(php-symfony-filesystem) = v5.4.6
Provides: bundled(php-symfony-finder) = v5.4.3
Provides: bundled(php-symfony-options-resolver) = v5.4.3
-Provides: bundled(php-symfony-polyfill-ctype) = v1.24.0
-Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.24.0
-Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.24.0
-Provides: bundled(php-symfony-polyfill-mbstring) = v1.24.0
-Provides: bundled(php-symfony-polyfill-php73) = v1.24.0
-Provides: bundled(php-symfony-polyfill-php80) = v1.24.0
-Provides: bundled(php-symfony-polyfill-php81) = v1.24.0
-Provides: bundled(php-symfony-process) = v5.4.3
+Provides: bundled(php-symfony-polyfill-ctype) = v1.25.0
+Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.25.0
+Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.25.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.25.0
+Provides: bundled(php-symfony-polyfill-php73) = v1.25.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.25.0
+Provides: bundled(php-symfony-polyfill-php81) = v1.25.0
+Provides: bundled(php-symfony-process) = v5.4.5
Provides: bundled(php-symfony-service-contracts) = v2.5.0
-Provides: bundled(php-symfony-stopwatch) = v5.4.3
+Provides: bundled(php-symfony-stopwatch) = v5.4.5
Provides: bundled(php-symfony-string) = v5.4.3
Provides: php-composer(friendsofphp/php-cs-fixer) = %{version}
@@ -147,6 +147,9 @@ sed -e 's:%{_datadir}:%{buildroot}%{_datadir}:' -i %{name}
%changelog
+* Tue Mar 8 2022 Remi Collet <remi@remirepo.net> - 3.7.0-1
+- update to 3.7.0 #StandWithUkraine️
+
* Tue Feb 8 2022 Remi Collet <remi@remirepo.net> - 3.6.0-1
- update to 3.6.0