summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-08-18 07:00:05 +0200
committerRemi Collet <remi@php.net>2022-08-18 07:00:05 +0200
commit44006cdad0610a33f528c3031b8ae8901ff4c471 (patch)
treee5dd319f208db7783a4a55843b9b1bc7bedaa4b6
parent5fa0652a42e01e978e925e465244a1a7f44a66fb (diff)
update to 3.10.0
-rw-r--r--composer.json2
-rw-r--r--installed.json208
-rw-r--r--php-cs-fixer.spec21
3 files changed, 124 insertions, 107 deletions
diff --git a/composer.json b/composer.json
index ea9d003..01f09da 100644
--- a/composer.json
+++ b/composer.json
@@ -20,7 +20,7 @@
"composer/semver": "^3.2",
"composer/xdebug-handler": "^3.0.3",
"doctrine/annotations": "^1.13",
- "php-cs-fixer/diff": "^2.0",
+ "sebastian/diff": "^4.0",
"symfony/console": "^5.4 || ^6.0",
"symfony/event-dispatcher": "^5.4 || ^6.0",
"symfony/filesystem": "^5.4 || ^6.0",
diff --git a/installed.json b/installed.json
index b4b7605..a16ae5c 100644
--- a/installed.json
+++ b/installed.json
@@ -383,61 +383,6 @@
"install-path": "../doctrine/lexer"
},
{
- "name": "php-cs-fixer/diff",
- "version": "v2.0.2",
- "version_normalized": "2.0.2.0",
- "source": {
- "type": "git",
- "url": "https://github.com/PHP-CS-Fixer/diff.git",
- "reference": "29dc0d507e838c4580d018bd8b5cb412474f7ec3"
- },
- "dist": {
- "type": "zip",
- "url": "https://api.github.com/repos/PHP-CS-Fixer/diff/zipball/29dc0d507e838c4580d018bd8b5cb412474f7ec3",
- "reference": "29dc0d507e838c4580d018bd8b5cb412474f7ec3",
- "shasum": ""
- },
- "require": {
- "php": "^5.6 || ^7.0 || ^8.0"
- },
- "require-dev": {
- "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.0",
- "symfony/process": "^3.3"
- },
- "time": "2020-10-14T08:32:19+00:00",
- "type": "library",
- "installation-source": "dist",
- "autoload": {
- "classmap": [
- "src/"
- ]
- },
- "notification-url": "https://packagist.org/downloads/",
- "license": [
- "BSD-3-Clause"
- ],
- "authors": [
- {
- "name": "Sebastian Bergmann",
- "email": "sebastian@phpunit.de"
- },
- {
- "name": "Kore Nordmann",
- "email": "mail@kore-nordmann.de"
- }
- ],
- "description": "sebastian/diff v3 backport support for PHP 5.6+",
- "homepage": "https://github.com/PHP-CS-Fixer",
- "keywords": [
- "diff"
- ],
- "support": {
- "issues": "https://github.com/PHP-CS-Fixer/diff/issues",
- "source": "https://github.com/PHP-CS-Fixer/diff/tree/v2.0.2"
- },
- "install-path": "../php-cs-fixer/diff"
- },
- {
"name": "psr/cache",
"version": "1.0.1",
"version_normalized": "1.0.1.0",
@@ -647,18 +592,87 @@
"install-path": "../psr/log"
},
{
+ "name": "sebastian/diff",
+ "version": "4.0.4",
+ "version_normalized": "4.0.4.0",
+ "source": {
+ "type": "git",
+ "url": "https://github.com/sebastianbergmann/diff.git",
+ "reference": "3461e3fccc7cfdfc2720be910d3bd73c69be590d"
+ },
+ "dist": {
+ "type": "zip",
+ "url": "https://api.github.com/repos/sebastianbergmann/diff/zipball/3461e3fccc7cfdfc2720be910d3bd73c69be590d",
+ "reference": "3461e3fccc7cfdfc2720be910d3bd73c69be590d",
+ "shasum": ""
+ },
+ "require": {
+ "php": ">=7.3"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^9.3",
+ "symfony/process": "^4.2 || ^5"
+ },
+ "time": "2020-10-26T13:10:38+00:00",
+ "type": "library",
+ "extra": {
+ "branch-alias": {
+ "dev-master": "4.0-dev"
+ }
+ },
+ "installation-source": "dist",
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "notification-url": "https://packagist.org/downloads/",
+ "license": [
+ "BSD-3-Clause"
+ ],
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sebastian@phpunit.de"
+ },
+ {
+ "name": "Kore Nordmann",
+ "email": "mail@kore-nordmann.de"
+ }
+ ],
+ "description": "Diff implementation",
+ "homepage": "https://github.com/sebastianbergmann/diff",
+ "keywords": [
+ "diff",
+ "udiff",
+ "unidiff",
+ "unified diff"
+ ],
+ "support": {
+ "issues": "https://github.com/sebastianbergmann/diff/issues",
+ "source": "https://github.com/sebastianbergmann/diff/tree/4.0.4"
+ },
+ "funding": [
+ {
+ "url": "https://github.com/sebastianbergmann",
+ "type": "github"
+ }
+ ],
+ "install-path": "../sebastian/diff"
+ },
+ {
"name": "symfony/console",
- "version": "v5.4.10",
- "version_normalized": "5.4.10.0",
+ "version": "v5.4.11",
+ "version_normalized": "5.4.11.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "4d671ab4ddac94ee439ea73649c69d9d200b5000"
+ "reference": "535846c7ee6bc4dd027ca0d93220601456734b10"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/4d671ab4ddac94ee439ea73649c69d9d200b5000",
- "reference": "4d671ab4ddac94ee439ea73649c69d9d200b5000",
+ "url": "https://api.github.com/repos/symfony/console/zipball/535846c7ee6bc4dd027ca0d93220601456734b10",
+ "reference": "535846c7ee6bc4dd027ca0d93220601456734b10",
"shasum": ""
},
"require": {
@@ -696,7 +710,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2022-06-26T13:00:04+00:00",
+ "time": "2022-07-22T10:42:43+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -730,7 +744,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.10"
+ "source": "https://github.com/symfony/console/tree/v5.4.11"
},
"funding": [
{
@@ -990,17 +1004,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.9",
- "version_normalized": "5.4.9.0",
+ "version": "v5.4.11",
+ "version_normalized": "5.4.11.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "36a017fa4cce1eff1b8e8129ff53513abcef05ba"
+ "reference": "6699fb0228d1bc35b12aed6dd5e7455457609ddd"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/36a017fa4cce1eff1b8e8129ff53513abcef05ba",
- "reference": "36a017fa4cce1eff1b8e8129ff53513abcef05ba",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/6699fb0228d1bc35b12aed6dd5e7455457609ddd",
+ "reference": "6699fb0228d1bc35b12aed6dd5e7455457609ddd",
"shasum": ""
},
"require": {
@@ -1009,7 +1023,7 @@
"symfony/polyfill-mbstring": "~1.8",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-05-20T13:55:35+00:00",
+ "time": "2022-07-20T13:00:38+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1037,7 +1051,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.9"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.11"
},
"funding": [
{
@@ -1057,17 +1071,17 @@
},
{
"name": "symfony/finder",
- "version": "v5.4.8",
- "version_normalized": "5.4.8.0",
+ "version": "v5.4.11",
+ "version_normalized": "5.4.11.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "9b630f3427f3ebe7cd346c277a1408b00249dad9"
+ "reference": "7872a66f57caffa2916a584db1aa7f12adc76f8c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/9b630f3427f3ebe7cd346c277a1408b00249dad9",
- "reference": "9b630f3427f3ebe7cd346c277a1408b00249dad9",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/7872a66f57caffa2916a584db1aa7f12adc76f8c",
+ "reference": "7872a66f57caffa2916a584db1aa7f12adc76f8c",
"shasum": ""
},
"require": {
@@ -1075,7 +1089,7 @@
"symfony/deprecation-contracts": "^2.1|^3",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-04-15T08:07:45+00:00",
+ "time": "2022-07-29T07:37:50+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1103,7 +1117,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v5.4.8"
+ "source": "https://github.com/symfony/finder/tree/v5.4.11"
},
"funding": [
{
@@ -1123,17 +1137,17 @@
},
{
"name": "symfony/options-resolver",
- "version": "v5.4.3",
- "version_normalized": "5.4.3.0",
+ "version": "v5.4.11",
+ "version_normalized": "5.4.11.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/options-resolver.git",
- "reference": "cc1147cb11af1b43f503ac18f31aa3bec213aba8"
+ "reference": "54f14e36aa73cb8f7261d7686691fd4d75ea2690"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/options-resolver/zipball/cc1147cb11af1b43f503ac18f31aa3bec213aba8",
- "reference": "cc1147cb11af1b43f503ac18f31aa3bec213aba8",
+ "url": "https://api.github.com/repos/symfony/options-resolver/zipball/54f14e36aa73cb8f7261d7686691fd4d75ea2690",
+ "reference": "54f14e36aa73cb8f7261d7686691fd4d75ea2690",
"shasum": ""
},
"require": {
@@ -1142,7 +1156,7 @@
"symfony/polyfill-php73": "~1.0",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-01-02T09:53:40+00:00",
+ "time": "2022-07-20T13:00:38+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1175,7 +1189,7 @@
"options"
],
"support": {
- "source": "https://github.com/symfony/options-resolver/tree/v5.4.3"
+ "source": "https://github.com/symfony/options-resolver/tree/v5.4.11"
},
"funding": [
{
@@ -1787,24 +1801,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.8",
- "version_normalized": "5.4.8.0",
+ "version": "v5.4.11",
+ "version_normalized": "5.4.11.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "597f3fff8e3e91836bb0bd38f5718b56ddbde2f3"
+ "reference": "6e75fe6874cbc7e4773d049616ab450eff537bf1"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/597f3fff8e3e91836bb0bd38f5718b56ddbde2f3",
- "reference": "597f3fff8e3e91836bb0bd38f5718b56ddbde2f3",
+ "url": "https://api.github.com/repos/symfony/process/zipball/6e75fe6874cbc7e4773d049616ab450eff537bf1",
+ "reference": "6e75fe6874cbc7e4773d049616ab450eff537bf1",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-04-08T05:07:18+00:00",
+ "time": "2022-06-27T16:58:25+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1832,7 +1846,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.8"
+ "source": "https://github.com/symfony/process/tree/v5.4.11"
},
"funding": [
{
@@ -2003,17 +2017,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.10",
- "version_normalized": "5.4.10.0",
+ "version": "v5.4.11",
+ "version_normalized": "5.4.11.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "4432bc7df82a554b3e413a8570ce2fea90e94097"
+ "reference": "5eb661e49ad389e4ae2b6e4df8d783a8a6548322"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/4432bc7df82a554b3e413a8570ce2fea90e94097",
- "reference": "4432bc7df82a554b3e413a8570ce2fea90e94097",
+ "url": "https://api.github.com/repos/symfony/string/zipball/5eb661e49ad389e4ae2b6e4df8d783a8a6548322",
+ "reference": "5eb661e49ad389e4ae2b6e4df8d783a8a6548322",
"shasum": ""
},
"require": {
@@ -2033,7 +2047,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2022-06-26T15:57:47+00:00",
+ "time": "2022-07-24T16:15:25+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2072,7 +2086,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.10"
+ "source": "https://github.com/symfony/string/tree/v5.4.11"
},
"funding": [
{
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 813944c..f223dd8 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 4465d70ba776806857a1ac2a6f877e582445ff36
+%global gh_commit 76d7da666e66d83a1dc27a9d1c625c80cc4ac1fe
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.9.5
+Version: 3.10.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -50,7 +50,7 @@ Provides: php-cs-fixer3 = %{version}
# Bundled PHP libraries
# License BSD-3-Clause
-Provides: bundled(php-php-cs-fixer-diff) = v2.0.2
+Provides: bundled(php-sebastian-diff) = 4.0.4
# License MIT
Provides: bundled(php-composer-pcre) = 3.0.0
Provides: bundled(php-composer-semver) = 3.3.2
@@ -61,13 +61,13 @@ Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.1.2
Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 1.1.4
-Provides: bundled(php-symfony-console) = v5.4.10
+Provides: bundled(php-symfony-console) = v5.4.11
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
Provides: bundled(php-symfony-event-dispatcher) = v5.4.9
Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.2
-Provides: bundled(php-symfony-filesystem) = v5.4.9
-Provides: bundled(php-symfony-finder) = v5.4.8
-Provides: bundled(php-symfony-options-resolver) = v5.4.3
+Provides: bundled(php-symfony-filesystem) = v5.4.11
+Provides: bundled(php-symfony-finder) = v5.4.11
+Provides: bundled(php-symfony-options-resolver) = v5.4.11
Provides: bundled(php-symfony-polyfill-ctype) = v1.26.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.26.0
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.26.0
@@ -75,10 +75,10 @@ Provides: bundled(php-symfony-polyfill-mbstring) = v1.26.0
Provides: bundled(php-symfony-polyfill-php73) = v1.26.0
Provides: bundled(php-symfony-polyfill-php80) = v1.26.0
Provides: bundled(php-symfony-polyfill-php81) = v1.26.0
-Provides: bundled(php-symfony-process) = v5.4.8
+Provides: bundled(php-symfony-process) = v5.4.11
Provides: bundled(php-symfony-service-contracts) = v2.5.2
Provides: bundled(php-symfony-stopwatch) = v5.4.5
-Provides: bundled(php-symfony-string) = v5.4.10
+Provides: bundled(php-symfony-string) = v5.4.11
Provides: php-composer(friendsofphp/php-cs-fixer) = %{version}
@@ -153,6 +153,9 @@ sed -e 's:%{_datadir}:%{buildroot}%{_datadir}:' -i %{name}
%changelog
+* Thu Aug 18 2022 Remi Collet <remi@remirepo.net> - 3.10.0-1
+- update to 3.10.0
+
* Fri Jul 22 2022 Remi Collet <remi@remirepo.net> - 3.9.5-1
- update to 3.9.5