summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-02-26 09:34:22 +0100
committerRemi Collet <remi@php.net>2024-02-26 09:34:22 +0100
commit415524f2618d826015ba31b0ce813b1b2b022ea6 (patch)
treec2772fd777e3c199c033bc45972608aebb2b2307
parent3761ba81bd58fa6413ffa2a8b32832feb3ad669a (diff)
update to 3.50.0
-rw-r--r--composer.json5
-rw-r--r--installed.json102
-rw-r--r--php-cs-fixer.spec23
3 files changed, 58 insertions, 72 deletions
diff --git a/composer.json b/composer.json
index 979f9b6..b498074 100644
--- a/composer.json
+++ b/composer.json
@@ -26,7 +26,7 @@
"ext-tokenizer": "*",
"composer/semver": "^3.4",
"composer/xdebug-handler": "^3.0.3",
- "sebastian/diff": "^4.0 || ^5.0",
+ "sebastian/diff": "^4.0 || ^5.0 || ^6.0",
"symfony/console": "^5.4 || ^6.0 || ^7.0",
"symfony/event-dispatcher": "^5.4 || ^6.0 || ^7.0",
"symfony/filesystem": "^5.4 || ^6.0 || ^7.0",
@@ -47,7 +47,8 @@
"php-cs-fixer/accessible-object": "^1.1",
"php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.4",
"php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.4",
- "phpunit/phpunit": "^9.6 || ^10.5.5",
+ "phpunit/phpunit": "^9.6 || ^10.5.5 || ^11.0.2",
+ "symfony/var-dumper": "^5.4 || ^6.0 || ^7.0",
"symfony/yaml": "^5.4 || ^6.0 || ^7.0"
},
"suggest": {
diff --git a/installed.json b/installed.json
index bef4df0..da8a85e 100644
--- a/installed.json
+++ b/installed.json
@@ -996,17 +996,17 @@
},
{
"name": "symfony/polyfill-ctype",
- "version": "v1.28.0",
- "version_normalized": "1.28.0.0",
+ "version": "v1.29.0",
+ "version_normalized": "1.29.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-ctype.git",
- "reference": "ea208ce43cbb04af6867b4fdddb1bdbf84cc28cb"
+ "reference": "ef4d7e442ca910c4764bce785146269b30cb5fc4"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/ea208ce43cbb04af6867b4fdddb1bdbf84cc28cb",
- "reference": "ea208ce43cbb04af6867b4fdddb1bdbf84cc28cb",
+ "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/ef4d7e442ca910c4764bce785146269b30cb5fc4",
+ "reference": "ef4d7e442ca910c4764bce785146269b30cb5fc4",
"shasum": ""
},
"require": {
@@ -1018,12 +1018,9 @@
"suggest": {
"ext-ctype": "For best performance"
},
- "time": "2023-01-26T09:26:14+00:00",
+ "time": "2024-01-29T20:11:03+00:00",
"type": "library",
"extra": {
- "branch-alias": {
- "dev-main": "1.28-dev"
- },
"thanks": {
"name": "symfony/polyfill",
"url": "https://github.com/symfony/polyfill"
@@ -1061,7 +1058,7 @@
"portable"
],
"support": {
- "source": "https://github.com/symfony/polyfill-ctype/tree/v1.28.0"
+ "source": "https://github.com/symfony/polyfill-ctype/tree/v1.29.0"
},
"funding": [
{
@@ -1081,17 +1078,17 @@
},
{
"name": "symfony/polyfill-intl-grapheme",
- "version": "v1.28.0",
- "version_normalized": "1.28.0.0",
+ "version": "v1.29.0",
+ "version_normalized": "1.29.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-grapheme.git",
- "reference": "875e90aeea2777b6f135677f618529449334a612"
+ "reference": "32a9da87d7b3245e09ac426c83d334ae9f06f80f"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/875e90aeea2777b6f135677f618529449334a612",
- "reference": "875e90aeea2777b6f135677f618529449334a612",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/32a9da87d7b3245e09ac426c83d334ae9f06f80f",
+ "reference": "32a9da87d7b3245e09ac426c83d334ae9f06f80f",
"shasum": ""
},
"require": {
@@ -1100,12 +1097,9 @@
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2023-01-26T09:26:14+00:00",
+ "time": "2024-01-29T20:11:03+00:00",
"type": "library",
"extra": {
- "branch-alias": {
- "dev-main": "1.28-dev"
- },
"thanks": {
"name": "symfony/polyfill",
"url": "https://github.com/symfony/polyfill"
@@ -1145,7 +1139,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.28.0"
+ "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.29.0"
},
"funding": [
{
@@ -1165,17 +1159,17 @@
},
{
"name": "symfony/polyfill-intl-normalizer",
- "version": "v1.28.0",
- "version_normalized": "1.28.0.0",
+ "version": "v1.29.0",
+ "version_normalized": "1.29.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-normalizer.git",
- "reference": "8c4ad05dd0120b6a53c1ca374dca2ad0a1c4ed92"
+ "reference": "bc45c394692b948b4d383a08d7753968bed9a83d"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-normalizer/zipball/8c4ad05dd0120b6a53c1ca374dca2ad0a1c4ed92",
- "reference": "8c4ad05dd0120b6a53c1ca374dca2ad0a1c4ed92",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-normalizer/zipball/bc45c394692b948b4d383a08d7753968bed9a83d",
+ "reference": "bc45c394692b948b4d383a08d7753968bed9a83d",
"shasum": ""
},
"require": {
@@ -1184,12 +1178,9 @@
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2023-01-26T09:26:14+00:00",
+ "time": "2024-01-29T20:11:03+00:00",
"type": "library",
"extra": {
- "branch-alias": {
- "dev-main": "1.28-dev"
- },
"thanks": {
"name": "symfony/polyfill",
"url": "https://github.com/symfony/polyfill"
@@ -1232,7 +1223,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.28.0"
+ "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.29.0"
},
"funding": [
{
@@ -1252,17 +1243,17 @@
},
{
"name": "symfony/polyfill-mbstring",
- "version": "v1.28.0",
- "version_normalized": "1.28.0.0",
+ "version": "v1.29.0",
+ "version_normalized": "1.29.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-mbstring.git",
- "reference": "42292d99c55abe617799667f454222c54c60e229"
+ "reference": "9773676c8a1bb1f8d4340a62efe641cf76eda7ec"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/42292d99c55abe617799667f454222c54c60e229",
- "reference": "42292d99c55abe617799667f454222c54c60e229",
+ "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/9773676c8a1bb1f8d4340a62efe641cf76eda7ec",
+ "reference": "9773676c8a1bb1f8d4340a62efe641cf76eda7ec",
"shasum": ""
},
"require": {
@@ -1274,12 +1265,9 @@
"suggest": {
"ext-mbstring": "For best performance"
},
- "time": "2023-07-28T09:04:16+00:00",
+ "time": "2024-01-29T20:11:03+00:00",
"type": "library",
"extra": {
- "branch-alias": {
- "dev-main": "1.28-dev"
- },
"thanks": {
"name": "symfony/polyfill",
"url": "https://github.com/symfony/polyfill"
@@ -1318,7 +1306,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.28.0"
+ "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.29.0"
},
"funding": [
{
@@ -1338,28 +1326,25 @@
},
{
"name": "symfony/polyfill-php80",
- "version": "v1.28.0",
- "version_normalized": "1.28.0.0",
+ "version": "v1.29.0",
+ "version_normalized": "1.29.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php80.git",
- "reference": "6caa57379c4aec19c0a12a38b59b26487dcfe4b5"
+ "reference": "87b68208d5c1188808dd7839ee1e6c8ec3b02f1b"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/6caa57379c4aec19c0a12a38b59b26487dcfe4b5",
- "reference": "6caa57379c4aec19c0a12a38b59b26487dcfe4b5",
+ "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/87b68208d5c1188808dd7839ee1e6c8ec3b02f1b",
+ "reference": "87b68208d5c1188808dd7839ee1e6c8ec3b02f1b",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2023-01-26T09:26:14+00:00",
+ "time": "2024-01-29T20:11:03+00:00",
"type": "library",
"extra": {
- "branch-alias": {
- "dev-main": "1.28-dev"
- },
"thanks": {
"name": "symfony/polyfill",
"url": "https://github.com/symfony/polyfill"
@@ -1404,7 +1389,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php80/tree/v1.28.0"
+ "source": "https://github.com/symfony/polyfill-php80/tree/v1.29.0"
},
"funding": [
{
@@ -1424,28 +1409,25 @@
},
{
"name": "symfony/polyfill-php81",
- "version": "v1.28.0",
- "version_normalized": "1.28.0.0",
+ "version": "v1.29.0",
+ "version_normalized": "1.29.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php81.git",
- "reference": "7581cd600fa9fd681b797d00b02f068e2f13263b"
+ "reference": "c565ad1e63f30e7477fc40738343c62b40bc672d"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/7581cd600fa9fd681b797d00b02f068e2f13263b",
- "reference": "7581cd600fa9fd681b797d00b02f068e2f13263b",
+ "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/c565ad1e63f30e7477fc40738343c62b40bc672d",
+ "reference": "c565ad1e63f30e7477fc40738343c62b40bc672d",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2023-01-26T09:26:14+00:00",
+ "time": "2024-01-29T20:11:03+00:00",
"type": "library",
"extra": {
- "branch-alias": {
- "dev-main": "1.28-dev"
- },
"thanks": {
"name": "symfony/polyfill",
"url": "https://github.com/symfony/polyfill"
@@ -1486,7 +1468,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php81/tree/v1.28.0"
+ "source": "https://github.com/symfony/polyfill-php81/tree/v1.29.0"
},
"funding": [
{
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index e4cf8e9..e90ec79 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-cs-fixer
#
-# Copyright (c) 2016-2023 Remi Collet
+# Copyright (c) 2016-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 8742f7aa6f72a399688b65e4f58992c2d4681fc2
+%global gh_commit dbea11dcb6d9a1f6c8d51c0e580ab4a8876f524c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 2024-02-02
+%global gh_date 2024-02-23
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.49.0
+Version: 3.50.0
Release: 1%{?dist}
Summary: PHP Coding Standards Fixer
@@ -66,12 +66,12 @@ Provides: bundled(php-symfony-event-dispatcher-contracts) = v3.0.2
Provides: bundled(php-symfony-filesystem) = v6.0.19
Provides: bundled(php-symfony-finder) = v6.0.19
Provides: bundled(php-symfony-options-resolver) = v6.0.19
-Provides: bundled(php-symfony-polyfill-ctype) = v1.28.0
-Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.28.0
-Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.28.0
-Provides: bundled(php-symfony-polyfill-mbstring) = v1.28.0
-Provides: bundled(php-symfony-polyfill-php80) = v1.28.0
-Provides: bundled(php-symfony-polyfill-php81) = v1.28.0
+Provides: bundled(php-symfony-polyfill-ctype) = v1.29.0
+Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.29.0
+Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.29.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.29.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.29.0
+Provides: bundled(php-symfony-polyfill-php81) = v1.29.0
Provides: bundled(php-symfony-process) = v6.0.19
Provides: bundled(php-symfony-service-contracts) = v3.0.2
Provides: bundled(php-symfony-stopwatch) = v6.0.19
@@ -150,6 +150,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Mon Feb 26 2024 Remi Collet <remi@remirepo.net> - 3.50.0-1
+- update to 3.50.0
+
* Mon Feb 5 2024 Remi Collet <remi@remirepo.net> - 3.49.0-1
- update to 3.49.0