summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-06-20 10:18:21 +0200
committerRemi Collet <remi@php.net>2023-06-20 10:18:21 +0200
commit3689dfd7612655ddd815994a949a7f36a2423897 (patch)
treedf685754fa3b3d44ec5da723f92ddd4bc41ff3ac
parentfd40c43f4257ac6b626f501d32d0de9ffc0f439c (diff)
update to 3.18.0
-rw-r--r--installed.json52
-rwxr-xr-xmakesrc.sh2
-rw-r--r--php-cs-fixer.spec13
3 files changed, 37 insertions, 30 deletions
diff --git a/installed.json b/installed.json
index 2535423..1c70bd7 100644
--- a/installed.json
+++ b/installed.json
@@ -308,31 +308,35 @@
},
{
"name": "doctrine/deprecations",
- "version": "v1.0.0",
- "version_normalized": "1.0.0.0",
+ "version": "v1.1.1",
+ "version_normalized": "1.1.1.0",
"source": {
"type": "git",
"url": "https://github.com/doctrine/deprecations.git",
- "reference": "0e2a4f1f8cdfc7a92ec3b01c9334898c806b30de"
+ "reference": "612a3ee5ab0d5dd97b7cf3874a6efe24325efac3"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/doctrine/deprecations/zipball/0e2a4f1f8cdfc7a92ec3b01c9334898c806b30de",
- "reference": "0e2a4f1f8cdfc7a92ec3b01c9334898c806b30de",
+ "url": "https://api.github.com/repos/doctrine/deprecations/zipball/612a3ee5ab0d5dd97b7cf3874a6efe24325efac3",
+ "reference": "612a3ee5ab0d5dd97b7cf3874a6efe24325efac3",
"shasum": ""
},
"require": {
- "php": "^7.1|^8.0"
+ "php": "^7.1 || ^8.0"
},
"require-dev": {
"doctrine/coding-standard": "^9",
- "phpunit/phpunit": "^7.5|^8.5|^9.5",
- "psr/log": "^1|^2|^3"
+ "phpstan/phpstan": "1.4.10 || 1.10.15",
+ "phpstan/phpstan-phpunit": "^1.0",
+ "phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
+ "psalm/plugin-phpunit": "0.18.4",
+ "psr/log": "^1 || ^2 || ^3",
+ "vimeo/psalm": "4.30.0 || 5.12.0"
},
"suggest": {
"psr/log": "Allows logging deprecations via PSR-3 logger implementation"
},
- "time": "2022-05-02T15:47:09+00:00",
+ "time": "2023-06-03T09:27:29+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -348,7 +352,7 @@
"homepage": "https://www.doctrine-project.org/",
"support": {
"issues": "https://github.com/doctrine/deprecations/issues",
- "source": "https://github.com/doctrine/deprecations/tree/v1.0.0"
+ "source": "https://github.com/doctrine/deprecations/tree/v1.1.1"
},
"install-path": "../doctrine/deprecations"
},
@@ -713,17 +717,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.23",
- "version_normalized": "5.4.23.0",
+ "version": "v5.4.24",
+ "version_normalized": "5.4.24.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "90f21e27d0d88ce38720556dd164d4a1e4c3934c"
+ "reference": "560fc3ed7a43e6d30ea94a07d77f9a60b8ed0fb8"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/90f21e27d0d88ce38720556dd164d4a1e4c3934c",
- "reference": "90f21e27d0d88ce38720556dd164d4a1e4c3934c",
+ "url": "https://api.github.com/repos/symfony/console/zipball/560fc3ed7a43e6d30ea94a07d77f9a60b8ed0fb8",
+ "reference": "560fc3ed7a43e6d30ea94a07d77f9a60b8ed0fb8",
"shasum": ""
},
"require": {
@@ -761,7 +765,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2023-04-24T18:47:29+00:00",
+ "time": "2023-05-26T05:13:16+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -795,7 +799,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.23"
+ "source": "https://github.com/symfony/console/tree/v5.4.24"
},
"funding": [
{
@@ -1852,24 +1856,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.23",
- "version_normalized": "5.4.23.0",
+ "version": "v5.4.24",
+ "version_normalized": "5.4.24.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "4b842fc4b61609e0a155a114082bd94e31e98287"
+ "reference": "e3c46cc5689c8782944274bb30702106ecbe3b64"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/4b842fc4b61609e0a155a114082bd94e31e98287",
- "reference": "4b842fc4b61609e0a155a114082bd94e31e98287",
+ "url": "https://api.github.com/repos/symfony/process/zipball/e3c46cc5689c8782944274bb30702106ecbe3b64",
+ "reference": "e3c46cc5689c8782944274bb30702106ecbe3b64",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2023-04-18T13:50:24+00:00",
+ "time": "2023-05-17T11:26:05+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1897,7 +1901,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.23"
+ "source": "https://github.com/symfony/process/tree/v5.4.24"
},
"funding": [
{
diff --git a/makesrc.sh b/makesrc.sh
index a9ba49b..e03115a 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -20,7 +20,7 @@ else
git checkout $COMMIT || exit1
cp composer.json ../
- composer config platform.php 7.4
+ composer config platform.php 7.4.99
composer install --no-interaction --no-progress --no-dev --optimize-autoloader
cp vendor/composer/installed.json ../
popd
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 3d87926..bd5776d 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 3f0ed862f22386c55a767461ef5083bddceeed79
+%global gh_commit b123395c9fa3a70801f816f13606c0f3a7ada8df
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.17.0
+Version: 3.18.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -57,13 +57,13 @@ Provides: bundled(php-composer-pcre) = 3.1.0
Provides: bundled(php-composer-semver) = 3.3.2
Provides: bundled(php-composer-xdebug-handler) = 3.0.3
Provides: bundled(php-doctrine-annotations) = 2.0.1
-Provides: bundled(php-doctrine-deprecations) = v1.0.0
+Provides: bundled(php-doctrine-deprecations) = v1.1.1
Provides: bundled(php-doctrine-lexer) = 2.1.0
Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.1.2
Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 1.1.4
-Provides: bundled(php-symfony-console) = v5.4.23
+Provides: bundled(php-symfony-console) = v5.4.24
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
Provides: bundled(php-symfony-event-dispatcher) = v5.4.22
Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.2
@@ -77,7 +77,7 @@ Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
Provides: bundled(php-symfony-polyfill-php73) = v1.27.0
Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
-Provides: bundled(php-symfony-process) = v5.4.23
+Provides: bundled(php-symfony-process) = v5.4.24
Provides: bundled(php-symfony-service-contracts) = v2.5.2
Provides: bundled(php-symfony-stopwatch) = v5.4.21
Provides: bundled(php-symfony-string) = v5.4.22
@@ -155,6 +155,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Tue Jun 20 2023 Remi Collet <remi@remirepo.net> - 3.18.0-1
+- update to 3.18.0
+
* Wed May 24 2023 Remi Collet <remi@remirepo.net> - 3.17.0-1
- update to 3.17.0