summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-02-17 07:38:28 +0100
committerRemi Collet <remi@php.net>2025-02-17 07:38:28 +0100
commit03729f37869b8724a4b6486d21d8289fb4e65bc4 (patch)
tree64c6ce5d3cda49a57db80d79060e3aa808ea22cf
parent75e4962a16f58b36ccfff9d4c495602bd82b0565 (diff)
update to 3.69.0
-rw-r--r--composer.json16
-rwxr-xr-xmakesrc.sh5
-rw-r--r--php-cs-fixer.spec13
3 files changed, 22 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index a3f667e..cf6fd66 100644
--- a/composer.json
+++ b/composer.json
@@ -33,7 +33,7 @@
"react/promise": "^2.0 || ^3.0",
"react/socket": "^1.0",
"react/stream": "^1.0",
- "sebastian/diff": "^4.0 || ^5.1 || ^6.0",
+ "sebastian/diff": "^4.0 || ^5.1 || ^6.0 || ^7.0",
"symfony/console": "^5.4 || ^6.4 || ^7.0",
"symfony/event-dispatcher": "^5.4 || ^6.4 || ^7.0",
"symfony/filesystem": "^5.4 || ^6.4 || ^7.0",
@@ -46,18 +46,18 @@
"symfony/stopwatch": "^5.4 || ^6.4 || ^7.0"
},
"require-dev": {
- "facile-it/paraunit": "^1.3.1 || ^2.4",
- "infection/infection": "^0.29.8",
+ "facile-it/paraunit": "^1.3.1 || ^2.5",
+ "infection/infection": "^0.29.10",
"justinrainbow/json-schema": "^5.3 || ^6.0",
"keradus/cli-executor": "^2.1",
"mikey179/vfsstream": "^1.6.12",
"php-coveralls/php-coveralls": "^2.7",
"php-cs-fixer/accessible-object": "^1.1",
- "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.5",
- "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.5",
- "phpunit/phpunit": "^9.6.22 || ^10.5.40 || ^11.5.2",
- "symfony/var-dumper": "^5.4.48 || ^6.4.15 || ^7.2.0",
- "symfony/yaml": "^5.4.45 || ^6.4.13 || ^7.2.0"
+ "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.6",
+ "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.6",
+ "phpunit/phpunit": "^9.6.22 || ^10.5.45 || ^11.5.7",
+ "symfony/var-dumper": "^5.4.48 || ^6.4.18 || ^7.2.0",
+ "symfony/yaml": "^5.4.45 || ^6.4.18 || ^7.2.0"
},
"suggest": {
"ext-dom": "For handling output formats in XML",
diff --git a/makesrc.sh b/makesrc.sh
index 55c46fd..69295c8 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -24,7 +24,10 @@ else
cp composer.json ../
composer config platform.php 8.1.99
- composer install --no-interaction --no-progress --no-dev --optimize-autoloader
+ # see https://github.com/PHP-CS-Fixer/PHP-CS-Fixer/blob/master/dev-tools/build.sh
+ # some dev dep cannot be satisfied but are not needed
+ composer remove --dev infection/infection --no-update
+ composer install --no-interaction --no-progress --no-dev --no-scripts --optimize-autoloader
cp vendor/composer/installed.json ../
popd
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 27eab59..3cc8a54 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -11,14 +11,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 7bedb718b633355272428c60736dc97fb96daf27
+%global gh_commit 630a59448c00729bc235d5e95cfedefeaca37523
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 2025-01-30
+%global gh_date 2025-02-14
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.68.5
+Version: 3.69.0
Release: 1%{?dist}
Summary: PHP Coding Standards Fixer
@@ -70,6 +70,9 @@ projects. This tool does not only detect them, but also fixes them for you.
%setup -q -n %{gh_project}-%{gh_commit}
%patch -P0 -p1 -b .rpm
+# Fix version
+sed -e '/VERSION/s/3.68.6-DEV/%{version}/' -i src/Console/Application.php
+
%build
# Empty build section, most likely nothing required.
@@ -87,6 +90,7 @@ install -Dpm755 %{name} %{buildroot}%{_bindir}/%{name}
%check
sed -e 's:%{_datadir}:%{buildroot}%{_datadir}:' -i %{name}
+PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version
PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
@@ -100,6 +104,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Mon Feb 17 2025 Remi Collet <remi@remirepo.net> - 3.69.0-1
+- update to 3.69.0
+
* Fri Jan 31 2025 Remi Collet <remi@remirepo.net> - 3.68.5-1
- update to 3.68.5