summaryrefslogtreecommitdiffstats
path: root/php-componere.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-02-01 11:20:30 +0100
committerRemi Collet <remi@remirepo.net>2019-02-01 11:20:30 +0100
commit5a7190c571efb34b4dda81724318070d2a65579c (patch)
tree49501478d25592dcac91d7976e63aa8d73698572 /php-componere.spec
parentda26f242b167029e5fcdb37a3be74b88a453053e (diff)
update to 3.0.0
raise dependency on PHP 7.1
Diffstat (limited to 'php-componere.spec')
-rw-r--r--php-componere.spec39
1 files changed, 10 insertions, 29 deletions
diff --git a/php-componere.spec b/php-componere.spec
index 216901c..8c2d9a5 100644
--- a/php-componere.spec
+++ b/php-componere.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-componere
#
-# Copyright (c) 2018 Remi Collet
+# Copyright (c) 2018-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -12,33 +12,20 @@
%{?scl: %scl_package php-componere}
-%global gh_commit 2939a4149c27229844a3b29a3d336a3e8a14ac9a
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner krakjoe
-%global gh_project componere
-#global gh_date 20160608
%global pecl_name componere
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
Summary: Composing PHP classes at runtime
Name: %{?scl_prefix}php-componere
-Version: 2.1.3
-%if 0%{?gh_date:1}
-Release: 3%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%endif
+Version: 3.0.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://github.com/%{gh_owner}/%{gh_project}
-%if 0%{?gh_date:1}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-%else
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-%endif
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-devel > 7.1
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -55,16 +42,10 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-Obsoletes: php70u-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
Obsoletes: php71u-%{pecl_name} <= %{version}
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-%{pecl_name} <= %{version}
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
@@ -99,11 +80,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
-%if 0%{?gh_date:1}
-mv %{gh_project}-%{gh_commit} NTS
-%else
mv %{pecl_name}-%{version} NTS
-%endif
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
@@ -113,8 +90,8 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
# Sanity check, really often broken
extver=$(sed -n '/define PHP_COMPONERE_VERSION/{s/.* "//;s/".*$//;p}' php_componere.h)
-if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?gh_date:-dev}.
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
exit 1
fi
cd ..
@@ -218,6 +195,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Feb 1 2019 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- update to 3.0.0
+- raise dependency on PHP 7.1
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 2.1.3-3
- rebuild for 7.3.0beta2 new ABI