summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-28 15:49:59 +0100
committerRemi Collet <remi@remirepo.net>2018-02-28 15:49:59 +0100
commit8b5e1ccca72b2fe7f2ee1cb57544782132f3e4ff (patch)
tree351d7f7f097f5203bdd6366b6f480b5cdd8049f1
parenta27f9ff39cf2dd8cea75549efeaefc4482b9f2e3 (diff)
v2.0.0
-rw-r--r--REFLECTION128
-rw-r--r--php-componere.spec11
2 files changed, 127 insertions, 12 deletions
diff --git a/REFLECTION b/REFLECTION
index eae14f3..1278da4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,7 +1,7 @@
-Extension [ <persistent> extension #79 componere version 1.3.0 ] {
+Extension [ <persistent> extension #79 componere version 2.0.0 ] {
- - Classes [3] {
- Class [ <internal:componere> class Componere\Definition ] {
+ - Classes [5] {
+ Class [ <internal:componere> abstract class Componere\Abstract\Definition ] {
- Constants [0] {
}
@@ -15,10 +15,7 @@ Extension [ <persistent> extension #79 componere version 1.3.0 ] {
- Properties [0] {
}
- - Methods [8] {
- Method [ <internal:componere, ctor> public method __construct ] {
- }
-
+ - Methods [3] {
Method [ <internal:componere> public method addMethod ] {
- Parameters [2] {
@@ -34,6 +31,33 @@ Extension [ <persistent> extension #79 componere version 1.3.0 ] {
}
}
+ Method [ <internal:componere> public method addInterface ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $interface ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:componere> class Componere\Definition extends Componere\Abstract\Definition ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [9] {
+ Method [ <internal:componere, ctor> public method __construct ] {
+ }
+
Method [ <internal:componere> public method addProperty ] {
- Parameters [2] {
@@ -50,12 +74,67 @@ Extension [ <persistent> extension #79 componere version 1.3.0 ] {
}
}
+ Method [ <internal:componere> public method getClosure ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:componere> public method getClosures ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:componere> public method register ] {
- Parameters [0] {
}
}
+ Method [ <internal:componere, inherits Componere\Abstract\Definition> public method addMethod ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> Componere\Method $method ]
+ }
+ }
+
+ Method [ <internal:componere, inherits Componere\Abstract\Definition> public method addTrait ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $trait ]
+ }
+ }
+
+ Method [ <internal:componere, inherits Componere\Abstract\Definition> public method addInterface ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $interface ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:componere> class Componere\Patch extends Componere\Abstract\Definition ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [8] {
+ Method [ <internal:componere, ctor> public method __construct ] {
+ }
+
Method [ <internal:componere> public method getClosure ] {
- Parameters [1] {
@@ -65,8 +144,41 @@ Extension [ <persistent> extension #79 componere version 1.3.0 ] {
Method [ <internal:componere> public method getClosures ] {
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:componere> public method apply ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:componere> public method revert ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:componere, inherits Componere\Abstract\Definition> public method addMethod ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> Componere\Method $method ]
+ }
+ }
+
+ Method [ <internal:componere, inherits Componere\Abstract\Definition> public method addTrait ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $trait ]
+ }
+ }
+
+ Method [ <internal:componere, inherits Componere\Abstract\Definition> public method addInterface ] {
+
- Parameters [1] {
- Parameter #0 [ <optional> $scope ]
+ Parameter #0 [ <required> $interface ]
}
}
}
diff --git a/php-componere.spec b/php-componere.spec
index 2e92b38..02306bc 100644
--- a/php-componere.spec
+++ b/php-componere.spec
@@ -12,7 +12,7 @@
%{?scl: %scl_package php-componere}
-%global gh_commit 9653769e4be011f86627461b4ae75f90fc42d324
+%global gh_commit 758a01d438d7062139fa57ae315c7f55fe4759a6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner krakjoe
%global gh_project componere
@@ -21,11 +21,11 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-Summary: Class composition at runtime
+Summary: Composing PHP classes at runtime
Name: %{?scl_prefix}php-componere
-Version: 1.3.0
+Version: 2.0.0
%if 0%{?gh_date:1}
-Release: 0.3.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
@@ -176,6 +176,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Feb 28 2018 Remi Collet <remi@remirepo.net> - 2.0.0-1
+- Update to 2.0.0
+
* Tue Feb 27 2018 Remi Collet <remi@remirepo.net> - 1.3.0-1
- new package, version 1.3.0 +2 commits:
fix build warnings + add LICENSE file