summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-03-02 16:03:11 +0100
committerRemi Collet <remi@remirepo.net>2018-03-02 16:03:11 +0100
commit5cbbd2cc24147b792f7559ff1a6c2e8db5bd7fe6 (patch)
tree0be8c416a673bd6a3a6a268040adb7d4339107ed
parent32bf1591c0f9c5b23b6837d085c887b1a6040032 (diff)
v2.1.0
-rw-r--r--REFLECTION66
-rw-r--r--php-componere.spec8
2 files changed, 65 insertions, 9 deletions
diff --git a/REFLECTION b/REFLECTION
index 041ae0e..39f593f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,8 @@
-Extension [ <persistent> extension #79 componere version 2.0.1 ] {
+Extension [ <persistent> extension #79 componere version 2.1.0 ] {
+
+ - Dependencies {
+ Dependency [ reflection (Required) ]
+ }
- Classes [5] {
Class [ <internal:componere> abstract final class Componere\Abstract\Definition ] {
@@ -15,7 +19,7 @@ Extension [ <persistent> extension #79 componere version 2.0.1 ] {
- Properties [0] {
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:componere> public method addMethod ] {
- Parameters [2] {
@@ -37,6 +41,12 @@ Extension [ <persistent> extension #79 componere version 2.0.1 ] {
Parameter #0 [ <required> $interface ]
}
}
+
+ Method [ <internal:componere> public method getReflector ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -54,7 +64,7 @@ Extension [ <persistent> extension #79 componere version 2.0.1 ] {
- Properties [0] {
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:componere, ctor> public method __construct ] {
}
@@ -120,6 +130,12 @@ Extension [ <persistent> extension #79 componere version 2.0.1 ] {
Parameter #0 [ <required> $interface ]
}
}
+
+ Method [ <internal:componere, inherits Componere\Abstract\Definition> public method getReflector ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -137,7 +153,7 @@ Extension [ <persistent> extension #79 componere version 2.0.1 ] {
- Properties [0] {
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:componere, ctor> public method __construct ] {
}
@@ -193,6 +209,12 @@ Extension [ <persistent> extension #79 componere version 2.0.1 ] {
Parameter #0 [ <required> $interface ]
}
}
+
+ Method [ <internal:componere, inherits Componere\Abstract\Definition> public method getReflector ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -210,7 +232,7 @@ Extension [ <persistent> extension #79 componere version 2.0.1 ] {
- Properties [0] {
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:componere, ctor> public method __construct ] {
- Parameters [1] {
@@ -235,6 +257,12 @@ Extension [ <persistent> extension #79 componere version 2.0.1 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:componere> public method getReflector ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -252,11 +280,11 @@ Extension [ <persistent> extension #79 componere version 2.0.1 ] {
- Properties [0] {
}
- - Methods [4] {
+ - Methods [8] {
Method [ <internal:componere, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <required> $value ]
+ Parameter #0 [ <optional> $value ]
}
}
@@ -277,6 +305,30 @@ Extension [ <persistent> extension #79 componere version 2.0.1 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:componere> public method isProtected ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:componere> public method isPrivate ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:componere> public method isStatic ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:componere> public method hasDefault ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
}
diff --git a/php-componere.spec b/php-componere.spec
index 6ed5dc6..e288e81 100644
--- a/php-componere.spec
+++ b/php-componere.spec
@@ -12,7 +12,7 @@
%{?scl: %scl_package php-componere}
-%global gh_commit cc328c6d0e1d9d89c1fc214a050ca3ca8f850451
+%global gh_commit 94df694367126f942da2dfe8fc006b06e766f7ed
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner krakjoe
%global gh_project componere
@@ -23,7 +23,7 @@
Summary: Composing PHP classes at runtime
Name: %{?scl_prefix}php-componere
-Version: 2.0.1
+Version: 2.1.0
%if 0%{?gh_date:1}
Release: 1%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -33,6 +33,7 @@ License: PHP
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -176,6 +177,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Mar 2 2018 Remi Collet <remi@remirepo.net> - 2.1.0-1
+- Update to 2.1.0
+
* Thu Mar 1 2018 Remi Collet <remi@remirepo.net> - 2.0.1-1
- Update to 2.0.1