summaryrefslogtreecommitdiffstats
path: root/php-cakephp.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-cakephp.spec')
-rw-r--r--php-cakephp.spec16
1 files changed, 14 insertions, 2 deletions
diff --git a/php-cakephp.spec b/php-cakephp.spec
index 24a5804..1f40c22 100644
--- a/php-cakephp.spec
+++ b/php-cakephp.spec
@@ -8,7 +8,7 @@
#
# https://github.com/cakephp/cakephp/releases
-%global gh_commit e6a6342dd238ea0eed656808262cfc02ef44a0f2
+%global gh_commit 2687a47f7f339a66ccc77dff9f9f8eab6fd8fc1d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner cakephp
%global gh_project cakephp
@@ -23,7 +23,7 @@
%global chronos_version 1.3.0
Name: php-%{pk_vendor}
-Version: 3.8.12
+Version: 3.9.0
Release: 1%{?dist}
Summary: The CakePHP framework
@@ -65,6 +65,7 @@ BuildRequires: php-aura-intl >= 3.0.0
BuildRequires: php-PsrLog >= 1.0.0
BuildRequires: php-zendframework-zend-diactoros >= 1.4.0
%endif
+BuildRequires: php-paragonie-random-compat
%endif
@@ -279,6 +280,7 @@ Summary: CakePHP Utility Classes
# "cakephp/core": "^3.6.0"
Requires: php(language) >= 5.6
Requires: php-composer(%{pk_vendor}/core) = %{version}
+Requires: php-paragonie-random-compat
# From phpcompatinfo report
Requires: php-simplexml
Requires: php-ctype
@@ -331,6 +333,7 @@ require_once '%{php_home}/Fedora/Autoloader/autoload.php';
'%{php_home}/Psr/Log/autoload.php',
'%{php_home}/Psr/SimpleCache/autoload.php',
'%{php_home}/Zend/Diactoros/autoload.php',
+ '%{php_home}/random_compat/autoload.php',
]);
EOF
@@ -426,6 +429,7 @@ require_once '%{php_home}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Dependencies::required([
dirname(__DIR__) . '/Core/autoload.php',
__DIR__ . '/bootstrap.php',
+ '%{php_home}/random_compat/autoload.php',
]);
EOF
@@ -482,7 +486,11 @@ exit (class_exists("Cake\\Utility\\Hash") ? 0 : 1);
: Run upstream test suites
ret=0
phpunit tests/TestCase/Cache --verbose || ret=1
+%if 0%{?rhel} == 6 || 0%{?rhel} == 7
+: skip for missing laminas used in Http component
+%else
phpunit tests/TestCase/Core --verbose || ret=1
+%endif
phpunit tests/TestCase/Collection --verbose || ret=1
%if 0%{?rhel} == 6
: skip suite as sqlite is too old
@@ -583,6 +591,10 @@ exit $ret
%changelog
+* Mon Jun 22 2020 Remi Collet <remi@remirepo.net> - 3.9.0-1
+- update to 3.9.0
+- add dependency on paragonie/random_compat
+
* Fri May 8 2020 Remi Collet <remi@remirepo.net> - 3.8.12-1
- update to 3.8.12