summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-cakephp.spec7
2 files changed, 8 insertions, 3 deletions
diff --git a/composer.json b/composer.json
index 47e15a5..12543c7 100644
--- a/composer.json
+++ b/composer.json
@@ -98,6 +98,8 @@
"cs-check": "phpcs --colors --parallel=16 -p src/ tests/",
"cs-fix": "phpcbf --colors --parallel=16 -p src/ tests/",
"test": "phpunit",
- "test-coverage": "phpunit --coverage-clover=clover.xml"
+ "test-coverage": "phpunit --coverage-clover=clover.xml",
+ "phpstan": "phpstan analyse -c phpstan.neon -l 2 src/",
+ "phpstan-setup": "cp composer.json composer.backup && composer require --dev phpstan/phpstan-shim:^0.11 && mv composer.backup composer.json"
}
}
diff --git a/php-cakephp.spec b/php-cakephp.spec
index eca1549..6a9ae49 100644
--- a/php-cakephp.spec
+++ b/php-cakephp.spec
@@ -8,7 +8,7 @@
#
# https://github.com/cakephp/cakephp/releases
-%global gh_commit ea64434740f0d2a53438f95a3de414de63a11101
+%global gh_commit 34833a0c02fc1fc21e27ceb69cf7b4f7c131a3cc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner cakephp
%global gh_project cakephp
@@ -23,7 +23,7 @@
%global chronos_version 1.2.8
Name: php-%{pk_vendor}
-Version: 3.8.5
+Version: 3.8.6
Release: 1%{?dist}
Summary: The CakePHP framework
@@ -582,6 +582,9 @@ exit $ret
%changelog
+* Thu Nov 7 2019 Remi Collet <remi@remirepo.net> - 3.8.6-1
+- update to 3.8.6
+
* Mon Oct 7 2019 Remi Collet <remi@remirepo.net> - 3.8.5-1
- update to 3.8.5