summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-21 08:32:36 +0200
committerRemi Collet <remi@remirepo.net>2021-06-21 08:32:36 +0200
commit8cb07b8b7aabe1192da7dd5f8531d50f148c6046 (patch)
tree86154e62072fcaa6cd8324fb97d5f097abaa5446
parentf0d545615c6c37f388d4da728fefb4ebe5934447 (diff)
update to 3.10.0
-rw-r--r--php-cakephp.spec10
-rw-r--r--src/Console/composer.json42
-rw-r--r--src/Http/composer.json49
3 files changed, 99 insertions, 2 deletions
diff --git a/php-cakephp.spec b/php-cakephp.spec
index b5f82bc..a21d1a7 100644
--- a/php-cakephp.spec
+++ b/php-cakephp.spec
@@ -8,7 +8,7 @@
#
# https://github.com/cakephp/cakephp/releases
-%global gh_commit 6d7e57a5bedf59bd55f36627bc3b9ab6235df5e9
+%global gh_commit 084963bd27984e50174fadcbdee91048112231a0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner cakephp
%global gh_project cakephp
@@ -23,7 +23,7 @@
%global chronos_version 1.3.0
Name: php-%{pk_vendor}
-Version: 3.9.9
+Version: 3.10.0
Release: 1%{?dist}
Summary: The CakePHP framework
@@ -591,6 +591,12 @@ exit $ret
%changelog
+* Mon Jun 21 2021 Remi Collet <remi@remirepo.net> - 3.10.0-1
+- update to 3.10.0
+
+* Mon May 31 2021 Remi Collet <remi@remirepo.net> - 3.9.10-1
+- update to 3.9.10
+
* Wed Apr 28 2021 Remi Collet <remi@remirepo.net> - 3.9.9-1
- update to 3.9.9
diff --git a/src/Console/composer.json b/src/Console/composer.json
new file mode 100644
index 0000000..971d9a6
--- /dev/null
+++ b/src/Console/composer.json
@@ -0,0 +1,42 @@
+{
+ "name": "cakephp/console",
+ "description": "Build beautiful console applications with CakePHP",
+ "type": "library",
+ "keywords": [
+ "cakephp",
+ "console",
+ "cli",
+ "framework"
+ ],
+ "homepage": "https://cakephp.org",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "CakePHP Community",
+ "homepage": "https://github.com/cakephp/cache/graphs/contributors"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/cakephp/cakephp/issues",
+ "forum": "https://stackoverflow.com/tags/cakephp",
+ "irc": "irc://irc.freenode.org/cakephp",
+ "source": "https://github.com/cakephp/console"
+ },
+ "require": {
+ "php": ">=7.2.0",
+ "cakephp/core": "^4.0",
+ "cakephp/event": "^4.0",
+ "cakephp/filesystem": "^4.0",
+ "cakephp/log": "^4.0",
+ "cakephp/utility": "^4.0"
+ },
+ "suggest": {
+ "cakephp/datasource": "To use the Shell or Command base classes",
+ "cakephp/orm": "To use the Shell or Command base classes"
+ },
+ "autoload": {
+ "psr-4": {
+ "Cake\\Console\\": "."
+ }
+ }
+}
diff --git a/src/Http/composer.json b/src/Http/composer.json
new file mode 100644
index 0000000..5802f3e
--- /dev/null
+++ b/src/Http/composer.json
@@ -0,0 +1,49 @@
+{
+ "name": "cakephp/http",
+ "description": "CakePHP HTTP client and PSR7/15 middleware libraries",
+ "type": "library",
+ "keywords": [
+ "cakephp",
+ "http",
+ "psr7",
+ "psr15"
+ ],
+ "homepage": "https://cakephp.org",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "CakePHP Community",
+ "homepage": "https://github.com/cakephp/http/graphs/contributors"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/cakephp/cakephp/issues",
+ "forum": "https://stackoverflow.com/tags/cakephp",
+ "irc": "irc://irc.freenode.org/cakephp",
+ "source": "https://github.com/cakephp/http"
+ },
+ "require": {
+ "php": ">=7.2.0",
+ "cakephp/core": "^4.0",
+ "cakephp/event": "^4.0",
+ "cakephp/utility": "^4.0",
+ "composer/ca-bundle": "^1.2",
+ "psr/http-client": "^1.0",
+ "psr/http-server-handler": "^1.0",
+ "psr/http-server-middleware": "^1.0",
+ "laminas/laminas-diactoros": "^2.1",
+ "laminas/laminas-httphandlerrunner": "^1.0"
+ },
+ "provide": {
+ "psr/http-client-implementation": "^1.0"
+ },
+ "suggest": {
+ "cakephp/cache": "To use cache session storage",
+ "cakephp/orm": "To use database session storage"
+ },
+ "autoload": {
+ "psr-4": {
+ "Cake\\Http\\": "."
+ }
+ }
+}