summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-11-27 10:19:59 +0100
committerRemi Collet <remi@remirepo.net>2018-11-27 10:19:59 +0100
commitf02bee9e79f207896bf448d3cf5ed17e58b40052 (patch)
tree25137d3287736db845b093a792551263c618c60d
parent2ea99209d9e25c49b855e3829d1cd9eaf5c61457 (diff)
update to 0.6.0, bundled libbrotli 1.0.7
open https://github.com/kjdev/php-ext-brotli/pull/14 fix version open https://github.com/kjdev/php-ext-brotli/pull/15 fix skip open https://github.com/kjdev/php-ext-brotli/pull/16 comment
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION11
-rw-r--r--php-brotli.spec28
3 files changed, 37 insertions, 8 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..45889dd
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,6 @@
+
+brotli
+
+Brotli support => enabled
+Extension Version => 0.6.0
+Library Version => 1.0.5
diff --git a/REFLECTION b/REFLECTION
index 6b38072..0ee7960 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,13 @@
-Extension [ <persistent> extension #77 brotli version 0.5.1 ] {
+Extension [ <persistent> extension #78 brotli version 0.6.0 ] {
+
+ - INI {
+ Entry [ brotli.output_compression <ALL> ]
+ Current = '0'
+ }
+ Entry [ brotli.output_compression_level <ALL> ]
+ Current = '-1'
+ }
+ }
- Constants [3] {
Constant [ integer BROTLI_GENERIC ] { 0 }
diff --git a/php-brotli.spec b/php-brotli.spec
index 2d3b672..c92384c 100644
--- a/php-brotli.spec
+++ b/php-brotli.spec
@@ -23,7 +23,7 @@
%global with_libbrotli 0
%endif
-%global gh_commit 1c275034502060b385a5abdc130538ec8499078e
+%global gh_commit f9289ba1d1b909f8fb148dfaf5cbfab691f734b1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner kjdev
%global gh_project php-ext-brotli
@@ -34,11 +34,11 @@
Summary: Brotli Extension for PHP
Name: %{?sub_prefix}php-%{pecl_name}
-Version: 0.5.1
+Version: 0.6.0
%if 0%{?gh_date:1}
-Release: 3%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: MIT
Group: Development/Languages
@@ -52,7 +52,7 @@ BuildRequires: %{?scl_prefix}php-devel
%if %{?with_libbrotli}
BuildRequires: brotli-devel >= 0.6.0
%else
-Provides: bundled(brotli) = 1.0.4
+Provides: bundled(brotli) = 1.0.7
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -109,8 +109,8 @@ mv brotli/LICENSE .
# Use the system library
mv brotli tests
%else
-# See https://github.com/kjdev/php-ext-brotli/pull/9
-sed -e '/BROTLI_LIB_VERSION/s/1.0.1/1.0.4/' -i config.m4
+# See https://github.com/kjdev/php-ext-brotli/pull/14
+sed -e '/BROTLI_LIB_VERSION/s/1.0.4/1.0.7/' -i config.m4
%endif
# Sanity check, really often broken
@@ -130,6 +130,10 @@ cp -pr NTS ZTS
cat << 'EOF' | tee %{ini_name}
; Enable '%{summary}' extension module
extension = %{pecl_name}.so
+
+; Configuration
+;brotli.output_compression = 0
+;brotli.output_compression_level = -1
EOF
@@ -198,6 +202,10 @@ REPORT_EXIT_STATUS=1 \
%if %{with_zts}
cd ../ZTS
+: Ignore CGI tests
+# see https://github.com/kjdev/php-ext-brotli/pull/15
+find tests -name \*phpt -exec grep -Eq -- '--(EXPECTHEADERS|GET|CGI)--' {} \; -delete -print
+
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
@@ -227,6 +235,12 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Nov 27 2018 Remi Collet <remi@remirepo.net> - 0.6.0-1
+- update to 0.6.0, bundled libbrotli 1.0.7
+- open https://github.com/kjdev/php-ext-brotli/pull/14 fix version
+- open https://github.com/kjdev/php-ext-brotli/pull/15 fix skip
+- open https://github.com/kjdev/php-ext-brotli/pull/16 comment
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 0.5.1-3
- rebuild for 7.3.0beta2 new ABI