summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-05 09:31:08 +0200
committerRemi Collet <remi@remirepo.net>2020-06-05 09:31:08 +0200
commit63866fb832f0d9fee58e31c259ce8c2c97f49e1e (patch)
treef71deacb5ac3e4596225845723429ece7582516c
parentdf044fa8a307b0a2fb8a2ad356985cb80fa87d22 (diff)
update to 0.8.0
drop patch merged upstream
-rw-r--r--23.patch68
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION14
-rw-r--r--php-brotli.spec20
4 files changed, 19 insertions, 87 deletions
diff --git a/23.patch b/23.patch
deleted file mode 100644
index 52af90b..0000000
--- a/23.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From ebd41e895b08445275bef0befeadb2eeba156835 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 24 Jul 2019 07:58:34 +0200
-Subject: [PATCH] fix for stream change in 7.4.0beta1
-
----
- brotli.c | 23 +++++++++++++++++++++--
- 1 file changed, 21 insertions(+), 2 deletions(-)
-
-diff --git a/brotli.c b/brotli.c
-index 891f706..87f8d2f 100644
---- a/brotli.c
-+++ b/brotli.c
-@@ -470,11 +470,19 @@ static int php_brotli_decompress_close(php_stream *stream,
- return EOF;
- }
-
-+#if PHP_VERSION_ID < 70400
- static size_t php_brotli_decompress_read(php_stream *stream,
- char *buf,
- size_t count TSRMLS_DC)
- {
- size_t ret = 0;
-+#else
-+static ssize_t php_brotli_decompress_read(php_stream *stream,
-+ char *buf,
-+ size_t count TSRMLS_DC)
-+{
-+ ssize_t ret = 0;
-+#endif
- STREAM_DATA_FROM_STREAM();
-
- /* input */
-@@ -485,7 +493,11 @@ static size_t php_brotli_decompress_read(php_stream *stream,
- if (input) {
- efree(input);
- }
-+#if PHP_VERSION_ID < 70400
- return 0;
-+#else
-+ return -1;
-+#endif
- }
- self->available_in = php_stream_read(self->stream, input,
- brotli_buffer_size );
-@@ -592,13 +604,20 @@ static int php_brotli_compress_close(php_stream *stream,
- return EOF;
- }
-
-+#if PHP_VERSION_ID < 70400
- static size_t php_brotli_compress_write(php_stream *stream,
- const char *buf,
- size_t count TSRMLS_DC)
- {
-- STREAM_DATA_FROM_STREAM();
--
- size_t ret = 0;
-+#else
-+static ssize_t php_brotli_compress_write(php_stream *stream,
-+ const char *buf,
-+ size_t count TSRMLS_DC)
-+{
-+ ssize_t ret = 0;
-+#endif
-+ STREAM_DATA_FROM_STREAM();
-
- size_t available_in = count;
- const uint8_t *next_in = (uint8_t *)buf;
diff --git a/PHPINFO b/PHPINFO
index 4507757..21bcffd 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
brotli
Brotli support => enabled
-Extension Version => 0.7.0
-Library Version => 1.0.5
+Extension Version => 0.8.0
+Library Version => 1.0.7
diff --git a/REFLECTION b/REFLECTION
index 4673319..9ba7aa7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #81 brotli version 0.7.0 ] {
+Extension [ <persistent> extension #114 brotli version 0.8.0 ] {
- INI {
Entry [ brotli.output_compression <ALL> ]
@@ -10,12 +10,12 @@ Extension [ <persistent> extension #81 brotli version 0.7.0 ] {
}
- Constants [6] {
- Constant [ integer BROTLI_GENERIC ] { 0 }
- Constant [ integer BROTLI_TEXT ] { 1 }
- Constant [ integer BROTLI_FONT ] { 2 }
- Constant [ integer BROTLI_COMPRESS_LEVEL_MIN ] { 0 }
- Constant [ integer BROTLI_COMPRESS_LEVEL_MAX ] { 11 }
- Constant [ integer BROTLI_COMPRESS_LEVEL_DEFAULT ] { 11 }
+ Constant [ int BROTLI_GENERIC ] { 0 }
+ Constant [ int BROTLI_TEXT ] { 1 }
+ Constant [ int BROTLI_FONT ] { 2 }
+ Constant [ int BROTLI_COMPRESS_LEVEL_MIN ] { 0 }
+ Constant [ int BROTLI_COMPRESS_LEVEL_MAX ] { 11 }
+ Constant [ int BROTLI_COMPRESS_LEVEL_DEFAULT ] { 11 }
}
- Functions {
diff --git a/php-brotli.spec b/php-brotli.spec
index d74b65e..2c10110 100644
--- a/php-brotli.spec
+++ b/php-brotli.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-brotli
#
-# Copyright (c) 2017-2019 Remi Collet
+# Copyright (c) 2017-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -17,13 +17,13 @@
%global pkg_name %{name}
%endif
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 7
%global with_libbrotli 1
%else
%global with_libbrotli 0
%endif
-%global gh_commit 942eadcd2d81db045a7721cfff37f070e54dfe66
+%global gh_commit f8ad32c46936bcc22c601d08f182e5029ad925db
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner kjdev
%global gh_project php-ext-brotli
@@ -34,11 +34,11 @@
Summary: Brotli Extension for PHP
Name: %{?sub_prefix}php-%{pecl_name}
-Version: 0.7.0
+Version: 0.8.0
%if 0%{?gh_date:1}
-Release: 3%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -46,8 +46,6 @@ Source0: %{pkg_name}-%{version}-%{gh_short}.tgz
# retrieve a recursive git snapshot with submodule
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/kjdev/php-ext-brotli/pull/23.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
%if %{?with_libbrotli}
@@ -97,8 +95,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{gh_project}-%{gh_commit} NTS
cd NTS
-%patch0 -p1
-
# replace symlink
rm LICENSE
mv brotli/LICENSE .
@@ -228,6 +224,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Jun 5 2020 Remi Collet <remi@remirepo.net> - 0.8.0-1
+- update to 0.8.0
+- drop patch merged upstream
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 0.7.0-4
- rebuild for 7.4.0RC1