summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-04 08:33:36 +0200
committerRemi Collet <remi@php.net>2023-08-04 08:33:36 +0200
commit41cfd07aed2864e65539da80da7c2ef430597511 (patch)
treede40700b09c34a38277f34f169571534763e51e2
parentf40dab69e0cd028c46c0b35ba115002eba65401a (diff)
update to 0.14.0
build out of sources tree sources from pecl
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION30
-rwxr-xr-xmakesrc.sh27
-rw-r--r--php-brotli.spec138
4 files changed, 76 insertions, 121 deletions
diff --git a/PHPINFO b/PHPINFO
index ea5dc86..ba8dac9 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
brotli
Brotli support => enabled
-Extension Version => 0.13.1
+Extension Version => 0.14.0
Library Version => 1.0.9
APCu serializer ABI => 0
diff --git a/REFLECTION b/REFLECTION
index 8d7ac7a..989778e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 brotli version 0.13.1 ] {
+Extension [ <persistent> extension #71 brotli version 0.14.0 ] {
- Dependencies {
Dependency [ apcu (Optional) ]
@@ -29,37 +29,37 @@ Extension [ <persistent> extension #119 brotli version 0.13.1 ] {
- Parameters [3] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $quality ]
- Parameter #2 [ <optional> $mode ]
+ Parameter #1 [ <optional> $quality = <default> ]
+ Parameter #2 [ <optional> $mode = <default> ]
}
}
Function [ <internal:brotli> function brotli_uncompress ] {
- Parameters [2] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $max ]
+ Parameter #1 [ <optional> $max = <default> ]
}
}
Function [ <internal:brotli> function Brotli\compress ] {
- Parameters [3] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $quality ]
- Parameter #2 [ <optional> $mode ]
+ Parameter #1 [ <optional> $quality = <default> ]
+ Parameter #2 [ <optional> $mode = <default> ]
}
}
Function [ <internal:brotli> function Brotli\uncompress ] {
- Parameters [2] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $max ]
+ Parameter #1 [ <optional> $max = <default> ]
}
}
Function [ <internal:brotli> function brotli_compress_init ] {
- Parameters [2] {
- Parameter #0 [ <optional> $quality ]
- Parameter #1 [ <optional> $mode ]
+ Parameter #0 [ <optional> $quality = <default> ]
+ Parameter #1 [ <optional> $mode = <default> ]
}
}
Function [ <internal:brotli> function brotli_compress_add ] {
@@ -67,7 +67,7 @@ Extension [ <persistent> extension #119 brotli version 0.13.1 ] {
- Parameters [3] {
Parameter #0 [ <required> $context ]
Parameter #1 [ <required> $data ]
- Parameter #2 [ <optional> $mode ]
+ Parameter #2 [ <optional> $mode = <default> ]
}
}
Function [ <internal:brotli> function brotli_uncompress_init ] {
@@ -80,14 +80,14 @@ Extension [ <persistent> extension #119 brotli version 0.13.1 ] {
- Parameters [3] {
Parameter #0 [ <required> $context ]
Parameter #1 [ <required> $data ]
- Parameter #2 [ <optional> $mode ]
+ Parameter #2 [ <optional> $mode = <default> ]
}
}
Function [ <internal:brotli> function Brotli\compress_init ] {
- Parameters [2] {
- Parameter #0 [ <optional> $quality ]
- Parameter #1 [ <optional> $mode ]
+ Parameter #0 [ <optional> $quality = <default> ]
+ Parameter #1 [ <optional> $mode = <default> ]
}
}
Function [ <internal:brotli> function Brotli\compress_add ] {
@@ -95,7 +95,7 @@ Extension [ <persistent> extension #119 brotli version 0.13.1 ] {
- Parameters [3] {
Parameter #0 [ <required> $context ]
Parameter #1 [ <required> $data ]
- Parameter #2 [ <optional> $mode ]
+ Parameter #2 [ <optional> $mode = <default> ]
}
}
Function [ <internal:brotli> function Brotli\uncompress_init ] {
@@ -108,7 +108,7 @@ Extension [ <persistent> extension #119 brotli version 0.13.1 ] {
- Parameters [3] {
Parameter #0 [ <required> $context ]
Parameter #1 [ <required> $data ]
- Parameter #2 [ <optional> $mode ]
+ Parameter #2 [ <optional> $mode = <default> ]
}
}
}
diff --git a/makesrc.sh b/makesrc.sh
deleted file mode 100755
index ea1e7e8..0000000
--- a/makesrc.sh
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/bash
-
-NAME=$(basename $PWD)
-OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
-PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
-VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
-COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
-SHORT=${COMMIT:0:7}
-
-echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
-
-echo "Cloning..."
-rm -rf $PROJECT-$COMMIT
-git clone --recursive https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
-
-echo "Getting commit..."
-pushd $PROJECT-$COMMIT
-git checkout $COMMIT
-popd
-
-echo "Archiving..."
-tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
-
-echo "Cleaning..."
-rm -rf $PROJECT-$COMMIT
-
-echo "Done."
diff --git a/php-brotli.spec b/php-brotli.spec
index 5f847f1..85371e1 100644
--- a/php-brotli.spec
+++ b/php-brotli.spec
@@ -1,62 +1,37 @@
# remirepo spec file for php-brotli
#
-# Copyright (c) 2017-2021 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2017-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
+%{?scl:%scl_package php-brotli}
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-brotli
-%else
-%global pkg_name %{name}
-%endif
-
-# To build with PHP 5.x use --without apcu
-%bcond_without apcu
-
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 7
+%bcond_without apcu
%bcond_without libbrotli
-%else
-%bcond_with libbrotli
-%endif
+%bcond_without tests
-%global gh_commit c17297688a6c7d23be33f170405f099aa7cd0d38
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner kjdev
-%global gh_project php-ext-brotli
-#global gh_date 20160608
%global pecl_name brotli
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: Brotli Extension for PHP
-Name: %{?sub_prefix}php-%{pecl_name}
-Version: 0.13.1
-%if 0%{?gh_date:1}
-Release: 2%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%else
+Name: %{?scl_prefix}php-%{pecl_name}
+Version: 0.14.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%endif
License: MIT
-URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: %{pkg_name}-%{version}-%{gh_short}.tgz
-# retrieve a recursive git snapshot with submodule
-Source1: makesrc.sh
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-%if %{with apcu}
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pecl-apcu-devel
-%else
-BuildRequires: %{?scl_prefix}php-devel
-%endif
+BuildRequires: %{?scl_prefix}php-pear
%if %{with libbrotli}
BuildRequires: brotli-devel >= 0.6.0
%else
@@ -65,39 +40,30 @@ Provides: bundled(brotli) = 1.0.9
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-%{pecl_name} <= %{version}
-%endif
-%endif
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%description
-This extension allows Brotli compression.
+PHP extension for compression and decompression with Brotli library.
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
%setup -qc
-mv %{gh_project}-%{gh_commit} NTS
-cd NTS
-# replace symlink
-rm LICENSE
-mv brotli/LICENSE .
+%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+cd %{sources}
%if %{with libbrotli}
# Use the system library
-mv brotli tests
+rm -r brotli
+sed -e '\:"brotli/:d' -i ../package.xml
+%else
+cp brotli/LICENSE LICENSE-brotli
%endif
# Sanity check, really often broken
@@ -108,9 +74,9 @@ if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
fi
cd ..
+mkdir NTS
%if %{with_zts}
-# duplicate for ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Drop in the bit of configuration
@@ -127,13 +93,12 @@ EOF
%build
%{?dtsenable}
-cd NTS
-%if %{with libbrotli}
-mv tests/brotli brotli
-%endif
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
- --with-php-config=%{_bindir}/php-config \
+ --with-php-config=%{__phpconfig} \
%if %{with libbrotli}
--with-libbrotli \
%endif
@@ -143,12 +108,8 @@ make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%if %{with libbrotli}
-mv tests/brotli brotli
-%endif
-%{_bindir}/zts-phpize
%configure \
- --with-php-config=%{_bindir}/zts-php-config \
+ --with-php-config=%{__ztsphpconfig} \
%if %{with libbrotli}
--with-libbrotli \
%endif
@@ -165,22 +126,32 @@ make %{?_smp_mflags}
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
%if %{with_zts}
# Install the ZTS stuff
make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
+# Documentation
+cd %{sources}
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
%check
-cd NTS
+cd %{sources}
+
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
-%if "%{php_version}" > "7.0"
+%if %{with apcu}
: Check that apcu is aware of brotli serializer
%{__php} --no-php-ini \
--define extension=apcu.so \
@@ -190,31 +161,37 @@ cd NTS
--ri apcu | grep '%{pecl_name}'
%endif
+%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php -q --offline --show-diff || : ignore
+%{__php} -n run-tests.php -q --offline --show-diff
+%endif
%if %{with_zts}
-cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
+%if %{with tests}
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php -q --offline --show-diff
%endif
+%endif
%files
-%{!?_licensedir:%global license %%doc}
-%license NTS/LICENSE
-%doc NTS/README.md
+%{?_licensedir:%license %{sources}/LICENSE}
+%if %{without libbrotli}
+%{?_licensedir:%license %{sources}/LICENSE-brotli}
+%endif
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
@@ -226,6 +203,11 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Aug 4 2023 Remi Collet <remi@remirepo.net> - 0.14.0-1
+- update to 0.14.0
+- build out of sources tree
+- sources from pecl
+
* Sat Jan 23 2021 Remi Collet <remi@remirepo.net> - 0.13.1-1
- update to 0.13.1