summaryrefslogtreecommitdiffstats
path: root/php-ast.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-ast.spec')
-rw-r--r--php-ast.spec10
1 files changed, 9 insertions, 1 deletions
diff --git a/php-ast.spec b/php-ast.spec
index b7a5ac8..492c092 100644
--- a/php-ast.spec
+++ b/php-ast.spec
@@ -24,7 +24,7 @@ Version: 1.0.8
%if 0%{?gh_date:1}
Release: 0.6.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -34,6 +34,8 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
%endif
+Patch0: https://patch-diff.githubusercontent.com/raw/nikic/php-ast/pull/174.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -103,6 +105,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1 -b .pr174
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_AST_VERSION/{s/.* "//;s/".*$//;p}' php_ast.h)
if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
@@ -231,6 +235,10 @@ fi
%changelog
+* Wed Sep 2 2020 Remi Collet <remi@remirepo.net> - 1.0.8-2
+- add patch for 8.0.0beta3 from
+ https://github.com/nikic/php-ast/pull/174
+
* Thu Aug 6 2020 Remi Collet <remi@remirepo.net> - 1.0.8-1
- update to 1.0.8