summaryrefslogtreecommitdiffstats
path: root/php-ast.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-ast.spec')
-rw-r--r--php-ast.spec10
1 files changed, 6 insertions, 4 deletions
diff --git a/php-ast.spec b/php-ast.spec
index 7f730a9..2a8d7d6 100644
--- a/php-ast.spec
+++ b/php-ast.spec
@@ -80,19 +80,21 @@ EOF
cd %{sources}
%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
%configure \
--with-php-config=%{__phpconfig} \
--enable-ast
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
%configure \
--with-php-config=%{__ztsphpconfig} \
--enable-ast
-make %{?_smp_mflags}
+%make_build
%endif
@@ -103,12 +105,12 @@ make %{?_smp_mflags}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
# Install the NTS stuff
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
# Install the ZTS stuff
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif