summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-08-05 06:16:17 +0200
committerRemi Collet <fedora@famillecollet.com>2016-08-05 06:16:17 +0200
commitd1344dbf540bf99e15250ce7a6687f741cbeeee9 (patch)
treeb447bb1bb96bac147e864966d33c618e3c346255
parent0a471daaf34c1c91e6d2ad621e3f35a0c4a05b9a (diff)
php-ast: switch the spec
-rw-r--r--php-ast-dev.spec191
-rw-r--r--php-ast.spec24
2 files changed, 13 insertions, 202 deletions
diff --git a/php-ast-dev.spec b/php-ast-dev.spec
deleted file mode 100644
index 2521709..0000000
--- a/php-ast-dev.spec
+++ /dev/null
@@ -1,191 +0,0 @@
-# remirepo spec file for php-ast
-#
-# Copyright (c) 2015-2016 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%{?scl: %scl_package php-ast}
-
-%global gh_commit b8f5805b17c43c664dda62d1f401a7d3379be9f3
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner nikic
-%global gh_project php-ast
-%global gh_date 20160608
-%global pecl_name ast
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-# After 20-tokenizer.ini
-%global ini_name 40-%{pecl_name}.ini
-
-Summary: Abstract Syntax Tree
-Name: %{?scl_prefix}php-ast
-Version: 0.1.2
-%if 0%{?gh_date:1}
-Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%endif
-License: PHP
-Group: Development/Languages
-URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-BuildRequires: %{?scl_prefix}php-devel > 7
-BuildRequires: %{?scl_prefix}php-tokenizer
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-Requires: %{?scl_prefix}php-tokenizer%{?_isa}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
-Obsoletes: php70u-%{pecl_name} <= %{version}
-Obsoletes: php70w-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-%{pecl_name} <= %{version}
-Obsoletes: php71w-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-This extension exposes the abstract syntax tree generated by PHP 7.
-
-This extension is experimental and the representation of the syntax tree is not final.
-
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
-
-%prep
-%setup -qc
-mv %{gh_project}-%{gh_commit} NTS
-
-cd NTS
-
-# When this file is removed, fix description
-[ -f EXPERIMENTAL ] || exit 1
-
-# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_AST_VERSION/{s/.* "//;s/".*$//;p}' php_ast.h)
-if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?gh_date:-dev}.
- exit 1
-fi
-cd ..
-
-%if %{with_zts}
-# duplicate for ZTS build
-cp -pr NTS ZTS
-%endif
-
-# Drop in the bit of configuration
-cat << 'EOF' | tee %{ini_name}
-; Enable '%{summary}' extension module
-extension = %{pecl_name}.so
-EOF
-
-
-%build
-cd NTS
-%{_bindir}/phpize
-%configure \
- --with-php-config=%{_bindir}/php-config \
- --enable-ast
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-%configure \
- --with-php-config=%{_bindir}/zts-php-config \
- --enable-ast
-make %{?_smp_mflags}
-%endif
-
-
-%install
-rm -rf %{buildroot}
-# Install the NTS stuff
-make -C NTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-%if %{with_zts}
-# Install the ZTS stuff
-make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-
-
-%check
-cd NTS
-: Minimal load test for NTS extension
-%{__php} --no-php-ini \
- --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension=tokenizer.so -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff || : ignore
-
-%if %{with_zts}
-cd ../ZTS
-: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=tokenizer.so -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%{!?_licensedir:%global license %%doc}
-%license NTS/LICENSE
-%doc NTS/EXPERIMENTAL
-%doc NTS/README.md
-%doc NTS/scripts
-%doc NTS/util.php
-
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
-
-%changelog
-* Fri Jun 10 2016 Remi Collet <remi@fedoraproject.org> - 0.1.2-0.1.20160608gitb8f5805
-- update to 0.1.2-dev for PHP 7.1
-
-* Thu Jan 7 2016 Remi Collet <remi@fedoraproject.org> - 0.1.1-1
-- update to 0.1.1
-
-* Thu Oct 29 2015 Remi Collet <remi@fedoraproject.org> - 0.1.0-0.2.20151021gitac969d7
-- add dependency on php-tokenizer, fix test suite
-
-* Wed Oct 28 2015 Remi Collet <remi@fedoraproject.org> - 0.1.0-0.1.20151021gitac969d7
-- new package, version 0.1.0dev
diff --git a/php-ast.spec b/php-ast.spec
index e8ad683..2521709 100644
--- a/php-ast.spec
+++ b/php-ast.spec
@@ -7,14 +7,12 @@
# Please, preserve the changelog entries
#
%{?scl: %scl_package php-ast}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__php: %global __php %{_bindir}/php}
-%global gh_commit 3b9abc7b6012d760de99e10edc99c9742dafd11a
+%global gh_commit b8f5805b17c43c664dda62d1f401a7d3379be9f3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nikic
%global gh_project php-ast
-#global gh_date 20151021
+%global gh_date 20160608
%global pecl_name ast
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
# After 20-tokenizer.ini
@@ -22,9 +20,9 @@
Summary: Abstract Syntax Tree
Name: %{?scl_prefix}php-ast
-Version: 0.1.1
+Version: 0.1.2
%if 0%{?gh_date:1}
-Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
@@ -45,6 +43,10 @@ Requires: %{?scl_prefix}php-tokenizer%{?_isa}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
Obsoletes: php70u-%{pecl_name} <= %{version}
Obsoletes: php70w-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-%{pecl_name} <= %{version}
+Obsoletes: php71w-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -71,9 +73,6 @@ cd NTS
# When this file is removed, fix description
[ -f EXPERIMENTAL ] || exit 1
-# Fix
-sed -e '/PHP_AST_VERSION/s/0.1.0/0.1.0-dev/' -i php_ast.h
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_AST_VERSION/{s/.* "//;s/".*$//;p}' php_ast.h)
if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
@@ -166,7 +165,7 @@ rm -rf %{buildroot}
%license NTS/LICENSE
%doc NTS/EXPERIMENTAL
%doc NTS/README.md
-%doc NTS/generate_ast_data.php
+%doc NTS/scripts
%doc NTS/util.php
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -179,6 +178,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Jun 10 2016 Remi Collet <remi@fedoraproject.org> - 0.1.2-0.1.20160608gitb8f5805
+- update to 0.1.2-dev for PHP 7.1
+
* Thu Jan 7 2016 Remi Collet <remi@fedoraproject.org> - 0.1.1-1
- update to 0.1.1
@@ -186,4 +188,4 @@ rm -rf %{buildroot}
- add dependency on php-tokenizer, fix test suite
* Wed Oct 28 2015 Remi Collet <remi@fedoraproject.org> - 0.1.0-0.1.20151021gitac969d7
-- new package, version 0.1.0dev \ No newline at end of file
+- new package, version 0.1.0dev