summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-09 07:27:56 +0200
committerRemi Collet <remi@remirepo.net>2017-10-09 07:27:56 +0200
commit8b5e641548f4cfbc155ee14e04305eb0d0ad5f03 (patch)
treef8abf5cd4e69655dcf3c6662d337d4105333f6a2
parent6229d64acd9badfbc4fbdcd86a63d1d9fc4e8421 (diff)
v0.1.6
-rw-r--r--REFLECTION37
-rw-r--r--php-ast.spec5
2 files changed, 39 insertions, 3 deletions
diff --git a/REFLECTION b/REFLECTION
index 9989ed9..119516a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #75 ast version 0.1.5 ] {
+Extension [ <persistent> extension #75 ast version 0.1.6 ] {
- Constants [190] {
Constant [ integer ast\AST_ARG_LIST ] { 128 }
@@ -221,9 +221,20 @@ Extension [ <persistent> extension #75 ast version 0.1.5 ] {
Parameter #0 [ <required> $kind ]
}
}
+ Function [ <internal:ast> function ast\get_metadata ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:ast> function ast\get_supported_versions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $exclude_deprecated ]
+ }
+ }
}
- - Classes [2] {
+ - Classes [3] {
Class [ <internal:ast> class ast\Node ] {
- Constants [0] {
@@ -288,6 +299,28 @@ Extension [ <persistent> extension #75 ast version 0.1.5 ] {
}
}
}
+
+ Class [ <internal:ast> class ast\Metadata ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> public $kind ]
+ Property [ <default> public $name ]
+ Property [ <default> public $flags ]
+ Property [ <default> public $flagsCombinable ]
+ }
+
+ - Methods [0] {
+ }
+ }
}
}
diff --git a/php-ast.spec b/php-ast.spec
index 92616ac..d12ab55 100644
--- a/php-ast.spec
+++ b/php-ast.spec
@@ -20,7 +20,7 @@
Summary: Abstract Syntax Tree
Name: %{?scl_prefix}php-ast
-Version: 0.1.5
+Version: 0.1.6
%if 0%{?gh_date:1}
Release: 0.3.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -210,6 +210,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Oct 9 2017 Remi Collet <remi@remirepo.net> - 0.1.6-1
+- Update to 0.1.6
+
* Tue Aug 1 2017 Remi Collet <remi@remirepo.net> - 0.1.5-1
- update to 0.1.5 (stable)
- sources from PECL