summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-13 08:11:17 +0200
committerRemi Collet <remi@remirepo.net>2020-09-13 08:11:17 +0200
commit54702d3a097cb007cc9b985c2a827fa4e40a666c (patch)
treec6fbe6542870670645717455651a48ded025dd7f
parent35c24923242603723ad99809fceb775523e97cc2 (diff)
v1.0.10
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION33
-rw-r--r--php-ast.spec5
3 files changed, 26 insertions, 16 deletions
diff --git a/PHPINFO b/PHPINFO
index 03d3fe2..2b43af8 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
ast
ast support => enabled
-extension version => 1.0.9
-AST version => Current version is 70. All versions (including experimental): {50, 60, 70, 80}
+extension version => 1.0.10
+AST version => Current version is 80. All versions (including experimental): {50, 60, 70, 80}
diff --git a/REFLECTION b/REFLECTION
index 9ca77f0..9d31195 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #71 ast version 1.0.9 ] {
+Extension [ <persistent> extension #71 ast version 1.0.10 ] {
- - Constants [192] {
+ - Constants [193] {
Constant [ int ast\AST_ARG_LIST ] { 128 }
Constant [ int ast\AST_LIST ] { 255 }
Constant [ int ast\AST_ARRAY ] { 129 }
@@ -20,6 +20,7 @@ Extension [ <persistent> extension #71 ast version 1.0.9 ] {
Constant [ int ast\AST_USE ] { 143 }
Constant [ int ast\AST_TYPE_UNION ] { 254 }
Constant [ int ast\AST_ATTRIBUTE_LIST ] { 253 }
+ Constant [ int ast\AST_ATTRIBUTE_GROUP ] { 251 }
Constant [ int ast\AST_MATCH_ARM_LIST ] { 252 }
Constant [ int ast\AST_NAME ] { 2048 }
Constant [ int ast\AST_CLOSURE_VAR ] { 2049 }
@@ -199,40 +200,46 @@ Extension [ <persistent> extension #71 ast version 1.0.9 ] {
Function [ <internal:ast> function ast\parse_file ] {
- Parameters [2] {
- Parameter #0 [ <required> $filename ]
- Parameter #1 [ <required> $version ]
+ Parameter #0 [ <required> string $filename ]
+ Parameter #1 [ <required> int $version ]
}
+ - Return [ ast\Node ]
}
Function [ <internal:ast> function ast\parse_code ] {
- Parameters [3] {
- Parameter #0 [ <required> $code ]
- Parameter #1 [ <required> $version ]
- Parameter #2 [ <optional> $filename ]
+ Parameter #0 [ <required> string $code ]
+ Parameter #1 [ <required> int $version ]
+ Parameter #2 [ <optional> string $filename ]
}
+ - Return [ ast\Node ]
}
Function [ <internal:ast> function ast\get_kind_name ] {
- Parameters [1] {
- Parameter #0 [ <required> $kind ]
+ Parameter #0 [ <required> int $kind ]
}
+ - Return [ string ]
}
Function [ <internal:ast> function ast\kind_uses_flags ] {
- Parameters [1] {
- Parameter #0 [ <required> $kind ]
+ Parameter #0 [ <required> int $kind ]
}
+ - Return [ bool ]
}
Function [ <internal:ast> function ast\get_metadata ] {
- Parameters [0] {
}
+ - Return [ array ]
}
Function [ <internal:ast> function ast\get_supported_versions ] {
- Parameters [1] {
- Parameter #0 [ <optional> $exclude_deprecated ]
+ Parameter #0 [ <optional> bool $exclude_deprecated ]
}
+ - Return [ array ]
}
}
@@ -259,10 +266,10 @@ Extension [ <persistent> extension #71 ast version 1.0.9 ] {
Method [ <internal:ast, ctor> public method __construct ] {
- Parameters [4] {
- Parameter #0 [ <optional> $kind ]
- Parameter #1 [ <optional> $flags ]
+ Parameter #0 [ <optional> int or NULL $kind ]
+ Parameter #1 [ <optional> int or NULL $flags ]
Parameter #2 [ <optional> array or NULL $children ]
- Parameter #3 [ <optional> $lineno ]
+ Parameter #3 [ <optional> int or NULL $lineno ]
}
}
}
diff --git a/php-ast.spec b/php-ast.spec
index c82bda4..e2d9dfd 100644
--- a/php-ast.spec
+++ b/php-ast.spec
@@ -20,7 +20,7 @@
Summary: Abstract Syntax Tree
Name: %{?scl_prefix}php-ast
-Version: 1.0.9
+Version: 1.0.10
%if 0%{?gh_date:1}
Release: 0.6.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -225,6 +225,9 @@ fi
%changelog
+* Sun Sep 13 2020 Remi Collet <remi@remirepo.net> - 1.0.10-1
+- update to 1.0.10
+
* Fri Sep 4 2020 Remi Collet <remi@remirepo.net> - 1.0.9-1
- update to 1.0.9
- drop patch merged upstream