summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-08-12 08:44:45 +0200
committerRemi Collet <remi@php.net>2024-08-12 08:44:45 +0200
commit182f8fd60b232604765c5b41ab088767b2f141b3 (patch)
treef06db3298baa1adbb9249bfb771fa03a7bef9162
parent0c1ab5343d6c2e735b7c338c2bb5be2978c67315 (diff)
update to 1.1.2
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION8
-rw-r--r--php-ast.spec34
3 files changed, 15 insertions, 31 deletions
diff --git a/PHPINFO b/PHPINFO
index 5d01301..dcc20d5 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
ast
ast support => enabled
-extension version => 1.1.1
-AST version => Current version is 90. All versions (including experimental): {50, 60, 70, 80, 85, 90, 100}
+extension version => 1.1.2
+AST version => Current version is 110. All versions (including experimental): {50, 60, 70, 80, 85, 90, 100, 110}
diff --git a/REFLECTION b/REFLECTION
index 5f26948..dbc52b8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #69 ast version 1.1.1 ] {
+Extension [ <persistent> extension #65 ast version 1.1.2 ] {
- - Constants [203] {
+ - Constants [205] {
Constant [ int ast\AST_ARG_LIST ] { 128 }
Constant [ int ast\AST_LIST ] { 255 }
Constant [ int ast\AST_ARRAY ] { 129 }
@@ -31,6 +31,7 @@ Extension [ <persistent> extension #69 ast version 1.1.1 ] {
Constant [ int ast\AST_METHOD ] { 69 }
Constant [ int ast\AST_ARROW_FUNC ] { 71 }
Constant [ int ast\AST_CLASS ] { 70 }
+ Constant [ int ast\AST_PROPERTY_HOOK ] { 127 }
Constant [ int ast\AST_MAGIC_CONST ] { 0 }
Constant [ int ast\AST_TYPE ] { 1 }
Constant [ int ast\AST_CALLABLE_CONVERT ] { 3 }
@@ -63,6 +64,7 @@ Extension [ <persistent> extension #69 ast version 1.1.1 ] {
Constant [ int ast\AST_BREAK ] { 286 }
Constant [ int ast\AST_CONTINUE ] { 287 }
Constant [ int ast\AST_CLASS_NAME ] { 276 }
+ Constant [ int ast\AST_PROPERTY_HOOK_SHORT_BODY ] { 510 }
Constant [ int ast\AST_CLASS_CONST_GROUP ] { 546 }
Constant [ int ast\AST_DIM ] { 512 }
Constant [ int ast\AST_PROP ] { 513 }
@@ -133,7 +135,7 @@ Extension [ <persistent> extension #69 ast version 1.1.1 ] {
Constant [ int ast\flags\CLASS_INTERFACE ] { 1 }
Constant [ int ast\flags\CLASS_ANONYMOUS ] { 4 }
Constant [ int ast\flags\CLASS_ENUM ] { 268435456 }
- Constant [ int ast\flags\CLASS_READONLY ] { 8388608 }
+ Constant [ int ast\flags\CLASS_READONLY ] { 65536 }
Constant [ int ast\flags\PARAM_REF ] { 8 }
Constant [ int ast\flags\PARAM_VARIADIC ] { 16 }
Constant [ int ast\flags\TYPE_NULL ] { 1 }
diff --git a/php-ast.spec b/php-ast.spec
index 9945621..7f730a9 100644
--- a/php-ast.spec
+++ b/php-ast.spec
@@ -1,12 +1,12 @@
# remirepo spec file for php-ast
#
-# Copyright (c) 2015-2023 Remi Collet
+# Copyright (c) 2015-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%{?scl: %scl_package php-ast}
+%{?scl:%scl_package php-ast}
%global pecl_name ast
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -17,7 +17,7 @@
Summary: Abstract Syntax Tree
Name: %{?scl_prefix}php-ast
-Version: 1.1.1
+Version: 1.1.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD-3-Clause
URL: https://pecl.php.net/package/ast
@@ -32,7 +32,6 @@ BuildRequires: %{?scl_prefix}php-tokenizer
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-tokenizer%{?_isa}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
# PECL
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
@@ -52,7 +51,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
cd %{sources}
@@ -149,28 +148,8 @@ TEST_PHP_ARGS="-n -d extension=tokenizer.so -d extension=%{buildroot}%{php_ztsex
%endif
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%files
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -184,6 +163,9 @@ fi
%changelog
+* Mon Aug 12 2024 Remi Collet <remi@remirepo.net> - 1.1.2-1
+- update to 1.1.2
+
* Mon Nov 13 2023 Remi Collet <remi@remirepo.net> - 1.1.1-1
- update to 1.1.1