summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-07 18:09:42 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-07 18:09:42 +0100
commit07d2109a87b5c94dde012cbd51132cb05a8385fc (patch)
tree1b877c20aa7fc53d54d8d741e0eb29f3b774cde5
parentad9aed7ff91c130c94e1634fef1c657691ca685d (diff)
php-ast: 0.1.1
-rw-r--r--REFLECTION15
-rw-r--r--php-ast.spec11
2 files changed, 19 insertions, 7 deletions
diff --git a/REFLECTION b/REFLECTION
index aa0f5ab..9174895 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #74 ast version 0.1.0-dev ] {
+Extension [ <persistent> extension #56 ast version 0.1.1 ] {
- - Constants [169] {
+ - Constants [180] {
Constant [ integer ast\AST_FUNC_DECL ] { 66 }
Constant [ integer ast\AST_CLOSURE ] { 67 }
Constant [ integer ast\AST_METHOD ] { 68 }
@@ -170,6 +170,17 @@ Extension [ <persistent> extension #74 ast version 0.1.0-dev ] {
Constant [ integer ast\flags\EXEC_INCLUDE_ONCE ] { 4 }
Constant [ integer ast\flags\EXEC_REQUIRE ] { 8 }
Constant [ integer ast\flags\EXEC_REQUIRE_ONCE ] { 16 }
+ Constant [ integer ast\flags\USE_NORMAL ] { 361 }
+ Constant [ integer ast\flags\USE_FUNCTION ] { 346 }
+ Constant [ integer ast\flags\USE_CONST ] { 347 }
+ Constant [ integer ast\flags\MAGIC_LINE ] { 370 }
+ Constant [ integer ast\flags\MAGIC_FILE ] { 371 }
+ Constant [ integer ast\flags\MAGIC_DIR ] { 372 }
+ Constant [ integer ast\flags\MAGIC_NAMESPACE ] { 389 }
+ Constant [ integer ast\flags\MAGIC_FUNCTION ] { 376 }
+ Constant [ integer ast\flags\MAGIC_METHOD ] { 375 }
+ Constant [ integer ast\flags\MAGIC_CLASS ] { 373 }
+ Constant [ integer ast\flags\MAGIC_TRAIT ] { 374 }
}
- Functions {
diff --git a/php-ast.spec b/php-ast.spec
index 4d6d34d..e8ad683 100644
--- a/php-ast.spec
+++ b/php-ast.spec
@@ -10,11 +10,11 @@
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__php: %global __php %{_bindir}/php}
-%global gh_commit ac969d783a2cd33bca5b75ec647900f3abe23da3
+%global gh_commit 3b9abc7b6012d760de99e10edc99c9742dafd11a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nikic
%global gh_project php-ast
-%global gh_date 20151021
+#global gh_date 20151021
%global pecl_name ast
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
# After 20-tokenizer.ini
@@ -22,7 +22,7 @@
Summary: Abstract Syntax Tree
Name: %{?scl_prefix}php-ast
-Version: 0.1.0
+Version: 0.1.1
%if 0%{?gh_date:1}
Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -43,11 +43,9 @@ Requires: %{?scl_prefix}php-tokenizer%{?_isa}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
-%if "%{php_version}" > "7.0"
Obsoletes: php70u-%{pecl_name} <= %{version}
Obsoletes: php70w-%{pecl_name} <= %{version}
%endif
-%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
# Filter shared private
@@ -181,6 +179,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Jan 7 2016 Remi Collet <remi@fedoraproject.org> - 0.1.1-1
+- update to 0.1.1
+
* Thu Oct 29 2015 Remi Collet <remi@fedoraproject.org> - 0.1.0-0.2.20151021gitac969d7
- add dependency on php-tokenizer, fix test suite