summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-13 07:17:22 +0100
committerRemi Collet <remi@php.net>2023-11-13 07:17:22 +0100
commit0c1ab5343d6c2e735b7c338c2bb5be2978c67315 (patch)
tree471483491db8fd91d89171bd520f8a3df3dc9e5a
parente2fdb5fd3c78e18d4103b744925807650cc3c9cb (diff)
update to 1.1.1HEADmaster
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION34
-rw-r--r--php-ast.spec19
3 files changed, 24 insertions, 33 deletions
diff --git a/PHPINFO b/PHPINFO
index 7654cbd..5d01301 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
ast
ast support => enabled
-extension version => 1.1.0
-AST version => Current version is 90. All versions (including experimental): {50, 60, 70, 80, 85, 90}
+extension version => 1.1.1
+AST version => Current version is 90. All versions (including experimental): {50, 60, 70, 80, 85, 90, 100}
diff --git a/REFLECTION b/REFLECTION
index c0e17ca..5f26948 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #69 ast version 1.1.0 ] {
+Extension [ <persistent> extension #69 ast version 1.1.1 ] {
- Constants [203] {
Constant [ int ast\AST_ARG_LIST ] { 128 }
@@ -19,10 +19,10 @@ Extension [ <persistent> extension #69 ast version 1.1.0 ] {
Constant [ int ast\AST_TRAIT_ADAPTATIONS ] { 142 }
Constant [ int ast\AST_USE ] { 143 }
Constant [ int ast\AST_TYPE_UNION ] { 144 }
- Constant [ int ast\AST_TYPE_INTERSECTION ] { 250 }
- Constant [ int ast\AST_ATTRIBUTE_LIST ] { 145 }
- Constant [ int ast\AST_ATTRIBUTE_GROUP ] { 146 }
- Constant [ int ast\AST_MATCH_ARM_LIST ] { 147 }
+ Constant [ int ast\AST_TYPE_INTERSECTION ] { 145 }
+ Constant [ int ast\AST_ATTRIBUTE_LIST ] { 146 }
+ Constant [ int ast\AST_ATTRIBUTE_GROUP ] { 147 }
+ Constant [ int ast\AST_MATCH_ARM_LIST ] { 148 }
Constant [ int ast\AST_NAME ] { 2048 }
Constant [ int ast\AST_CLOSURE_VAR ] { 2049 }
Constant [ int ast\AST_NULLABLE_TYPE ] { 2050 }
@@ -107,7 +107,7 @@ Extension [ <persistent> extension #69 ast version 1.1.0 ] {
Constant [ int ast\AST_CATCH ] { 773 }
Constant [ int ast\AST_FOR ] { 1024 }
Constant [ int ast\AST_FOREACH ] { 1025 }
- Constant [ int ast\AST_ENUM_CASE ] { 1022 }
+ Constant [ int ast\AST_ENUM_CASE ] { 1026 }
Constant [ int ast\AST_PARAM ] { 1280 }
Constant [ int ast\flags\NAME_FQ ] { 0 }
Constant [ int ast\flags\NAME_NOT_FQ ] { 1 }
@@ -132,14 +132,14 @@ Extension [ <persistent> extension #69 ast version 1.1.0 ] {
Constant [ int ast\flags\CLASS_TRAIT ] { 2 }
Constant [ int ast\flags\CLASS_INTERFACE ] { 1 }
Constant [ int ast\flags\CLASS_ANONYMOUS ] { 4 }
- Constant [ int ast\flags\CLASS_ENUM ] { 4194304 }
+ Constant [ int ast\flags\CLASS_ENUM ] { 268435456 }
Constant [ int ast\flags\CLASS_READONLY ] { 8388608 }
Constant [ int ast\flags\PARAM_REF ] { 8 }
Constant [ int ast\flags\PARAM_VARIADIC ] { 16 }
Constant [ int ast\flags\TYPE_NULL ] { 1 }
Constant [ int ast\flags\TYPE_FALSE ] { 2 }
Constant [ int ast\flags\TYPE_TRUE ] { 3 }
- Constant [ int ast\flags\TYPE_BOOL ] { 17 }
+ Constant [ int ast\flags\TYPE_BOOL ] { 18 }
Constant [ int ast\flags\TYPE_LONG ] { 4 }
Constant [ int ast\flags\TYPE_DOUBLE ] { 5 }
Constant [ int ast\flags\TYPE_STRING ] { 6 }
@@ -150,7 +150,7 @@ Extension [ <persistent> extension #69 ast version 1.1.0 ] {
Constant [ int ast\flags\TYPE_ITERABLE ] { 13 }
Constant [ int ast\flags\TYPE_STATIC ] { 15 }
Constant [ int ast\flags\TYPE_MIXED ] { 16 }
- Constant [ int ast\flags\TYPE_NEVER ] { 22 }
+ Constant [ int ast\flags\TYPE_NEVER ] { 17 }
Constant [ int ast\flags\UNARY_BOOL_NOT ] { 14 }
Constant [ int ast\flags\UNARY_BITWISE_NOT ] { 13 }
Constant [ int ast\flags\UNARY_SILENCE ] { 260 }
@@ -189,14 +189,14 @@ Extension [ <persistent> extension #69 ast version 1.1.0 ] {
Constant [ int ast\flags\USE_NORMAL ] { 1 }
Constant [ int ast\flags\USE_FUNCTION ] { 2 }
Constant [ int ast\flags\USE_CONST ] { 4 }
- Constant [ int ast\flags\MAGIC_LINE ] { 375 }
- Constant [ int ast\flags\MAGIC_FILE ] { 376 }
- Constant [ int ast\flags\MAGIC_DIR ] { 377 }
- Constant [ int ast\flags\MAGIC_NAMESPACE ] { 382 }
- Constant [ int ast\flags\MAGIC_FUNCTION ] { 381 }
- Constant [ int ast\flags\MAGIC_METHOD ] { 380 }
- Constant [ int ast\flags\MAGIC_CLASS ] { 378 }
- Constant [ int ast\flags\MAGIC_TRAIT ] { 379 }
+ Constant [ int ast\flags\MAGIC_LINE ] { 343 }
+ Constant [ int ast\flags\MAGIC_FILE ] { 344 }
+ Constant [ int ast\flags\MAGIC_DIR ] { 345 }
+ Constant [ int ast\flags\MAGIC_NAMESPACE ] { 350 }
+ Constant [ int ast\flags\MAGIC_FUNCTION ] { 349 }
+ Constant [ int ast\flags\MAGIC_METHOD ] { 348 }
+ Constant [ int ast\flags\MAGIC_CLASS ] { 346 }
+ Constant [ int ast\flags\MAGIC_TRAIT ] { 347 }
Constant [ int ast\flags\ARRAY_SYNTAX_LIST ] { 1 }
Constant [ int ast\flags\ARRAY_SYNTAX_LONG ] { 2 }
Constant [ int ast\flags\ARRAY_SYNTAX_SHORT ] { 3 }
diff --git a/php-ast.spec b/php-ast.spec
index 6314b2f..9945621 100644
--- a/php-ast.spec
+++ b/php-ast.spec
@@ -8,12 +8,6 @@
#
%{?scl: %scl_package php-ast}
-# Defined in Fedora >= 37 and RHEL >= 10, in PHP >= 7.4 for remirepo
-%{!?__phpize: %global __phpize %{_bindir}/phpize}
-%{!?__ztsphpize: %global __ztsphpize %{_bindir}/zts-phpize}
-%{!?__phpconfig: %global __phpconfig %{_bindir}/php-config}
-%{!?__ztsphpconfig:%global __ztsphpconfig %{_bindir}/zts-php-config}
-
%global pecl_name ast
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
# After 20-tokenizer.ini
@@ -23,8 +17,8 @@
Summary: Abstract Syntax Tree
Name: %{?scl_prefix}php-ast
-Version: 1.1.0
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.1.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD-3-Clause
URL: https://pecl.php.net/package/ast
Source0: http://pecl.php.net/get/%{sources}.tgz
@@ -133,12 +127,6 @@ OPT="-P -q --show-diff"
if [ $VER -ge 70400 ]; then
OPT="$OPT %{?_smp_mflags}"
fi
-if [ $VER -ge 80300 ]; then
- rm tests/attributes_02.phpt
- rm tests/class_consts_80.phpt
- rm tests/php81_enums.phpt
- rm tests/php81_final_class_const.phpt
-fi
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -196,6 +184,9 @@ fi
%changelog
+* Mon Nov 13 2023 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1
+
* Mon Oct 2 2023 Remi Collet <remi@remirepo.net> - 1.1.0-4
- ignore 4 test failing with 8.3