summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json56
-rwxr-xr-xphp-amqplib-get-source.sh73
-rw-r--r--php-amqplib.spec159
3 files changed, 288 insertions, 0 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..cc8ae63
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,56 @@
+{
+ "name": "php-amqplib/php-amqplib",
+ "replace": {
+ "videlalvaro/php-amqplib": "self.version"
+ },
+ "type": "library",
+ "description": "Formerly videlalvaro/php-amqplib. This library is a pure PHP implementation of the AMQP protocol. It's been tested against RabbitMQ.",
+ "keywords": ["rabbitmq", "message", "queue"],
+ "homepage": "https://github.com/php-amqplib/php-amqplib/",
+ "authors": [
+ {
+ "name": "Alvaro Videla",
+ "role": "Original Maintainer"
+ },
+ {
+ "name": "John Kelly",
+ "email": "johnmkelly86@gmail.com",
+ "role": "Maintainer"
+ },
+ {
+ "name": "Raúl Araya",
+ "email": "nubeiro@gmail.com",
+ "role": "Maintainer"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.0",
+ "ext-bcmath": "*",
+ "ext-mbstring": "*"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^4.8",
+ "scrutinizer/ocular": "^1.1",
+ "squizlabs/php_codesniffer": "^2.5"
+ },
+ "suggest": {
+ "ext-sockets": "Use AMQPSocketConnection"
+ },
+ "autoload": {
+ "psr-4": {
+ "PhpAmqpLib\\": "PhpAmqpLib/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "PhpAmqpLib\\Tests\\Functional\\": "tests/Functional",
+ "PhpAmqpLib\\Tests\\Unit\\": "tests/Unit"
+ }
+ },
+ "license": "LGPL-2.1",
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.7-dev"
+ }
+ }
+}
diff --git a/php-amqplib-get-source.sh b/php-amqplib-get-source.sh
new file mode 100755
index 0000000..b2ac62b
--- /dev/null
+++ b/php-amqplib-get-source.sh
@@ -0,0 +1,73 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+if [ -x "$1" ]
+then
+ SPEC=$1
+else
+ SPEC=`ls *.spec | head -1`
+fi
+
+SPEC_DIR=`pwd`
+
+print "SPEC_DIR = $SPEC_DIR"
+
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '%global\s*github_version' $SPEC | awk '{print $3}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*github_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*github_name' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*github_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ TAR_FILE=${SPEC_DIR}/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+ chmod 0644 $TAR_FILE
+popd
+
+rm -rf $TEMP_DIR
diff --git a/php-amqplib.spec b/php-amqplib.spec
new file mode 100644
index 0000000..5373fc9
--- /dev/null
+++ b/php-amqplib.spec
@@ -0,0 +1,159 @@
+#
+# Fedora spec file for php-php-amqplib-php-amqplib
+#
+# Copyright (c) 2017 Shawn Iwinski <shawn@iwin.ski>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner php-amqplib
+%global github_name php-amqplib
+%global github_version 2.7.0
+%global github_commit f48748546e398d846134c594dfca9070c4c3b356
+
+%global composer_vendor php-amqplib
+%global composer_project php-amqplib
+
+# "php": ">=5.3.0"
+%global php_min_ver 5.3.0
+
+# Build using "--without tests" to disable tests
+%global with_tests 0%{!?_without_tests:1}
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+
+Name: %{composer_project}
+Version: %{github_version}
+Release: 2%{?github_release}%{?dist}
+Summary: Pure PHP implementation of the AMQP protocol
+
+Group: Development/Libraries
+License: LGPLv2
+URL: https://github.com/%{github_owner}/%{github_name}
+
+# GitHub export does not include tests.
+# Run php-php-amqplib-php-amqplib-get-source.sh to create full source.
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+## composer.json
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: php-bcmath
+BuildRequires: php-mbstring
+BuildRequires: php-sockets
+## phpcompatinfo for version 2.7.0
+BuildRequires: php-date
+BuildRequires: php-json
+BuildRequires: php-pcntl
+BuildRequires: php-pcre
+BuildRequires: php-reflection
+BuildRequires: php-spl
+## Autoloader
+BuildRequires: php-composer(fedora/autoloader)
+%endif
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+Requires: php-bcmath
+Requires: php-mbstring
+# composer.json: suggest
+Requires: php-sockets
+# phpcompatinfo for version 2.7.0
+Requires: php-date
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Weak dependencies
+%if 0%{?fedora} >= 21
+Suggests: php-pcntl
+%endif
+
+# Standard "php-{COMPOSER_VENDOR}-{COMPOSER_PROJECT}" naming
+Provides: php-%{composer_vendor}-%{composer_project} = %{version}-%{release}
+Provides: %{composer_vendor}-%{composer_project} = %{version}-%{release}
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
+%description
+This library is a pure PHP implementation of the AMQP 0-9-1 protocol [1]. It's
+been tested against RabbitMQ [2].
+
+Autoloader: %{phpdir}/PhpAmqpLib/autoload.php
+
+[1] http://www.rabbitmq.com/tutorials/amqp-concepts.html
+[2] http://www.rabbitmq.com/
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+
+%build
+: Create autoloader
+cat <<'AUTOLOAD' | tee PhpAmqpLib/autoload.php
+<?php
+/**
+ * Autoloader for %{name} and its' dependencies
+ * (created by %{name}-%{version}-%{release}).
+ */
+require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
+
+\Fedora\Autoloader\Autoload::addPsr4('PhpAmqpLib\\', __DIR__);
+AUTOLOAD
+
+
+%install
+mkdir -p %{buildroot}%{phpdir}
+cp -rp PhpAmqpLib %{buildroot}%{phpdir}/
+
+
+%check
+%if %{with_tests}
+: Create tests bootstrap
+cat <<'BOOTSTRAP' | tee bootstrap.php
+<?php
+date_default_timezone_set('UTC');
+require '%{buildroot}%{phpdir}/PhpAmqpLib/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('PhpAmqpLib\\Tests\\Unit\\', __DIR__.'/tests/Unit');
+BOOTSTRAP
+
+: Remove tests requiring a running AMQP service
+rm -f tests/Unit/Wire/IO/SocketIOTest.php
+
+: Upstream tests
+RETURN_CODE=0
+PHPUNIT=$(which phpunit)
+for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71 php72; do
+ if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
+ --testsuite="Unit Tests" || RETURN_CODE=1
+ fi
+done
+exit $RETURN_CODE
+%else
+: Tests skipped
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{phpdir}/PhpAmqpLib
+
+
+%changelog
+* Fri Nov 03 2017 Shawn Iwinski <shawn@iwin.ski> - 2.7.0-2
+- Set default timezone in tests' bootstrap
+
+* Wed Oct 25 2017 Shawn Iwinski <shawn@iwin.ski> - 2.7.0-1
+- Initial package