summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-05-16 15:56:35 +0200
committerRemi Collet <fedora@famillecollet.com>2013-05-16 15:56:35 +0200
commit53a971198d40d62388b0b803aadef98ea8cd54ba (patch)
tree47044052358d2223561331e8d4e8f672160200af
parent25e5cc8e553f5585772be2c1636f7fefcf4a4345 (diff)
php-SymfonyCmfRouting: 1.0.1 (backport)
-rw-r--r--php-SymfonyCmfRouting.spec36
1 files changed, 29 insertions, 7 deletions
diff --git a/php-SymfonyCmfRouting.spec b/php-SymfonyCmfRouting.spec
index d3da987..bfa258c 100644
--- a/php-SymfonyCmfRouting.spec
+++ b/php-SymfonyCmfRouting.spec
@@ -1,19 +1,21 @@
%global github_owner symfony-cmf
%global github_name Routing
-%global github_version 1.0.0
-%global github_commit 4706313dc7708633cfb1228c8b44e807aa44b6bf
-%global github_date 20130306
-
-%global github_release alpha4.%{github_date}git%(c=%{github_commit}; echo ${c:0:7})
+%global github_version 1.0.1
+%global github_commit a98a795555d4b9d456eecceb2654bb2590320303
+%global github_date 20130430
%global php_min_ver 5.3.2
%global symfony_min_ver 2.1.0
%global symfony_max_ver 2.3.0
+# Tests are only run with rpmbuild --with tests
+# Need to investigate errors
+%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+
Name: php-SymfonyCmfRouting
Version: %{github_version}
-Release: 0.3.%{github_release}%{?dist}
+Release: 1%{?dist}
Summary: Extends the Symfony2 routing component
Group: Development/Libraries
@@ -23,21 +25,27 @@ Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{githu
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
+%if %{with_tests}
# For tests
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
BuildRequires: php-pear(pear.symfony.com/Routing) >= %{symfony_min_ver}
BuildRequires: php-pear(pear.symfony.com/Routing) < %{symfony_max_ver}
+BuildRequires: php-pear(pear.symfony.com/HttpFoundation) >= %{symfony_min_ver}
+BuildRequires: php-pear(pear.symfony.com/HttpFoundation) < %{symfony_max_ver}
BuildRequires: php-pear(pear.symfony.com/HttpKernel) >= %{symfony_min_ver}
BuildRequires: php-pear(pear.symfony.com/HttpKernel) < %{symfony_max_ver}
# For tests: phpci
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
+%endif
Requires: php(language) >= %{php_min_ver}
Requires: php-pear(pear.symfony.com/Routing) >= %{symfony_min_ver}
Requires: php-pear(pear.symfony.com/Routing) < %{symfony_max_ver}
+Requires: php-pear(pear.symfony.com/HttpFoundation) >= %{symfony_min_ver}
+Requires: php-pear(pear.symfony.com/HttpFoundation) < %{symfony_max_ver}
Requires: php-pear(pear.symfony.com/HttpKernel) >= %{symfony_min_ver}
Requires: php-pear(pear.symfony.com/HttpKernel) < %{symfony_max_ver}
# phpci
@@ -96,9 +104,13 @@ cp -rp * %{buildroot}%{_datadir}/php/Symfony/Cmf/Component/Routing/
%check
+%if %{with_tests}
%{_bindir}/phpunit \
- -d include_path="%{buildroot}%{_datadir}/php:%{pear_phpdir}:%{_datadir}/php" \
+ -d include_path="%{buildroot}%{_datadir}/php:%{pear_phpdir}" \
-c phpunit.xml.dist
+%else
+: Tests skipped, missing '--with tests' option
+%endif
%files
@@ -110,11 +122,21 @@ cp -rp * %{buildroot}%{_datadir}/php/Symfony/Cmf/Component/Routing/
%exclude %{_datadir}/php/Symfony/Cmf/Component/Routing/LICENSE
%exclude %{_datadir}/php/Symfony/Cmf/Component/Routing/README.md
%exclude %{_datadir}/php/Symfony/Cmf/Component/Routing/composer.json
+%exclude %{_datadir}/php/Symfony/Cmf/Component/Routing/phpunit.xml.dist
%exclude %{_datadir}/php/Symfony/Cmf/Component/Routing/Test
%exclude %{_datadir}/php/Symfony/Cmf/Component/Routing/Tests
%changelog
+* Thu May 16 2013 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- backport 1.0.1 for remi repo.
+
+* Wed May 08 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0.1-1
+- Updated to version 1.0.1
+- Added php-pear(pear.symfony.com/HttpFoundation) require
+- Only run tests with "--with tests" option
+- Remove phpunit.xml.dist from packaging since tests themselves are not included
+
* Mon Mar 11 2013 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.3.alpha4.20130306git4706313
- backport for remi repo.